?
Solved

A: drive does not read disks

Posted on 2003-03-22
10
Medium Priority
?
276 Views
Last Modified: 2010-04-26
when i put my disk into a: drive the green light comes on and then a message pops up and says cannot read from specified device retry, cancel.

whats wrong with it?

cheers, nick.
0
Comment
Question by:hereisnick
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
10 Comments
 
LVL 1

Expert Comment

by:oakcrest
ID: 8188534
1. When is last time you used this drive?
2. Are the diskettes new, never used?
3. Has the cover been off the box since last drive usage? If so, what was done to system.

These will help guide me to suggestions.
0
 
LVL 4

Accepted Solution

by:
micro66 earned 100 total points
ID: 8188611
The drive may need cleaning, or it's out of alignment, or you have used a bad disk.  There are special disks to clean the drive.  Only use the proper cleaning disk (available online or at most computer stores) for the type of drive you have (for example, don't use a standard cleaning disk for an LS-120 A: drive).  If it's out of alignment, I don't think there's any easy way to realign nowadays.  Years ago there was software to test and align, but, if it's still around, it probably costs more than a new floppy drive ($10-15 at a computer show or via mail order).  If you've tried the diskette in someone else's drive and are sure it's good AND you've tried more than one disk in this drive (especially if they were formatted on more than one other computer), then those tests probably discount a bad disk.  The "tests" check to make sure that someone else's computer's drive isn't misaligned and formatted the disks or wrote the data in a way that can only be read by the drive that formatted and/or wrote the data.
0
 

Assisted Solution

by:NoviceScripter
NoviceScripter earned 100 total points
ID: 8188932
Yeah i had this problem once.........
And i tried everything but nothin works.
But when i replaced my floppy with a new drive, it works fine.
(some floppies can be defective and it's NOT your fault)
So bottom line.....change the floppy it's not expensive either.

Cheers
0
 [eBook] Windows Nano Server

Download this FREE eBook and learn all you need to get started with Windows Nano Server, including deployment options, remote management
and troubleshooting tips and tricks

 

Author Comment

by:hereisnick
ID: 8190316
re: oakcrest

last time i used it was around 3 days ago.
the diskette was one that id used before and had worked, ive tried others (none new).
nope havnt taken the cover off since last usage.

heres some more info:

when i click on the a drive icon with no disk inserted, the drive starts to try and load and then a message pops up and says "a: drive is not accessible the device is not ready..retry cancel"...i think this is a normal message right?

plus if i click on the icon once so it shows me how much memory is on the disk it does so.

But if i double click it makes no noise at all no loading noise or anything the light comes on and then after a few secs the message comes up.

how much does a floppy drive typically cost?
and same question about the cleaning disks?

my drive is a GENERIC NEC FLOPPY DISK
on the properties window for the drive it says no driver files are loaded or required for this device.....is this true?
0
 
LVL 4

Expert Comment

by:micro66
ID: 8190387
Online I've found the cleaning disk for US$3.00 and the floppy drive for as low as US$11.00 and as high as just over US$20.00.  At a computer show, floppy drives are typically under US$10.00 to about US$15.00.

True, you don't need separate drivers for a floppy.  It's inherent in most, if not all, operating systems.  What IS your operating system, by the way?
========================================
I found the following on the net, but I can't vouch for the validity of the info, in case you have Win98:

Does the drive work from DOS?

If it does, then this may help...
A number of people have reported that renaming or removing the file HSFLOP.PDR from their windows\system\iosubsys folder has solved their
problem with windows 98 not being able to access a floppy drive when DOS can.
You can then restore that file using the system file checker. Click start | run and key sfc.exe and click OK.
0
 

Author Comment

by:hereisnick
ID: 8190878
ok checked thru dos and it does the same thing.

i'll go and buy a disk cleaner for it tomorrow and let u guys know if it works. till tomorrow.......!!!
0
 

Author Comment

by:hereisnick
ID: 8190880
windows 98 by the way.
0
 
LVL 14

Expert Comment

by:FriarTuk
ID: 10630913
No comment has been added lately, so it's time to clean up this question.
I will leave the following recommendation for this question in the Cleanup topic area:

Split: micro66 {http:#8188611} & NoviceScripter {http:#8188932}

Please leave any comments here within the next four days.
PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER!

FriarTuk
EE Cleanup Volunteer
0

Featured Post

How Blockchain Is Impacting Every Industry

Blockchain expert Alex Tapscott talks to Acronis VP Frank Jablonski about this revolutionary technology and how it's making inroads into other industries and facets of everyday life.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Monitor input from a computer is usually nothing special.  In this instance it prevented anyone from using the computer.  This was a preconfiguration that didn't work.
Backups and Disaster RecoveryIn this post, we’ll look at strategies for backups and disaster recovery.
If you’ve ever visited a web page and noticed a cool font that you really liked the look of, but couldn’t figure out which font it was so that you could use it for your own work, then this video is for you! In this Micro Tutorial, you'll learn yo…
In this video you will find out how to export Office 365 mailboxes using the built in eDiscovery tool. Bear in mind that although this method might be useful in some cases, using PST files as Office 365 backup is troublesome in a long run (more on t…
Suggested Courses
Course of the Month13 days, 3 hours left to enroll

777 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question