• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1917
  • Last Modified:

System thinks AMD 2400 CPU is an 1800+ when i change BIOS Settings

I've recently put together a system which includes an ASUS A7N8X motherboard, an AMD 2400+ XP CPU at ~2000mhz, 512 MB DDR 2700 Micron RAM, an ASUS ti4200 V9820TD vid card. When I installed the sytem, the BIOS, Windows XP, directx 8.1, and system information, all saw the processor as an 1800+ at ~1492mhz. I've posted this question on this site and was told to flash my BIOS with the newst BIOS updates. I did and it seemed to fix the problem, everything recognized the 2400+ CPU.

But as soon as I make any changes in the BIOS setup utility, and save any of the cahnges I make, the system starts thinking it has an 1800+ cpu again, like it reverts back to the original settings. I flashed the BIOS again, it goes back to a 2400, but I can't make changes to the BIOS settings. In fact even change any of the settings in the BIOS, but still choose to save the current settings, it still reverts back to an 1800+. But if i don't click save changes it doesn't revert.

I have no clue what's going on, or even if this is a problem worth worrying about. Is it just saying that is the processor, is that the actuall performance that i'm getting. One individual also mentioned i should chance my front side bus speed to 166mhz, not 100 or 133, in order to fix the problem. But I can't find this in the BIOS utility, might it be caused by soemthing else?
0
prodier
Asked:
prodier
  • 7
  • 5
  • 4
  • +4
1 Solution
 
Jimbo99Commented:
Link to the other thread where you asked the question?  Sort of duplicitious to have us throw the same answers at you.
0
 
prodierAuthor Commented:
0
 
prodierAuthor Commented:
This is only fixed the problem temporarily, it seems not to be a permanent solution
0
Who's Defending Your Organization from Threats?

Protecting against advanced threats requires an IT dream team – a well-oiled machine of people and solutions working together to defend your organization. Download our resource kit today to learn more about the tools you need to build you IT Dream Team!

 
jwitt98Commented:
You need to change your front side bus to 133/266.  1492 MHZ x 1.33 = 1984 MHZ
0
 
Jimbo99Commented:
Check the jumper on your mobo to ensure that it isn't jumpered to 100mhz fsb.
0
 
prodierAuthor Commented:
Acording to my Mobo manual the only settings for the Central Processing Unit FSB (CPU_FSB) are 333/266 when pins 1-2 are set, and FSB 200 Only when pins 2-3 are set. I checked and pins 1-2 are set on my motherboard.

I'm not to sure that it's the FSB setting, because currently the BIOS reports that an AMD 2400 is installed, and Directx diagnostics and system info, concur they say the processor is a 2400 2000mhz cpu.

But, if i go and change any settings in the BIOS setup, it will revert back to an 1800 (~1492 mhz)
0
 
Howie_LyCommented:
A long shot, but have you checked your mainboard battery?

Set your system time, boot into windows.. shut it down.. power it up and see if it's lost time.

0
 
Jimbo99Commented:
Reflash your bios, then clear cmos, and try again.
0
 
azndragnz2kCommented:
have you tried going into device manager and updating the driver for your processor?  I did mines so when i overclocked my cpu it would always read at 2600+ instead of my original 2400+.
0
 
fracheCommented:
It's NOT necessary to flash your bios again ... during the boot you can see the bios version ... If the version is "ok", don't flash the bios again ...


Check if your motherboard version (revision) is compatible with this processor .
0
 
cassiohuiCommented:
should be either the mobo battery ran out, or you did not set the FSB correctly
0
 
prodierAuthor Commented:
Yeah, the BIOS versions are fine, the battery is good, I won't be reflashing it. I think I might have it, apparently in the BIOS setup, to set the FSB frequency, you have to set the 'External CPU Frequency'. It says to set it to 1/2 the FSB Frequency so i'll give this a try.
0
 
jwitt98Commented:
2400's are made to run at 133 mhz fsb.  DDR makes the actual data rate of the fsb 266.  That is why you have to set the fsb (or external CPU frequency) to 133/266.  Depending on your MB, this is either done in the bios (soft setup) or by a jumper on the mainboard. You should also pay attention to your clock multiplier.  133 times a multiplier of 15 will give you your ~2000 MHZ cpu speed.  If your motherboard and memory support it, you can set the fsb to 166/333, but you will have to use a lower multiplier to avoid overclocking and possibly damaging your cpu.  166 times a multiplier of 12 is ~2000 MHZ.
0
 
prodierAuthor Commented:
Okay, cool, so what should I set the memory frequency to?
0
 
jwitt98Commented:
It sounds like your motherboard has both jumpers and soft setup in which case you would have to set the jumper to 266/333 and then choose between one of the two fsb clock speeds (133/266 or 166/333) using the bios soft setup.
0
 
jwitt98Commented:
Generally, if your chips support it, you can set your dram clock to "by spd" (serial presence detect) and the system will automatically detect the correct dram clock speed.  Otherwise, you can set it to run at the highest speed your dram modules support.
0
 
prodierAuthor Commented:
One last question, what is the maximum speed a DDR 2700 chip supports (micron)
0
 
Jimbo99Commented:
It isn't an absolute Prodier.  It varies.  PC2700 is DDR 333.  166mhz X 2.

I have a suggestion.  What you may want to do is examine your cpu.  Look at the core.  Is it square or rectangular?

Then look at the lettering on the package.  Does it have a b or j in the code?  Something like "aiuhb" , or something like that.  Tell us the lettering.

This will tell us if it is a Thoroughbred B or A chip.  If it is square it is a Palamino core.  You won't make much progress, if any at all, if you put it at 166mhz fsb.

If you have a rectangular core then it is a thoroughbred core.  If you have the letter b or j in that sequence of lettering I stated above you have a thoroughbred b.

The thoroughbred A probably will give you trouble if you try to kick the fsb to 166.  If it is a thoroughbred B you can safely put it at 166mhz fsb.  But as the guy stated above, you will need to reduce your multiplier.

If you run it at 166mhz then you should be able probably to speed your ram up too.  They aren't really dependent but they'll run synchronously.

Either way, how did you keep the system from resetting back when you made a bios change?  I believe that is what you were complaining about.
0
 
prodierAuthor Commented:
Oh sorry, it was the FSB speed that was messing it up, it was set to 100mhz in the BIOS soft setup. But, like I mentioned, it was listed as the 'External CPU speed', which is half the FSB speed. This is my fist CPU that allows non-jumper settings, so I'm not quite familiar with the terminology.

Anyway thanks to all that helped me.
0
 
jwitt98Commented:
Prodier, thanks for accepting my answer.
In my previous post I suggested either setting the dram clock to spd or the max supported.  While you may get slightly better performance by setting to a higher frequency, it may be more stable to set it either to spd or the same as your fsb which is what I think Jimbo99 was getting at when he mentioned running synchronously.  This will eliminate any partial wait states between your cpu and memory.  Once you get your system up and running properly, you can increase the dram clock as long as your system remains stable.
Cheers
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 7
  • 5
  • 4
  • +4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now