Problem starting postgres server at boot time

Hi,
I've just installed redhat 8.0 together with postgres.
problem if I enable the service postgres at start time
I'm not able to connect to the datbase

If I start it manually with:
postmaster -i -D /var/lib/pgsql

then everything works fine, I can connect to the database

I took a look at the start-script in init.d I saw that with pg_ctl .. the -i option was missing
I added it, but still no changes,
any help is appreciated
thanks
martin
LVL 1
wbkAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
-jer-Connect With a Mentor Commented:
it depends on which runlevel your machine starts in (level 3 for text, level 5 for graphical)... make sure a link to the startup file is in the appropriate place for the mode you start the machine in...  check for links in the rcX.d directories.  If they're not, try this:
(postgresql is what I call to start/stop postgres on my server)

ln -s /etc/rc.d/init.d/postgresql /etc/rc.d/rc3.d/S85postgresql
ln -s /etc/rc.d/init.d/postgresql /etc/rc.d/rc5.d/S85postgresql
ln -s /etc/rc.d/init.d/postgresql /etc/rc.d/rc6.d/K15postgresql
ln -s /etc/rc.d/init.d/postgresql /etc/rc.d/rc0.d/K15postgresql
0
 
CleanupPingCommented:
wbk:
This old question needs to be finalized -- accept an answer, split points, or get a refund.  For information on your options, please click here-> http:/help/closing.jsp#1 
EXPERTS:
Post your closing recommendations!  No comment means you don't care.
0
All Courses

From novice to tech pro — start learning today.