Problem with DTS Schedule

I have created 2 jobs in DTS which run fine,
But when i schedule them to run they error
with this log.


Executed as user: ORION\SYSTEM. DTSRun:  Loading...   DTSRun:  Executing...   DTSRun OnStart:  DTSStep_DTSExecuteSQLTask_1   DTSRun OnError:  DTSStep_DTSExecuteSQLTask_1, Error = -2147217833 (80040E57)      Error string:  The statement has been terminated.      Error source:  Microsoft OLE DB Provider for SQL Server      Help file:        Help context:  0      Error Detail Records:      Error:  -2147217833 (80040E57); Provider Error:  3621 (E25)      Error string:        Error source:        Help file:        Help context:  0         Error:  -2147217833 (80040E57); Provider Error:  8115 (1FB3)      Error string:        Error source:        Help file:        Help context:  0      DTSRun OnFinish:  DTSStep_DTSExecuteSQLTask_1   DTSRun:  Package execution complete.  Process Exit Code 1.  The step failed.

Any ideas ?
dark22Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

adatheladCommented:
If it runs fine when you execute it manually, but fails when scheduled, this could be down to permissions. Make sure the SQL Agent account has sufficient permissions to do everything it needs to do. When you run it manually it uses your account permissions, but when scheduled it uses the SQL Agent account.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
arbertCommented:
Take a look at this--it has a little blurb in it about package owner and how the permissions work:

http://msdn.microsoft.com/library/default.asp?url=/library/en-us/dtssql/dts_pkgmng_sec_09dl.asp



Brett
0
dark22Author Commented:
I've checked the permissions and there fine.

Maybe i'm going about this the wrong way (i've only been using SQL server for 2 weeks)

I need to produce a sales report on our intranet every 10 minutes, The data is on an informix db and if i run the querys on there its very slow.

So i've used DTS to grab the data every 10 minutes and put it in an SQL db which works fine.

so my DTS says:-

Delete
From watt_custom
WHERE apptdate = GETDATE()

select *
from watt_custom
where appt_date = today

Which all works fine when i run it but errors when i schedule it.

Is there a better way of doing this???
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SQL Server

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.