Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 335
  • Last Modified:

Apache error when restarting httpd

Hi
I got this message when I try to restart the httpd daemon:
Syntax error on line 207 of /usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/libexec/libphp4.so into server: ld.so.1: /usr/local/apache/bin/httpd: fatal: libz.so: open failed: No such file or directory
./apachectl start: httpd could not be started

Anyone know why and should I just touch the libz.so file or do I have to get a copy somewhere else. I am able to comment out the line 207 and started my httpd without any problem.

thanks
0
wilfredt_99
Asked:
wilfredt_99
1 Solution
 
linxitCommented:
I assume from the file paths that you've compiled apache & php from source.

I guess that in the php configure, you added
--with-zlib or --with-zlib=/somepath (if it couldn't find it, configure would have failed). Another possibility is
--with-gd, which also requires zlib. Again, AFAIK, configure would fail if it can't find it.

Try locate libz*, if it doesn't exist you could always download the source from http://www.gzip.org/zlib/

If you do that, make sure /usr/local/lib is in your /etc/ld.so.conf and run /sbin/ldconfig after installing.

Andy

0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now