?
Solved

Installed Fine but now Can't Reboot -- Hangs

Posted on 2003-03-24
4
Medium Priority
?
247 Views
Last Modified: 2013-12-15
I've just installed Red Hat 8.0 on an old PC we had lying in the
garage.  (Read: No idea what all's in it.)  I used a boot floppy
(rawrite boot.img) to start the installation, then used the three CDs
made from the ISOs.  It installed and dropped me into the bash shell
and I went along happily configuring .bashrc's and such.

Then, I figured I should try restarting it, just to make sure
everything was okay.  Mistake.

I had been logged in as a user, then pressed Ctrl-D to logout.  This
brought me to the login prompt, where I then powered down the
computer.  I kept the boot floppy in, to ease into the booting thing.
It displayed this:

===
  Booting 'Red Hat Linux (2.4.18-14)'

root (hd0,0)
 Filesystem type is ext2fs, partition type 0x83
kernel /vmlinuz-2.4.18-14 ro root=LABEL=/
   [Linux-bzImage, setup=0x1400, size=0x107907]
initrd /initrd-2.4.18-14.img
   [Linux-initrd @ 0x1fd0000, 0x1f5af bytes]

Uncompressing Linux... Ok, booting the kernel.
===

And then it hangs there.  Exact same problem if I try to boot without
the floppy in.  I tried ejecting the boot floppy that I'd made during
the installation so that I'd be booting from the hard drive.  It hangs
at the same point every time:

===
SYSLINUX 1.75 2002-06-14  Copyright (C) 1994-2003 H. Peter Anvin

Press <return> (or wait 10 seconds) to boot your Red Hat Linux system
from /dev/hda2.  You may override the default linux kernel parameters
by typing "linux <params", followed by <return> if you like.

boot:
Loading vmlinuz.....................
Loading initrd.img....
Ready.
Uncompressing Linux... Ok, booting the kernel.
===

I know my hardware can run Red Hat, since it worked the very first
time.  I just can't get it to REboot.  Help would be much appreciated!


--
Arthaey
0
Comment
Question by:Arthaey
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
4 Comments
 
LVL 2

Accepted Solution

by:
TheWeakestLink earned 200 total points
ID: 8556937
One thing worries me : you wrote that you powered the machine off while at the login prompt.  Is that true?  I would guess that an old PC may not have the ability to do a graceful shutdown if the power button is pressed. If so, that means that you could have damaged the file system(s) which were mounted at the time, because Linux was still running, even if no user was logged in.

In order to shut down, you need to be logged in as someone with rights to issue the halt or reboot command - either as root, or a user su'ed to root or via sudo.  If you can get the install floppy to boot, you *may* be able to fsck the disk.  If it's just a simple setup, that's probably /dev/hda1, so "fsck /dev/hda1".  If you can't get it going, you may have to repartition and reinstall.

P.
0
 

Expert Comment

by:CleanupPing
ID: 9079523
Arthaey:
This old question needs to be finalized -- accept an answer, split points, or get a refund.  For information on your options, please click here-> http:/help/closing.jsp#1 
EXPERTS:
Post your closing recommendations!  No comment means you don't care.
0
 
LVL 12

Expert Comment

by:paullamhkg
ID: 10040339
No comment has been added lately, so it's time to clean up this TA.
I will leave the following recommendation for this question in the Cleanup topic area:

Accept: TheWeakestLink {http:#8556937}

Please leave any comments here within the next seven days.
PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER!

paullamhkg
EE Cleanup Volunteer
0

Featured Post

Percona Live Europe 2017 | Sep 25 - 27, 2017

The Percona Live Open Source Database Conference Europe 2017 is the premier event for the diverse and active European open source database community, as well as businesses that develop and use open source database software.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Network Interface Card (NIC) bonding, also known as link aggregation, NIC teaming and trunking, is an important concept to understand and implement in any environment where high availability is of concern. Using this feature, a server administrator …
Google Drive is extremely cheap offsite storage, and it's even possible to get extra storage for free for two years.  You can use the free account 15GB, and if you have an Android device..when you install Google Drive for the first time it will give…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial
Suggested Courses
Course of the Month9 days, 3 hours left to enroll

764 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question