can't set the timeout of session variables up to 20 minutes

hi...
i would like to set the timeout of my session variables to 6 hours, but after 20 minutes
(default in cf-administrator is 10 seconds) they timed out.

i tried to set it directly in my 'cfapplication - tag' with 'sessionTimeOut="#CreateTimeSpan(0,0,30,0)#"'
(for testing i set the timeout to 30 min) but it also timed out after 20 minutes.

when i set the timeout for example to 'sessionTimeOut="#CreateTimeSpan(0,0,0,10)#"' (10 seconds) then it works....

thanks for all ideas...

;-)

alethoAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

TallerMikeCommented:
The default timeout in the CFADMIN may be 10 seconds, but what is the MAXIMUM timout? It's to the left of the default. If this is set to 20 minutes, then you can never set the timeout greater than that. Try checking there first.

Try setting the Application timeout to 15 minutes and it should work, setting it to 25 will not then.
0
reitzenCommented:
Whatever you set in your APPLICATION.CFM page will never be longer than what has been set in Administration. It can be shorter, but never longer.

You must extend the timeout in Administration to see any effect from what you have set in your APPLICATION.cfm.

If you do not have access to Administration, the only option that comes to mind is to set a META tag with a refresh rate of about 19 minutes.  This way if a page just sits and the user does nothing for 19 minutes, the page will refresh itself and reset the session timer.

<meta http-equiv="REFRESH" content="19; url=/index.cfm">
0
Renante EnteraSenior PHP DeveloperCommented:
Try to add the parameter ApplicationTimeOut for your <cfapplication> tag. Setting it to a desired time span for your default value of your ColdFusion Administrator.

GOODLUCK!
0
Cloud Class® Course: CompTIA Cloud+

The CompTIA Cloud+ Basic training course will teach you about cloud concepts and models, data storage, networking, and network infrastructure.

alethoAuthor Commented:
thanks for your answers...

shame on me. i made a beginner's mistake.
for info:
in cf-admin i have set the maximum timeout to
'12 hours' and the minimum timeout to '10 seconds',
but i haven't restarted the cf-server...
so the defaults for the maximum and minimum timeouts were
still set - '20 minutes'.

when i tried to set the timeout to e.g. '10 minutes' in the 'cfapplication-tag', it worked fine, because the 'cfapplication-tag' overrides the default 'minimum
timeout'.
when i tried to set the timeout to e.g. '30 minutes' in the 'cfapplication-tag', it didn't work, because the 'cfapplication-tag' doesn't override the default 'maximum
timeout'.

the lesson of my problem ->
when you are updating your timeouts for the session variables, RESTART your cf-server!!!

;-)
0
mrichmonCommented:
No comment has been added lately, so it's time to clean up this question.
I will leave the following recommendation in the Cleanup topic area:

PAQ/Refund

Please leave any comments here within the next four days.

mrichmon
EE Cleanup Volunteer
0
ee_ai_constructCommented:
PAQed, with points refunded (50)

ee_ai_construct - (re-order part number #xm34)
Community Support Moderator
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Servers

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.