How to add required .dll file to the Java.library.path in JB8

I got the error when compile a program quoting notes library: lotus.domino.*. The error seems like miss the required .dll named nlsxbe.dll in java.library.path. How to solve it?
the detail paste below:

java.lang.UnsatisfiedLinkError: no nlsxbe in java.library.path

     at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1403)

     at java.lang.Runtime.loadLibrary0(Runtime.java:788)

     at java.lang.System.loadLibrary(System.java:832)

     at lotus.domino.NotesThread.load(NotesThread.java:299)

     at lotus.domino.NotesThread.checkLoaded(NotesThread.java:320)

     at lotus.domino.NotesThread.initThread(NotesThread.java:140)

     at lotus.domino.NotesThread.run(NotesThread.java:202)
David777Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

objectsCommented:
Try adding the dll somewhere in your PATH.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
msterjevCommented:
Put the dll into the windos directory, windows/system directory or into the directory you going to executing the classes!
0
Venci75Commented:
start you application using:
java -cp <class path> -Djava.library.path=<the path to nlsxbe.dll> <main class> <args>
0
Cloud Class® Course: Microsoft Exchange Server

The MCTS: Microsoft Exchange Server 2010 certification validates your skills in supporting the maintenance and administration of the Exchange servers in an enterprise environment. Learn everything you need to know with this course.

David777Author Commented:
I got the info that I can view the path of java.library which can be print out. How can I do it?
0
Venci75Commented:
System.out.println(System.getProperty("java.library.path"));
0
David777Author Commented:
I paste the nlsxbe.dll to system folder but not effective.
0
Venci75Commented:
which one? did you put it to
<WINDIR>/System32
?
0
David777Author Commented:
I'm testing. thank you, Venci75
0
David777Author Commented:
system
0
Venci75Commented:
try to put it to:
<WINDIR>/System32
0
David777Author Commented:
I got its output, but I find it same with the system set Path. Is it right?
If I change the system path to the note folder, I don't need to copy any .dll located in above folder to system folder?
0
David777Author Commented:
I got its output, but I find it same with the system set Path. Is it right?
If I change the system path to the note folder, I don't need to copy any .dll located in above folder to system folder?
0
Venci75Commented:
did you try to start your application using:
java -cp <class path> -Djava.library.path=<the path to nlsxbe.dll> <main class> <args>
0
David777Author Commented:
I have no idea how I can use the above line you give me. where do I input them and could you give me an example?
thanks
0
David777Author Commented:
I have no idea how I can use the above line you give me. where do I input them and could you give me an example?
thanks
0
David777Author Commented:
I have no idea how I can use the above line you give me. where do I input them and could you give me an example?
thanks
0
Venci75Commented:
how do you start your application?
0
David777Author Commented:
I'm using JB8, if I modify in run configuration?
0
Venci75Commented:
go to:
Project/Project Parameters
menu and choose the 'Run' tab.
Add to the 'VM parameters' field the following:
-Djava.library.path=<the path to nlsxbe.dll>
0
David777Author Commented:
I'm using JB8, if I modify in run configuration?
0
funnyveryfunnyCommented:
Hi,

I had a similar problem to yours in JB7 (missing hrtlib.dll in java.library.path) and just managed to solve it. So here is my solution, make a copy of nlsxbe.dll into yr ../JBuilder8/JDK/Bin/ directory.

It's worked for me becos the hrtlib.dll is now part of my java.library.path.

Hope it'll work for you.

Bye
0
objectsCommented:
What is your PATH set to?
0
David777Author Commented:
I solve it. I add the path contains the required file to system path, and run, it works.
Thank you all very much.
0
objectsCommented:
Same effect as adding the dll to somewhere in your path as I originally suggested :)
0
CleanupPingCommented:
David777:
This old question needs to be finalized -- accept an answer, split points, or get a refund.  For information on your options, please click here-> http:/help/closing.jsp#1 
EXPERTS:
Post your closing recommendations!  No comment means you don't care.
0
jimmackCommented:
No comment has been added lately, so it's time to clean up this TA.
I will leave a recommendation in the Cleanup topic area that this question is:

Accept objects' comment as answer.

Please leave any comments here within the next seven days.

PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER!

jimmack
EE Cleanup Volunteer
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Java

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.