• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 250
  • Last Modified:

WIndows 2000 Server w/ 2 Nics DNS Problem

I have a windows 2000 server with 2 nics (2 networks) I have the Routing and remote access service performing Nat and using the DHCP relay agent to distribute private IP's to my internal dhcp client machines. This setup is working well and I am getting Internet access. Remember 1 nic is to my cable modem and the other nic is to a switch for my internal network.

Problem, when I join my windows 2k professional desktop to my server it goes well, but the DNS resolution is taking place from the ISP dns instead of my server's DNS. NSlookup is unable to locate the DNS server 192.168.0.1  I have checked all configurations and I believe it is my DNS server config. I only have mydomain.com in the forward lookup zone (no ".") whatsoever. I was having a problem prior to this and thought I fixed it by re-installing DNS on that server because I added a member server and was unable to run dcpromo because IT TOO couldnt find the DNS server. After removing and reinstalling the DNS server it fixed it. Here is the scary part. when I removed and stopped the dns server in my root server. My clients were still reaching the internet. It's obviously not paying my little DNS server on my root DC any mind. However my dcpromo worked yesterday so I thought all was well until I was unable to do a manage from AD to my client 2k pro pc. Error states unable to find client.mydomain.com .. I went to the client machine and ran a NSlookup and for sure, its not finding it. I ran nslookup to a legit Internet site and its using my ISP DNS. HELP!
0
rarecatch
Asked:
rarecatch
1 Solution
 
joeyxiongCommented:
Make sure that your DNS server IP address is the primary DNS in its TCP/IP properties.  Windows 2000 refers to this as the Preferred DNS Server.  Use both DNS's from your ISP as Alternates.
0
 
rarecatchAuthor Commented:
My DNS server's IP Address is the only IP address in my tcp/ip config.  

My server has 2 network properties .. 1 for the Nic to my cable modem that the ISP issues the IP and DNS ( in which changes because its leased) and ..... the other Nic is to my switch for my internal network.

NIC to ISP\Cable Modem config : obtain IP address automatically, and for the DNS its obtain as well.

NIC to Switch: Static : 192.168.0.1 255.255.255.0 and DNS is 192.168.0.1 (Same as win2k server)

Im using Routing and remote access on my server to act as a router with the DHCP relay ( the dhcp relay acts as a dhcp server with internal to external routing of packets for internet access)

My client 2k pro is setup to obtain automatically with the DNS statically configured to my win2k server 192.168.0.1

I can map to my server share fine. and get internet. but when I try to do a manage on the computer from my DC the error I recieve is \\compuer.mydomain.com cannot be managed. the network path was not found. Its not registering the computer to the DNS server to be resolved. I can do a manage if I use the IP address though.

I am now able to do an NSlookup on both the DC and the win2kPRO workstation and get a default server as MYDC.domain.com now :-) I changed the DNS from obtain to my servers IP address for the ISP NIC Tcp\ip setting. But still unable to manage that 2kpro client from my DC without using straight IP

0
 
froggy3132000Commented:
Just go in to DNS snap-in and create a record for you 2kpro client.
0
 
Sebastien_BCommented:
It sounds like you misconfigured all that,

The "DHCP relay client" is not for you, in your example it will try to distribute some IP from your ISP to your LAN clients (so it will also push the ISP ip-config to your clients...) a simple DHCP server will be fine.

You should try configuring your DNS on W2KSRV to use "forwarders" (the ISP's DNS)

On your DHCP Server (not relay !), configure it to distribute ONLY your local DNS 192.168.0.1 (then if it cannot handle the name resolution, it will request the ISP's DNS for help)

Now stop configuring anything manually on your clients...

Tip : As you're using a private range for a few hosts, why don't you simply enable the Internet Connection Sharing ??
(Can be set from the ISP/Cable NIC properties, it will set the other NIC to 192.168.0.1...)

All will rock easily :)


Seb
0
 
rarecatchAuthor Commented:
Hey for all that have the setup I have I must say that I finally fixed my problem. Took me all day but I did it. Hey Sebastien thanks for the push in getting me to stray away from that dhcp "allocator" sorry I have been posting relay agent but I really mean allocator from within Microsofts NAT Options under Routing and Remote Access.

Problem: Unable to get my clients to register to DNS even with the force ipconfig /registerdns option.. still failed.

Fix: Disconnected my Cable Modem, Then Established a DHCP Server ( fully configured, scope and etc..) For some reason I tried to start the DHCP server and it picked up my ISP's DHCP**WIERD** I am still using Routing and Remote Access but withing the DHCP, just routing between the two interfaces (Nics). ! HEY , I dont like the easy way out, NO easy Share connections from Network properties ! I also had to be sure to add option 003 in the Scope Options of my DHCP server so that my clients would all recieve the default gateway of my DC. I also added the DNS Server as part of my Scope , again my DC IP. It seems the DHCP allocator just doesn't work well with client DNS registering.  Aaaaannnnd I added Forwarders! I really wanted to fix this without doing all that I did, I hate to just take the common road. I prefer troubleshooting helps me learn the other avenues. But I QUIT, DHCP "SERVER" it is , Thanks Sebastien
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now