Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 443
  • Last Modified:

On-Demand SubReport will not open v8.5

Good Afternoon,
I am new to crystal but i have been messing with this problem for several hours now.

I have an OnDemand SubReport on my main report. It will not open when you double click on the place holder at runtime.

**If you turn off On Demand the data populates fine in the subreport.**
- I am able to edit the On Demand caption.
- My links are good.
- When i double click the subreport in design mode it switches fine. At runtime nothing happens.

- I have tried creating a new On Demand SubReport...same result.
- I have tried reimporting ...nothing
- I have tried saving the subreport as somthing else...nothing

I dont quite get it...
0
NirvSysAlan
Asked:
NirvSysAlan
  • 2
1 Solution
 
mlmccCommented:
How are you calling the report?

If you are using a frontend application I think you have to EnableDrillDown.
Depending on how you are calling the report a line like should solve the problem

report.EnableDrillDown = True


mlmcc
0
 
NirvSysAlanAuthor Commented:
ok you rock
0
 
mlmccCommented:
Glad I could help

mlmcc
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now