?
Solved

[CISCO 1605] Unable to configure an interface as DHCP Client

Posted on 2003-03-26
23
Medium Priority
?
1,195 Views
Last Modified: 2012-05-04
Hi

first of all sorry if I make mistakes but I am not english :)

I'am a student and my company lend me a router cisco 1605.
I want to share my internet connexion with it.I ve got a cable connexion.
I have configured the first interface for my lan with no problem (with a static ip adress),but for the second interface,I can't configure it as a DHCP client (to have an IP adress by my ISP)

Someone can tell me what I have to do ?
I have try in the enable mode to type "Cisco1605(config-if)#ip address dhcp" but I've got an error.It seems I only can type an ip adress.

That's the router information :
ROM: System Bootstrap, Version 12.0(3)T, RELEASE SOFTWARE (fc1)
ROM: 1600 Software (C1600-RBOOT-R), Version 12.0(3)T,  RELEASE SOFTWARE (fc1)

Thanks

P.S : It's very important for my studies,so please do not hesitate if you have any suggestion
0
Comment
Question by:bigstyle
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 12
  • 9
  • 2
23 Comments
 
LVL 7

Expert Comment

by:pedrow
ID: 8215291
looks like you'll need to upgrade your IOS version to a newer one that supports it:

from http://www.cisco.com/en/US/partner/products/sw/iosswrel/ps1834/products_feature_guide09186a00800800e7.html#xtocid310110

ip address dhcp

To acquire an IP address on an Ethernet interface from the Dynamic Host Configuration Protocol (DHCP), use the ip address dhcp interface configuration command. To deconfigure any address that was acquired, use the no form of this command.
ip address dhcp

no ip address dhcp

Syntax Description

This command has no arguments or keywords.

Defaults

No default behavior or values.

Command Modes

Interface configuration

Command History
Release Modification

12.1(2)T - This command was introduced.  <<<<<--------
0
 

Author Comment

by:bigstyle
ID: 8217226
It was what I feared :-(

It's for that reason I precised the version of my IOS.

So I have to buy a new IOS?
I dont know if it is legal but i cant find one for my router,in the internet ?

I am a student and I don't really have money to buy a new IOS :/
0
 
LVL 7

Expert Comment

by:pedrow
ID: 8219038
I dunno.

call cisco. You might be able to see if you can get a educational discount. Or maybe your company has a support contract.
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 5

Expert Comment

by:epylko
ID: 8219494
IOS upgrades are not free.  You have to have a support agreement with Cisco to get one.  Definately check with your company.

Also, you might not have enough memory in the 1600 to upgrade to 12.1(2)T.  Also, the 1600 series have been declared end-of-life

-Eric
0
 

Author Comment

by:bigstyle
ID: 8219582
What really surprise me is that the option to be a dhcp client doesnt exist in a cisco router...

For the problem of memory,I think I ve got some EDO on my room to fix the problem.

And for my company I dont think they gonna pay to upgrade the router.
At the moment,they dont need it and I am in a training course there so I dont think my request will be listened.
0
 
LVL 7

Expert Comment

by:pedrow
ID: 8219891
sure it do :)

router1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
router1(config)#int fa0/0
router1(config-if)#ip address ?
  A.B.C.D  IP address
  dhcp     IP Address negotiated via DHCP

router1(config-if)#

just in later versions of code.

You gotta remember, when 12.0(3)T came out, home broadband was a pipe dream to most of us.

If you wanted isdn in your house, you needed something like a cisco 1004 to do it.

and generally speaking, you never wanted your router to be a dhcp client...

RAM on the 1600 is the 72-pin non-parity simm...I think it's got 8mb onboard and will take another 16mb stick...check the bottom of your pencil drawer...you might find some there. If not, you can probably find it pretty darn cheap(i bought mine for $24 two years ago).

0
 

Author Comment

by:bigstyle
ID: 8240557
I ve got some news about my problem.

One friend gave me an updated IOS for my router but now I ve got another kind of problem :/

The new version has 4.5 Mo and my flash card has 4 Mo.

I've tried something but it seems it doesnt work.
I took a PCMCIA Adapter and I put a compact flash memory (I ve tested an 8 and 16Mo).
The flash memory are empty so when the router boot,it is thanks to the Bootstrap.
Then that is what s happen :

Cisco1605(boot)#copy tftp flash
                         ****  NOTICE  ****
Flash load helper v1.0
This process will accept the copy options and then terminate
the current system image to use the ROM based image for the copy.
Routing functionality will not be available during that time.
If you are logged in via telnet, this connection will terminate.
Users with console access can see the results of the copy operation.
                         ---- ******** ----
Proceed? [confirm]
Address or name of remote host []? 192.168.0.1
Source filename []? c1600-nosy-mz.122-2.T.bin
Destination filename [c1600-nosy-mz.122-2.T.bin]?
Accessing tftp://192.168.0.1/c1600-nosy-mz.122-2.T.bin...
Erase flash: before copying? [confirm]

00:00:51: %SYS-5-RELOAD: Reload requested

Erasing the flash filesystem will remove all files! Continue? [confirm]
%QUICC_ETHER-1-LOSTCARR: Unit 1, lost carrier. Transceiver problem?
%Error erasing flash: (Device not found)
%FLH: tftp://192.168.0.1/c1600-nosy-mz.122-2.T.bin to flash ...
Loading c1600-nosy-mz.122-2.T.bin from 192.168.0.1 (via Ethernet0): !
%Error opening flash::c1600-nosy-mz.122-2.T.bin (Device not found)
%FLH: retry #1
%FLH: tftp://192.168.0.1/c1600-nosy-mz.122-2.T.bin to flash ... (retry)
Loading c1600-nosy-mz.122-2.T.bin from 192.168.0.1 (via Ethernet0): !
%Error opening flash::c1600-nosy-mz.122-2.T.bin (Device not found)
%FLH: Idling for 30 secs before retry #2
%FLH: tftp://192.168.0.1/c1600-nosy-mz.122-2.T.bin to flash ... (retry)
Loading c1600-nosy-mz.122-2.T.bin from 192.168.0.1 (via Ethernet0): !
%Error opening flash::c1600-nosy-mz.122-2.T.bin (Device not found)
%FLH: Flash download failed
%SYS-6-BOOT_MESSAGES: Messages above this line are from the boot loader.
boot of "flh:flh" using boot helper "eprom:c1600-rboot-r.120-3.T" failed
error returned: c1600-nosy-mz.122-2.T.bin 192.168.0.1
loadprog: error - on file open
boot: cannot load "flh:flh"ê


And he reboots two or three times in a row...

What kind of problem it is ?
Thanks
0
 

Author Comment

by:bigstyle
ID: 8245957
To put in a nutshell,I would like to know if I have to format my compactflash card before trying to write the new IOS in it.

And if yes,how can I format it ?
Thanks for all.
0
 
LVL 7

Expert Comment

by:pedrow
ID: 8246857
I've never heard you anyone being able to use compactflash with a pcmcia adapter for routers.

it's not even seeing that there's anything there as evidenced by:

%Error erasing flash: (Device not found)

You'll need to buy a regular flash memory card instead of cf...

0
 
LVL 5

Expert Comment

by:epylko
ID: 8247815
Check www.crucial.com or www.kingston.com for flash memory for the router.  They usually have reasonable prices.

-Eric
0
 

Author Comment

by:bigstyle
ID: 8255013
Thnaks for all,I ve finally found a IOS of 3.5Mo that supports the dhcp client option.

Now I ve got an another kind of problem.I dont know If I make another topic or if I follow here.
If there's a problem,I make a new one.

I want to share my internet connexion with my cisco 1605R.
I've got a modem cable connected to eth1 and eth0 is connected to a hub with the rest of my computers.

I think I have to configure the NAT but my problem is there...

I ve read and follow al the instructions there : http://www.cisco.com/warp/public/109/router_behind_cm_19268.shtml
It is exactly my situation but it doesn't work.
When I reload the router,I've got an ip adressed dynamically for the eth1 and for my eth0,I ve got the ip entered in my conf.

From a computer in my lan : I have entered in the default gateway the ip of eth0 and I can ping eth0 but I dont ping eth1 or an another ip connected to the net (google ip for example).

From my router : I can't ping eth0,eth1 and pc from my lan but I cant ping any ip connected to the net,neither the default gateway.

I think it's a problem with access-rules or the configuration of the nat but I found nothing over the web about that kind of configuration.
--------------------------------
Cisco1605#show ip interface ethernet 1
Ethernet1 is up, line protocol is up
  Internet address is 81.65.165.10/23
  Broadcast address is 255.255.255.255
  Address determined by DHCP
  MTU is 1500 bytes
  Helper address is not set
  Directed broadcast forwarding is disabled
  Outgoing access list is not set
  Inbound  access list is not set
--------------------------------------

Thanks
0
 
LVL 7

Expert Comment

by:pedrow
ID: 8255156
care to post relevant parts of the config?

interface configs, nat config and nat rules in particular?

Thanks,
0
 

Author Comment

by:bigstyle
ID: 8255167
Thnaks for all,I ve finally found a IOS of 3.5Mo that supports the dhcp client option.

Now I ve got an another kind of problem.I dont know If I make another topic or if I follow here.
If there's a problem,I make a new one.

I want to share my internet connexion with my cisco 1605R.
I've got a modem cable connected to eth1 and eth0 is connected to a hub with the rest of my computers.

I think I have to configure the NAT but my problem is there...

I ve read and follow al the instructions there : http://www.cisco.com/warp/public/109/router_behind_cm_19268.shtml
It is exactly my situation but it doesn't work.
When I reload the router,I've got an ip adressed dynamically for the eth1 and for my eth0,I ve got the ip entered in my conf.

From a computer in my lan : I have entered in the default gateway the ip of eth0 and I can ping eth0 but I dont ping eth1 or an another ip connected to the net (google ip for example).

From my router : I can't ping eth0,eth1 and pc from my lan but I cant ping any ip connected to the net,neither the default gateway.

I think it's a problem with access-rules or the configuration of the nat but I found nothing over the web about that kind of configuration.
--------------------------------
Cisco1605#show ip interface ethernet 1
Ethernet1 is up, line protocol is up
  Internet address is 81.65.165.10/23
  Broadcast address is 255.255.255.255
  Address determined by DHCP
  MTU is 1500 bytes
  Helper address is not set
  Directed broadcast forwarding is disabled
  Outgoing access list is not set
  Inbound  access list is not set
--------------------------------------

Thanks
0
 

Author Comment

by:bigstyle
ID: 8255512
Sorry for the second post (Back button of i.e :p)

This is my configuration file :


!
version 12.2
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname Cisco1605
!
logging queue-limit 100
enable secret 5 $1$3ckJ$AHPm6mhU3tZwApAyx3Yak1
enable password 7 000C17050A4F0A02022842
!
ip subnet-zero
no ip domain-lookup
ip name-server 212.198.0.91
ip name-server 212.198.0.51
ip dhcp excluded-address 192.168.0.1
!
ip dhcp pool CLIENT
   import all
   network 192.168.0.0 255.255.255.0
   default-router 192.168.0.10
!
!
!
!
interface Ethernet0
 description connected to EthernetLAN
 ip address 192.168.0.10 255.255.255.0
 ip nat inside
 no ip route-cache
 no cdp enable
!
interface Ethernet1
 ip address dhcp
 ip nat outside
 no ip route-cache
!
interface Serial0
 no ip address
 shutdown
!
router rip
 version 2
 network 192.168.0.0
 no auto-summary
!
ip nat log translations syslog
ip nat inside source list 102 interface Ethernet1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 81.65.161.1
ip http server
!
access-list 1 permit any log
access-list 102 permit ip 192.168.0.0 0.255.255.255 any
dialer-list 1 protocol ip permit
dialer-list 1 protocol ipx permit
bridge 1 protocol dec
!
line con 0
 exec-timeout 0 0
 password 7 11081D081E1C030807243F
 login
line vty 0 4
 password 7 1304131F02020C2E282A3C
 login
!
end


----------------------------------------------------

Cisco1605#show interfaces ethernet 0
Ethernet0 is up, line protocol is up
  Hardware is QUICC Ethernet, address is 00d0.58a8.eb20 (bia 00d0.58a8.eb20)
  Description: connected to EthernetLAN
  Internet address is 192.168.0.10/24
  MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:41, output 00:00:10, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     5 packets input, 685 bytes, 0 no buffer
     Received 4 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 input packets with dribble condition detected
     35 packets output, 2120 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out

--------------------------------------------------------

Cisco1605#show interfaces ethernet 1
Ethernet1 is up, line protocol is down
  Hardware is QUICC Ethernet, address is 00d0.58a8.eb21 (bia 00d0.58a8.eb21)
  Internet address is 81.65.161.80/23
  MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
     reliability 201/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:04:15, output 00:00:04, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     44 packets input, 5178 bytes, 0 no buffer
     Received 44 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 input packets with dribble condition detected
     41 packets output, 3576 bytes, 0 underruns
     27 output errors, 0 collisions, 0 interface resets
     0 babbles, 0 late collision, 0 deferred
     27 lost carrier, 0 no carrier (no matter cause I unplugged the cable)
     0 output buffer failures, 0 output buffers swapped out

----------------------------------------------------------
Cisco1605#show ip nat statistics
Total active translations: 0 (0 static, 0 dynamic; 0 extended)
Outside interfaces:
  Ethernet1
Inside interfaces:
  Ethernet0
Hits: 0  Misses: 0
Expired translations: 0
Dynamic mappings:
-- Inside Source
[Id: 1] access-list 102 interface Ethernet1 refcount 0

----------------------------------------------------

Except of my configuration file,I dont have configure nat elsewhere.

Thank you
0
 
LVL 7

Expert Comment

by:pedrow
ID: 8255716
I'm not seeing anything obviously wrong with the config.

looks like you have a link probem between your router and your cable modem:

Cisco1605#show interfaces ethernet 1
Ethernet1 is up, line protocol is down  <============
this seems to indicate that you might have a cabling problem since it was up/up in an earlier example.

odd that you still seem to have an received an ip address though.

maybe the connectors need to be re-seated.

Are the pc clients on your inside getting proper dhcp info from the router? it almost sounds as if the default route that it should be issuing isn't right...does the output of:
c:\>ipconfig /all

look as it should?

also, i'm not quite sure I have a handle on what can ping see what from the following exerpt:
"From my router : I can't ping eth0,eth1 and pc from my lan but I cant ping any ip connected to the net,neither the default gateway."

could you clarify this?


0
 

Author Comment

by:bigstyle
ID: 8255988
Between my cable modem and the router,it's ok.
that error : Ethernet1 is up, line protocol is down was because I type that command with the cable unplugged (because,I test it on that machine,and I have to unplugged it to have internet).

The clients received all nicely.With a ipconfig /renew,they receive an ip address,the default gateway,dns servers...

For the last comment,sorry I made a mistake.
From my router,I can ping eth0,eth1 and pc from my lan but i cant ping any ip connected to the net.

For the default gateway,I am 95% sure of it.
I suppose my isp use the same logic for all his network.
To be sure (I think) and to see what my eth1 client dhcp retrieve from my isp I type sh ip route

and I ve got :
--------------------------------------------
Cisco1605#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 81.65.161.1 to network 0.0.0.0

     81.0.0.0/23 is subnetted, 1 subnets
C       81.65.160.0 is directly connected, Ethernet1
C    192.168.0.0/24 is directly connected, Ethernet0
S*   0.0.0.0/0 [1/0] via 81.65.161.1

--------------------------------------------

But I think it is more a nat configuration problem,because as I said,a lan computer cannot ping the eth1 (internet interface)...damn it s very strange, I dont understand...One of my pc can ping eth1 but one other cant (but it can ping the eth0)

I am gonna try to see what's happen and to make the problem more easy :/
0
 

Author Comment

by:bigstyle
ID: 8256019
Between my cable modem and the router,it's ok.
that error : Ethernet1 is up, line protocol is down was because I type that command with the cable unplugged (because,I test it on that machine,and I have to unplugged it to have internet).

The clients received all nicely.With a ipconfig /renew,they receive an ip address,the default gateway,dns servers...

For the last comment,sorry I made a mistake.
From my router,I can ping eth0,eth1 and pc from my lan but i cant ping any ip connected to the net.

For the default gateway,I am 95% sure of it.
I suppose my isp use the same logic for all his network.
To be sure (I think) and to see what my eth1 client dhcp retrieve from my isp I type sh ip route

and I ve got :
--------------------------------------------
Cisco1605#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 81.65.161.1 to network 0.0.0.0

     81.0.0.0/23 is subnetted, 1 subnets
C       81.65.160.0 is directly connected, Ethernet1
C    192.168.0.0/24 is directly connected, Ethernet0
S*   0.0.0.0/0 [1/0] via 81.65.161.1

--------------------------------------------

But I think it is more a nat configuration problem,because as I said,a lan computer cannot ping the eth1 (internet interface)...damn it s very strange, I dont understand...One of my pc can ping eth1 but one other cant (but it can ping the eth0)

I am gonna try to see what's happen and to make the problem more easy :/
0
 
LVL 7

Accepted Solution

by:
pedrow earned 2000 total points
ID: 8256402

I see that you've got:
ip route 0.0.0.0 0.0.0.0 81.65.161.1

that doesn't seem to be on the same subnet as the network of your external interface:
81.65.165.10/23

your default route should point to the *next hop* router on the e1 interface's network.

Is that something the isp gave you? I'd think that with dhcp on the external interface that the default route would get assigned by the dhcp agent.

What happens if you delete the static default route?

the default route should get dynamically assigned by the isp if they're giving you dhcp.



0
 

Author Comment

by:bigstyle
ID: 8257047
Thanks a lot pedrow for your help and your disponibility.
I increase the question to 500 points.

If I can help you by any way,I ll do.

Thx
0
 
LVL 7

Expert Comment

by:pedrow
ID: 8257247
cool.
glad i could help :)
0
 

Author Comment

by:bigstyle
ID: 8260653
Just two little questions more :p)

1)I am trying to map a port for a server in my LAN can be used by internet users.
I dont think it's really clearly.
I have a server in my lan (192.168.0.1) and i want to be able to use it from internet.

My eth1 is a client dhcp so I ve tried something like that :

Cisco1605(config)#$ static tcp Ethernet1 3389 192.168.0.1 3389 extendable      
ip nat outside source static tcp Ethernet1 3389 192.168.0.1 3389 extendable
                                 ^
% Invalid input detected at '^' marker.

2)Someone know or have some good documentations about cisco routers,commands and possibility?
I'am not a registered user,and I can't find nothing interesting in the Cisco website.
0
 

Author Comment

by:bigstyle
ID: 8260661
sorry bad copy/paste .
The marker normaly shows the E from 'Ethernet1' not the r from 'source'
0
 
LVL 7

Expert Comment

by:pedrow
ID: 8264140
yeah...i usually paste into textpad...

I think you might be outta luck with the static port mapping.

it wants an ip address:

router(config)#ip nat inside source static tcp ?
  A.B.C.D  Inside local IP address
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

While it is possible to put two routes in place with the secondary having a higher metric, this may not always work. In the event of a failure that does not bring down the physical interface on the router the primary route is not removed. There is a…
Tired of waiting for your show or movie to load?  Are buffering issues a constant problem with your internet connection?  Check this article out to see if these simple adjustments are the solution for you.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Suggested Courses

777 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question