Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

How to detect weblogic app server is down and show custom error page

Posted on 2003-03-26
7
Medium Priority
?
851 Views
Last Modified: 2013-12-10
We are using iPlanet web server 6.0 as the web server and Weblogic as the app server. We need to show a custom error page when a request is made thru the web server and weblogic is down. Default msg comes up now is "No backend server available for connection: timed out after 10 seconds". Basically we need to detect if the app server (weblogic in this case) is down.

0
Comment
Question by:ankurwal
  • 3
4 Comments
 
LVL 4

Expert Comment

by:boxy73
ID: 8252083
Hi,

I'm using iPlanet 4.1 along with weblogic, and when I connect them two using obj.conf, I put it this way, for example, for jsps:

<Object name="My_jsp" ppath="*/*.jsp">
Service fn="wl-proxy" WebLogicCluster="10.9.6.10:7005,10.9.6.11:7005" ErrorPage="http://your_domain/your_path/your_error_page.html"
</Object>

and the same for servlets, for example.

This way, when I have my weblogic server down, my error page is the one that is shown in the web browswer.

Hope this helps you.
0
 

Author Comment

by:ankurwal
ID: 8252158
Thanks for your reply. But it didnt work for me. I tried using this entry in obj.conf

===================
<Object name="weblogic" ppath="*/*.jsp">
Service fn="wl-proxy" WebLogicHost="127.0.0.1" WebLogicPort="7001"
ErrorPage="index.html"
</Object>
====================

But got the following error in the web logs:

[02/Apr/2003:14:27:36] failure ( 3024):  Invalid configuration: File C:\Apps\iPlanet\Servers\https-my-instance\config\server.xml, line 32, column 11: Error processing obj.conf line 56: Directives must have at least one parameter  [02/Apr/2003:14:27:36] info ( 3024):  Suspend Httpd Service  

Any clues?
0
 
LVL 4

Expert Comment

by:boxy73
ID: 8253269
Try including the real IP address of your weblogic, and the port altogether as in my example.

And include the entire path of your error page. Is your weblogic listening on port 7001?
0
 
LVL 4

Accepted Solution

by:
boxy73 earned 200 total points
ID: 8253407
Also, check the compatibility between your iPlanet version and the weblogic one.

You can check that here:

http://e-docs.bea.com/wls/certifications/certifications/overview.html

For configuring plug-in for weblogic 7.0, you can find a useful doc here:

http://edocs.bea.com/wls/docs70/pdf/plugins.pdf

Hope this helps you.
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Verbose logging is used to diagnose garbage collector problems. By default, -verbose:gc output is written to either native_stderr.log or native_stdout.log.   It is also possible to redirect the logs to a user-specified file. This article will de…
Most of the developers using Tomcat find it easy to configure the datasource in Server.xml and use the JNDI name in the code to get the connection.  So the default connection pool using DBCP (or any other framework) is made available and the life go…
Exchange organizations may use the Journaling Agent of the Transport Service to archive messages going through Exchange. However, if the Transport Service is integrated with some email content management application (such as an anti-spam), the admin…
When cloud platforms entered the scene, users and companies jumped on board to take advantage of the many benefits, like the ability to work and connect with company information from various locations. What many didn't foresee was the increased risk…
Suggested Courses

572 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question