how to set the write permission

hi all,
         
      i have redhat linux 7.2 installed on my system ,my problem is tht when i login as a user i am unable to write or create folders on the mounted drives , when i checked the permissions the write so permission was not given , so i logged in as root and tried to change the permissions but i was not successful in changing the permissions .
  so plz tell me how should i set the write permission.

     i am sure tht the experts out here can easily help me out.  
lokesh_kumarAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

yuzhCommented:
use: chmod
command to change the dir/file permissions.
man chmod
eg:
chmod a+rw dir-name
will allow every one has read and write permissions to the dir

to learn more.

use chown
to change the ownnership of file/dir
(must be super user to change the ownership!)
man chown
to learn more.

0
unise_nlCommented:
Looks like you are on a NFS filesytem wrongly configured. PLease go to your server side and check the exports file configuration. I am currently not able to check on my own system, but do a man-read on exports, mount etc..
0
lokesh_kumarAuthor Commented:
i have used chmod many times to change the permission but it does not work . .
 chmod executes successfully without showing any error but permissions donot change
the filesystem of the drives is vfat and i am not connected to any server , i just have linux installed on a single system and there are 2 accounts on it , one is mine as user and the other is root .
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

fluid11Commented:
You can't access the mount because it was mounted with root privileges.  Edit the /etc/fstab file and add an entry like this...

/dev/hda1  /mnt/windoze  vfat   user 0 0

The above will allow a normal user to mount (and access) the FAT32 /dev/hda1 partition.

ChrisP
0
lokesh_kumarAuthor Commented:
hello chris,
             i agree with wht u said and i tried it before,
 i wrote      /dev/hda1  /mnt/98  vfat   user,rw   0 0

  and after doing this i was able to change the permission for the user account by logging in as root and using chmod but when i tried to login as the user(not as root) and checked the permissions , the write permission was not there which i could not understand .
   and when i try to use chmod as a user(not as root) the command does not execute.

  so now tell me wht to do next.  

          lokesh

0
fluid11Commented:
I meant to say "users" above, not user.

/dev/hda1   /mnt/98 vfat  users,rw 0 0

Have you tried mounting it as a regular user, not root?  If its already mounted, make sure to unmount it first.


ChrisP
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
unise_nlCommented:
It may be a dumb suggestion, but is fat under Linux able to collect information on ctime, mtime, atime, uid, gid and or permission vlags. In my perspective that foo..sh filesysteme technology of our $$ "friends" has no information tags as such.
So my (dumb) response is where on earth should the changed modes be administrated under vfat, as the tags are Not There.
0
lokesh_kumarAuthor Commented:
hi chris,
           thanx a lot, ur suggestion worked , i unmounted the drive first and then mounted it again and the things went fine.
 now i can create and delete files and directories but one problem is still there , now the files which are already already there in the mounted drive but are not having execute permission , i am unable to give execute permission to them , wht should i do to give execute permission to them.
     
0
fluid11Commented:
Let me see the output of "ls -l /mnt/win98" so that I can see exactly what you are talking about.

Try changing the fstab line to 'users,exec', and then umounting/remounting.


ChrisP
0
lokesh_kumarAuthor Commented:
hi chris,
          i will tell u my exact problem
in the mounted drive /mnt/98 i have a program written in c , when i try to execute the a.out file after compiling the c program it does not execute and says tht u donot have the permission to execute .
 wht could be the reason because now i can read and wite in the drive.
0
CleanupPingCommented:
lokesh_kumar:
This old question needs to be finalized -- accept an answer, split points, or get a refund.  For information on your options, please click here-> http:/help/closing.jsp#1 
EXPERTS:
Post your closing recommendations!  No comment means you don't care.
0
TheWeakestLinkCommented:
No comment has been added lately, so it's time to clean up this TA.
I will leave a recommendation in the Cleanup topic area that this question is:
Accept comments from fluid11 as answer
Please leave any comments here within the next seven days.

PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER!

TheWeakestLink
EE Cleanup Volunteer
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.