Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3901
  • Last Modified:

Error getting the Twain data source on a USB Canon Scanner

I got a Flatbed Canoscan FB 630U, and it's only connected through a USB cabel.
When I try to scan I get this error message :
"Error getting the Twain data source. Please check if it's connected properly to your
computer, or confirm if you selected a correct device."

I've tried on win98 and on windows 2000, no luck. I've also tried 2 different cables.
I've remove and reinstalled the scanner, I've download twain_drivers from Canon.dk...
I've also tried different USB ports. And I've tried different programs...Photoshop and Ulead PhotoExpress.
And if I do a test from the scanner on the Control Panel...the scanner reponse to the test and says everything is ok.

But I'm starting to think that maybe the scanner is broken...it's a few years old..

Anyways I hope anyone out there have an idea on how to fix this... :-)

Best Regards
Kollagoll
0
kollagoll
Asked:
kollagoll
2 Solutions
 
MetallimirkCommented:
Download an ASPI reset tool. YOu might have to go to Yahoo.COM and search for the TWAIN Data Source Error as a keyword. Some of those scanner sites have them. That may fix the issue.
0
 
westernerCommented:
Try contacting the company who made the scanner and dowload the lastest driver for your scanner.  I would suggest you also uninstall the original driver and after this has been done make sure that the twain directories in windows are empty.  As always if in doubt backup before uninstalling.  
0

Featured Post

[Video] Create a Disruption-Free Workspace

Open offices have their challenges. And Sometimes, it's even hard to work at work. It's time to reclaim your office and create a disruption-free workspace. With the MB 660, you can:

-Increase Concentration
-Improve well-being
-Boost Productivity

Tackle projects and never again get stuck behind a technical roadblock.
Join Now