Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1412
  • Last Modified:

can't open osf_boot when booting to a recovered root disk

Hi,

I'm in the process of doing a trial disaster recovery from a DS20E to an Alpha Server 1000. On the DS20E I backed up the /, /usr and /var directories. On the Alpha 1000 I did the following:

>>> show bootdef_dev
    bootdef_dev    dka0.0.6.0
>>> show dev
    dka0.0.6.0    DKA0     RZ29B
>>> boot dka400    # boot from tru64 v5.1 cdrom
# hwmgr -view devices
  /dev/disk/dsk6c    RZ29B    bus-0-targ-0-lun-0
# mountroot        # created tape device files tape?_d?
# diskconfig       # set up the root disk dsk6 with a: 256 MB AdvFS; b Swap; g: 200 MB AdvFS and H: 1503 MB AdvFS
# mkfdmn -orF /dev/disk/dsk6a root_domain
# mkfset root_domain   root
  (I did this for the other two domains (/usr and /var))
# mount root_domain#root  /mnt
# cd /mnt
# vrestore -xvf /dev/ntape/tape0_d1
  (I restored /usr and /var to their respective domains)
# vi /mnt/etc/fstab  # commented all other drives except those for root
# cd /mnt/etc/fdmns
# cd root_domain
# rm *
# ln -s /dev/disk/dsk6a  dsk6a
# cd usr_domain
# ln -s /dev/disk/dsk6g  dsk6g
# halt
>>> boot dka0 -fl s

I then recive the following:
****************************
jumping to bootstrap code
can't open osf_boot

halted CPU 0

halt code = 5
HALT instruction executed
PC20000030
boot failure
>>>
****************************

Also, when I booted agin from the cdrom I was not able to mount the root_domain without having to do mkfdmn and mkfset. On mounting there was no data and so I had to do a vrestore again to see if the osf_boot was copied to dsk6a (it was). How do you re-mount the domains withiout having to go through the whole process of mkfdmn, mkfset and vrestore.

Regards

Russ
**********************************************************
I have manged to solve the above problem with osf_boot. But now doing the following I get another problem:

>>> show bootdef_dev
   bootdef_dev    dka0.0.6.0
>>> set bootdef_dev ""
>>> boot dka400
# hwmgr -view devices
# dn_setup -install_tape
# hwmgr -view devices
  /dev/ntape/tape0
# mkfdmn -orF /dev/disk/dsk6a root_domain
# mkfset root_domain root
# mkfdmn -orF /dev/disk/dsk6g usr_domain
# mkfset usr_domain usr
# mkfset usr_domain var
# mount -t advfs root_domain#root /mnt
# cd /mnt
# vrestore -xf /dev/ntape/tape0_d1
# mount -t advfs usr_domain#usr /mnt/usr
# cd /mnt/usr
# vrestore -xf /dev/ntape/tape0_d1
# mount -t advfs usr_domain#var /mnt/var
# cd /mnt/var
# vrestore -xf /dev/ntape/tape0_d1
# disklabel -r dsk6a > /tmp/label
# disklabel -t dsk6a -r -F dsk6a /tmp/label RZ29B
# cd /mnt/etc/fdmns/root_domain
# rm *
# ln -s /dev/disk/dsk6a dsk6a
# cd ../usr_domain
# rm *
# ln -s /dev/disk/dsk6g dsk6g
# cd /mnt/etc
# ed fstab
  Commented out all except those entries for
  root_domain#root, usr_domain#usr and usr_domain#var
# fasthalt -y
>>> boot dka0 -fl s -fi genvmunix
   I can see the / but there is nothing on /usr and /var
# bcheckrc
  ********************************************************
  warning the disklabel for /dev/disk/dsk6g does not exist
  or is corrupted
  usr_domain#usr on /usr: I/O error
  warning the disklabel for /dev/disk/dsk6g does not exist
  or is corrupted
  usr_domain#var on /usr: I/O error
  ********************************************************

Russ
0
drruss
Asked:
drruss
2 Solutions
 
charlie250Commented:
I am curious as to why you are doing things this way..
The way I would approach it is to:
1. Do a fresh install on the As1000 setting up AdvFS domains as you need them.
2. Restore your old data from the DS20 and NOT restoring
/etc/fdmns and /etc/fstab , /etc/sysconfigtab, /vmunix and /dev.
There may be some other files you may not want but I can't think of anything off hand..

This should bypass your issues..
Charles
0
 
zvfs221Commented:
1. boot from installation media
2. recreate root filesystem and make disk bootable
3. restore root filesystem under /mnt
[--cut--]
# cd /mnt/etc
# rm dec_*
# cp dfsl.dat dfsl.bak
# cp dfsc.dat dfsc.bak
# cat /dev/null >dfsl.dat
# cat /dev/null >dfsc.dat
# shutdown -h now
P00>>>b -fl s -fi genvmunix <bootdef_dev>
# mount -u /
# dn_setup -init
# dsfmgr -K
[--cut--]
4. make /usr /var filesystems and restore them
5. make new customized kernel with doconfig
6. alter fstab
7. cross fingers and reboot with new kernel
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now