Slow LAN connection...

The problem is this....

I have 2 computers (A and B) connected to each others with cat 5 crossover cable. My computer A has 2 NICs and computer B has 1 NIC and computer B is connected to www through the computer A.

Both computers are using windows XP professional. Now when I try to move a movie about 700MB from computer to another it goes only about 1.5MB/s which is my cablemodems top speed. Isn't it suppose to go about 100MB/s ???

Computer A NIC 1 which is for the Computer B, is set to 100MB full dublex and computer B NIC is also set to 100MB full dublex.

In "my network places" I've set computer A to use 192.168.0.1 and computer B *.*.*.2 . I have also tried to change these to opposite but it didn't help. Computer A other NIC is using DHCP.

It's really anoying to move one movie when it takes 30 minutes.

Could it be broken cable???
Which connection should I set the Internet shareing option?
Any advices or does anyone else have this same problem???

thanks =)

MummuAsked:
Who is Participating?
 
nigelcwmConnect With a Mentor Commented:
Hi
It is possible that a) you have one faulty card or 2) if your cards are of a different make their timing is at the far ends of the allowable. If either is the case the packets could be being resent as when one card sends the other stats to get the packet but then the timing drops out of sync and so a resend request is made.
If you have another card try swapping one and if that does not work then try the other.
0
 
vthoangCommented:
did you use a cable modem speed tweaking program?
if you did you may have placed the settings in the global registry parameter instead of per interface.
either way you can try changing the settings yourself..
good setting for 10/100MB lan: (defaults are too conservative)
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters]

GlobalMaxTcpWindowSize
 REG_DWORD
 131400 (decimal)
TcpWindowSize
 REG_DWORD
 131400 (decimal)
Tcp1323Opts
 REG_DWORD
 3
 
0
 
anetworkCommented:
Ethernet is saturated at about 30%, so you will get about 30 Mbits/sec
Allowing a 20% overhead for headers etc, this gives about 24 Mbits/sec, or 2.4 Mbytes/sec
So, your 700 MB file should take about 700/2.4=291 secs, or 4.8 minutes.  Clearly something wrong then.  NB full duplex will make little difference here as the great majority of the data is in one direction.

Examine the stats from the NIC driver, if possible.  Are there lots of errors?  If so, check the cabling.

Perhaps the network is not the bottleneck.  Try a few simple checks:

Examine the %processor usage on both PCs.  Are either of them running at 100%?  If so, something else is causing the problem.
Try, for example, turning off any anti-virus software or firewall software - perhaps this in intefering with the flow of data.
Examine the hard disks, look at the LEDs on each PC.  Are either of them thrashing?  You should see a steady rhythm of LED flashes - first one, then the other, without lots of rattling.

How are you tansferring the file?  Are you using \\servername\sharename, or using ftp?  

0
The new generation of project management tools

With monday.com’s project management tool, you can see what everyone on your team is working in a single glance. Its intuitive dashboards are customizable, so you can create systems that work for you.

 
anetworkCommented:
...Internet Connection Sharing should be set on the NIC that connects to your cable modem.
0
 
ViRoyCommented:


im wondering if your computer is using NETBIOS via UDP,
that would definatley explain the slow speeds.
if your using TCP on both internal without static ip ranges within the same subnet... then this is the problem.

install IPX/SPX on the internal nic's - MUCH faster protocol for a LAN



0
 
ViRoyCommented:

hmm come to think of it ICS will setup DHCP on the internal nic...
can your other computer browse the internet fine?

both internal nics should be using a 192.168.0.1-2 address... however its possible that ICS needs a little extra config for a multi-homed PC.
check both internal IP, subnet and gateway

and go ahead and try IPX/SPX on both internal
0
 
MummuAuthor Commented:
First of all...

The first comment didn't work out but thanks anyway =).
Secondly... that ipx/spx-thing didn't work and it's still very slow. And both internal nics are using 192.168.0.1-2 addresses. Tomorrow I'll try to change the cards places and I'll see what happens.

And for ANETWORK... those didn't help either but I'll also try to get a new cable from some of my friends. And I'm using the \\servername\sharename - thing through the windows XP---> My network places----> Shared docs computer 2....

Thanks guys. I'll let you know what happens

-Mummu (FIN)-
0
 
newyhouseCommented:
Sounds to me like the file is possibly going through your cable modem.  Why would this happen?  Try unplugging your connection to the cable modem and seeing if the file will still transfer- at least then you'll know if it is in fact going to the cable modem for some reason...  

Just tryin' to rule something out-

Steve
0
 
ViRoyCommented:
you say your using a crossover cable...
did you make this cable yourself?
and if so, exactly what pins did you switch.
0
 
MummuAuthor Commented:
Problem solved and credits goes to the "nigelcwm". The problem was NIC B in my computer A. I changed the cable between those 2 NIC and now the movie goes in 7 minutes (about). I tried it earlier today and it took 92 minutes to move one movie =)

Thanks to all you guys

-Mummu-
0
 
nigelcwmCommented:
Mummu
Did the card or the cable change sort out the problem? Your answer left me confused.
N
0
 
ViRoyCommented:
lol well duh
your crossover cable was incorrectly switched then, 100mbps cable is special and requires more out of a cable then 10mbps
you were getting excessive collisions, load balancing would have quite possibly solved the problem, easier to replace the cable though
0
 
CleanupPingCommented:
Mummu:
This old question needs to be finalized -- accept an answer, split points, or get a refund.  For information on your options, please click here-> http:/help/closing.jsp#1 
EXPERTS:
Post your closing recommendations!  No comment means you don't care.
0
 
juliancrawfordCommented:
No comment has been added lately, so it's time to clean up this TA.
I will leave the following recommendation for this question in the Cleanup topic area:

Accept: nigelcwm {http:#8221654}

Please leave any comments here within the next seven days.
PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER!

Julian Crawford
EE Cleanup Volunteer
0
All Courses

From novice to tech pro — start learning today.