• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1810
  • Last Modified:

Plugging in a USB Device Causes XP to reboot

I use XP Home Edition and a USB 2.0 internal card in my computer.  USB has always worked fine until recently.  Now, whenever I plug in a USP device, XP immediately reboots the computer and then the device  can be accessed successfully.  Prior to this, a USB device would work fine without causing a reboot.  Whatever device I plug in, such as an external ZIP drive or a USB mini-drive, the crash and reboot occurs.  I have not recently installed any new hardware or software that should affect this. Any thoughts would be appreciated.
0
bobengel
Asked:
bobengel
1 Solution
 
CrazyOneCommented:
Not sure what the cause is but the following may fix it

HOW TO: Restore the Operating System to a Previous State in Windows XP
http://support.microsoft.com/default.aspx?scid=kb;en-us;306084


The Crazy One
0
 
CrazyOneCommented:
Also open the Device Manager and see if any conflicts are being reported. If so this may be were the problem is and it might just reqiure deleting the item and rebooting so XP can reinstall the driver.
0
 
CovenantCommented:
This could be a power related issue - an excessive current draw can cause systems to reboot.

It could be that your PSU has always been 'on the edge' and has degraded enough to cause this behaviour. If you cannot resolve this by software means or by system restore to an earlier date I would try swapping the PSU for a GOOD quality one of at least 400W (future-proofing).

HTH
0
 
Cookie_man_OCNZCommented:
its xp home it doesnt like any extension devices such as usb devices being pluged in when its running does it for me when i plug in an extension for dvi :/
0
 
bobengelAuthor Commented:
Covenant: I tend to accept your answer.  Some time ago, I did replace the noisy power supply with a quiet one that is rated at 350w.  Although the problem did not occur immediately after that, it still may be "on the edge" as you stated.  One thing I will try to prove this is to unplug the minidrive device that I always have connected and see if plugging in a single device still causes the reboot. However, since the ZIP drive has its own power supply, I don't think it uses the USB power as some other devices do.  Also, I will try plugging in the USB devices into the 1.1 sockets that are on the MB instead of the 2.0 card sockets.  If the problem goes away, it could be the USB 2 card but I doubt that.

CrazyOne: No conflicts in Device Manager.

Cookie_man_OCNZ": Do you now have XP Professional and did that cure the problem?  I didn't think the the two versions differed that much, especially as what could affect that particular issue.  I have an uninstalled XP Professional still sealed in the box which I could install but this might be the same as going back to a previous OS state as suggested by CrazyOne so I would never really know which was the real cure.

Thanks to for the responses


0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now