Unrecognised HDD Formating Issues!

Please help!

I have a second hard drive that has been working happily for a long while now, and then today I did a WinXP system restore point, and then restored to that point, and now my computer will not read from my second hard drive. It says it is not formatted, do I want to format it now?
No, I don't think I do - wouldn't that also format off my data?

Steps taken so far:

Uninstallation of the disk driver - rebooted, it automatically installed the driver again with no benefit
Booted to Linux - When attempting to mount the drive it said it had an incorrect file system.
restored to previous days restore point - problem persists


This data is extremely important, how can I get my computer to read it without re-formatting it, how can it need it? There is 30gb of data still on the drive...isn't there?

Apologies for low point value - it's all I have left
danebdonAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

CeLLuSCommented:
Yes you're correct, if you format you will delete all the data on that hard drive if it hasn’t been deleted already.  What was this drive formatted as before this issue, FAT32?  Why did you do a restore?  I would first try using a boot disk to see if I can see anything at all on that drive.  I have to assume that there is at least 1 partition on that drive if XP is asking you to format and that most likely something have happened to the FAT Table on that drive, so to be honest with you all your data is lost, just kidding.   Actually there are many tools out there that can help you retrieve your data.  Check this site out (http://www.systweak.com/fat32/fat11.htm), I personally like Norton SystemWorks.   Before I you go that route consider taking that drive out and placing it into another pc that you know is functioning correctly.  

Good Luck, I hope I helped a little
0
msa2003Commented:
Was the drive a dynamic volume (I guess no)? If you have a default static volume (not stripped or mirror) it's easy to restore some data (depends on what system areas are damaged) using special automated file restoration utilities. Ofcourse, if you will format the drive it will be much harder (or even impossible) to restore the data.
0
danebdonAuthor Commented:
An update:

The drive can be read from fully in DOS using a boot Win 98 boot disk. All the files are there.
I have tried Powerquests Lost and Found and it tells me the master boot record is corrupted. The drive is also reported to be offline by WinXPs system restore settings although this may be completely irrelevant. It is enabled, I know that.
It is viewable from Explorer as a Local Disk but when I try to access it I'm told it's not formatted.

I can copy over files to another hard disk using copy, but I can't use xcopy.

Is there no easy solution to repairing the master boot record or the FAT?

Thanks
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

CeLLuSCommented:
Have you tried running a scandisk from the Win98 boot disk on that second drive?

Here is a site that shows you how to use the recovery console to repair the master boot record with the fixmbr command.
 
http://www.wown.info/j_helmig/wxprcons.htm

But to be honest with you I'm not sure this will solve your problem, this can also cause additional problems if used incorrectly.

What type of Hard drive is it and what type of system is it?
0
danebdonAuthor Commented:
Thanks Cellus,
I've been all day now trying to fix this now and it's nice to have some help!

I'll try a scandisk on the drive now from the boot disk. When I try a scandisk from WinXP it just closes without any error message.

The hard disk is a western digital and my system is

1st HDD -- Win XP Partition - Linux Partitions
2nd HDD -- The Data
0
danebdonAuthor Commented:
Update:

Ran win98 scandisk and the second hdd passed with no errors found even though master boot record is reported corrupted by Powerquests Lost and Found.
Speaking of which, I did try to recover all the files to a seperate disk but when I got to selecting a destination disk the other hard disks had disappeared.
0
CeLLuSCommented:
Have you tried removing the hard drive and placing it into another PC that doesn't have any issues.  This way you can found out if it is a XP issue or a hard drive issue.  BTW I would check the IDE Cables and make sure they are OK and secure.  Might also want to check the Western Digital support website to see if they have documented any issues related to yours.  While you're there download Data Lifeguard Tools and run them on your disk.  Might also want to check microsoft windows update for any update patches.


Good Luck

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
pratiganCommented:
Question:  When you restored back to a prior point in time, was that prior point in time a time before the second harddrive was installed ??  Meaning- you went back to a pokint in time that could possible be a point when your system did not have a second harddrive, thereby it no longer recognizes the second harddrive as it wasn't there at that prior point.
0
danebdonAuthor Commented:
Update:

Using Drive Rescue I searched for logical partitions and was able to retrieve my data from the hard disk via a very laborious saving process.
I was surprised at how little information there is availble on the net for rescuing data stored on a disk on which the boot sector has become corrupted.

Even GRC's Spinrite failed to even analyse the data on the disk. It benchmarked it but could not analyse it.
0
danebdonAuthor Commented:
Thanks for your help and all your effort, Cellus.

The solution to my problem can be found in my last comment.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Storage

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.