?
Solved

Running my game server on my inside network, not being seen on internet (Cisco 2600)

Posted on 2003-03-29
3
Medium Priority
?
299 Views
Last Modified: 2010-03-19
I am running a game server on my internal lan, this is working correctly and works on the internet if I plug my PC in directly. I think the problem is due to NAT running on my cisco 2600 (config below). Because when I use my router, it isn't being seen on the list of internet servers as it should. What do I need to add to my config to allow it to be seen on the net.

The port my game uses is 14567 and the local IP is: 192.168.137.2
The IP address that my router picks up is 80.0.159.27

Any help would be much appreciated.

Thanks
James

Current configuration : 1301 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
!
ip subnet-zero
!
!
ip domain round-robin
!
no call rsvp-sync
!
!
interface Ethernet0/0
 description outside DHCP DSL interface
 mac-address 0002.a560.b487
 ip address dhcp
 ip access-group 100 in
 ip nat outside
 no ip mroute-cache
 no keepalive
 half-duplex

interface Ethernet0/1
 description Inside static Interface to my LAN
 ip address 192.168.137.254 255.255.255.0
 ip nat inside
 full-duplex
!
ip nat inside source list 1 interface Ethernet0/0 overload
ip classless
ip route 0.0.0.0 0.0.0.0 Ethernet0/0
no ip http server
!
!
access-list 1 permit 192.168.137.0 0.0.0.255
access-list 100 permit ip any any
!
dial-peer cor custom
!
!
!
line con 0
line aux 0
line vty 0 4
 timeout login response 300
 password
 login
!
end
0
Comment
Question by:jbartosik
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
3 Comments
 
LVL 2

Accepted Solution

by:
Todos earned 200 total points
ID: 8230851
Jbartosik,

What you are doing with above config actually is called PAT instead of NAT. To perform the NAT operation port redirection, use the following command on your router besides the config you allready have :

ip nat inside source static tcp 192.168.137.2 14567 80.0.159.27 14567 extendable

This should forward comming in on port 14567 on your ISP IP to your internal server.

grtz


Todos
0
 

Author Comment

by:jbartosik
ID: 8231091
Todos, thanks for your help, but it didn't work, I'm still not seeing my server being broadcast. Any other ideas?

Thanks
James

interface Ethernet0/0
 description outside DHCP DSL interface
 mac-address 0002.a560.b487
 ip address dhcp
 ip access-group 100 in
 ip nat outside
 no ip mroute-cache
 no keepalive
 half-duplex
 no cdp enable
!
interface Ethernet0/1
 description Inside static Interface to my LAN
 ip address 192.168.137.254 255.255.255.0
 ip nat inside
 full-duplex
!
ip nat inside source list 1 interface Ethernet0/0 overload
ip nat inside source static tcp 192.168.137.2 14690 80.0.159.27 14690 extendable
ip nat inside source static tcp 192.168.137.2 14567 80.0.159.27 14567 extendable
ip classless
ip route 0.0.0.0 0.0.0.0 Ethernet0/0
no ip http server
0
 

Author Comment

by:jbartosik
ID: 8231395
Ah fixed it, I needed to enable a second port. Thanks for your help.
0

Featured Post

Get proactive database performance tuning online

At Percona’s web store you can order full Percona Database Performance Audit in minutes. Find out the health of your database, and how to improve it. Pay online with a credit card. Improve your database performance now!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Most of the applications these days are on Cloud. Cloud is ubiquitous with many service providers in the market. Since it has many benefits such as cost reduction, software updates, remote access, disaster recovery and much more.
This month, Experts Exchange’s free Course of the Month is focused on CompTIA IT Fundamentals.
Viewers will learn how to connect to a wireless network using the network security key. They will also learn how to access the IP address and DNS server for connections that must be done manually. After setting up a router, find the network security…
Monitoring a network: how to monitor network services and why? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the philosophy behind service monitoring and why a handshake validation is critical in network monitoring. Software utilized …
Suggested Courses

765 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question