?
Solved

Windows XP Home & DirectX 9  Updates: "Not Passed Windows Logo Testing" = Not Installable.  WHA-AT??

Posted on 2003-03-29
5
Medium Priority
?
1,268 Views
Last Modified: 2008-01-09
RE: Windows XP Home & DirectX 9  Updates: "Not Passed Windows Logo Testing" = Not Installable.  WHA-AT??

First, some sys FYI:

- Win XP Home (version 2002, SP 1)
- Pentium IV, 845 chip, 1.6 Ghz
- 768 Mb Kingston SDRAM
- Two 7200 rpm HDs (20 + 40 Gig, non-dual boot)
- AOpen AX4BS Pro motherboard
- 19" ADI monitor
- Most CPU intensive apps: Steinberg SX (Music Production), Adobe After Effects (& other vid/graphics apps)


Hello:

Hopefully self-explanatory subject line.  Have OEM XP, and nothing on Microsoft site I can tell on issue. Problem is only recent -- downloads worked for both, but once installation kicks, similar error message:


>> (Red circle w/ white "X" icon) "The software you are installing has not passed Windows Logo testing to verify its compatibility with Windows XP (tell me why this testing is important).

This software will not be installed.  Contact your system administrator." <<

With DirectX, clicking OK, show one more message:

>> "Direct X did not copy a required file." <<  And finally in Installation GUI, "Installation Failed."


However, with Windows Update, I tried again a few times for at one point it had an option to get the exact error code (window with long numeric codes).  But now it simply skips the above message and the IE/Windows Update Window gives me a:

>> (Red circle w/ white "X" icon) "No Updates Were Installed.  The following items failed to install. To try installing them again, click Review and install updates, and then click Install Now again." <<  (Which is pointless.)

____________

What I've attempted to look into to solve this on my own:
 

-- Checked msconfig/Services and "Windows Intall" is enabled as are all other services listed.  Even fired "Windows Install" up from Admin. Console/Services -- from its "Manual" status to "Started."  Still no go on trying to intall.  Obviously something is corrupted or disabled or ?

Now, a while back, I did use an online guide (The ElderGeek.com) to carefully disable certain Services, particularly ones dealing with LAN or networked services since I've got a home stand-alone.  However I think I have done a Windows Update since then, though not 100% sure), so unclear if a Services issue.

Also, "Automatic Updates" Service is disabled, but it clearly states that one can update OS manually -- which I prefer and so do; this avoids being bugged with messages about updates I don't really need, I.e. the regular, more server/network related Critical ones.

I'd rather not blanket-enable all Services again and crowd my Task Manager with running apps and services again just to troubleshoot this.  Besides, problem may not be Services related.

LAST: This forum was critical in my solving the resurrection of an external Barracuda SCSI drive I occasionally use for backups via an Adaptec 2930U card.  While that went well, XP has since had to oddly create a temporary page file (setting  is always 0 Mb for both drives, and I can't change it for some reason.  System crashes after long Internet sessions, but overall, runs fine.

-- Could this last element have anything to do with subject of post?  Not sure if I've made Windows Updates since then, but Updates worked fine prior to that general period.

Any adivice and solution(s) most welcomed.
Thanks.

0
Comment
Question by:sonicsoul
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
5 Comments
 

Accepted Solution

by:
azatar earned 340 total points
ID: 8232967
You should just continue the install windows has that prob on a lot more that DX 9
0
 

Author Comment

by:sonicsoul
ID: 8233263
I did as you suggested, and though fitful, I was able to at least get some XP and Critical updates installed.  Odd, though how it says installation failed, then goes ahead and says installation OK, "Restart computer to finish installation."

As to DiretX 9, I'm not even going to mess with it for now.  Too long a download for the Redistrib. package (32 Mb.) that is recommended if installation problems occur with shorter End User one (8)... to just get the error message again.  Which I've gotten on downloading both versions.

So, partial and most important part of the issue solved.

Last, your statement seemed to infer that this "oddity" is common or at least to be expected with Updates.  If true, I hope Microsoft comes up with some "Critical Fix" Update to fix this buggy critter in their Updates situation :)
0
 

Author Comment

by:sonicsoul
ID: 8233267
Thanks, Azatar.
0
 

Expert Comment

by:azatar
ID: 8234358
np thx 4 the grade
0
 

Expert Comment

by:mckeough
ID: 10532956
The above "Accepted Answer" is incorrect. This is a common and simple problem to fix. All you need to do is right-click on "My Computer". Click Manage>Services and Applications>Services. Right click on the "Cryptographic Services." Click on "Properties." This service is most likely disabled. Make sure it is enabled by making the "Startup Type" in the drop down box "Automatic." Close everything and reinstall Directx 9 again. It should install without any problems. I've had this problem several times, and every time "Cryptographic Services" was disabled.

Yes, Microsoft needs to put something on their website about this issue. I do however know for a fact that Microsoft knows about the problem!
0

Featured Post

Three Reasons Why Backup is Strategic

Backup is strategic to your business because your data is strategic to your business. Without backup, your business will fail. This white paper explains why it is vital for you to design and immediately execute a backup strategy to protect 100 percent of your data.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

There are 2 things you must have in order to connect to the internet behind a router, The "Gateway IP" of the router, which is usually something like 192.168.xxx.1, I've seen routers with default values of: 192.168.0.1, 192.168.1.1, 192.168.11.1, …
When you start your Windows 10 PC and got an "Operating system not found" error or just saw  "Auto repair for startup" or a blinking cursor with black screen. A loop for Auto repair will start but fix nothing.  You will be panic as there are no back…
Two types of users will appreciate AOMEI Backupper Pro: 1 - Those with PCIe drives (and haven't found cloning software that works on them). 2 - Those who want a fast clone of their boot drive (no re-boots needed) and it can clone your drive wh…
Do you want to know how to make a graph with Microsoft Access? First, create a query with the data for the chart. Then make a blank form and add a chart control. This video also shows how to change what data is displayed on the graph as well as form…

770 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question