?
Solved

Problem installing USB Card in Pentium I (PC Chips Motherboard) Computer

Posted on 2003-03-30
10
Medium Priority
?
6,002 Views
Last Modified: 2013-11-09
Hello,

This is my first post on Experts-Exchange and I apologize if it is too long, but I'm not sure what the problem with my computer is.  This site has indicated that I should not worry about giving too much information, so I'll try to keep it as informative as possible without going into unnecessary detail.  (for those of you who just want the jist of my problem I have included a summary at the bottom...)

I own a Pentium I 166MHz non-brand computer with 32MB RAM that is running Windows 98SE.  I bought it quite a few years ago (it came preloaded with Windows 95) and not surprisingly, it did not come with USB ports.  I am very interested in installing USB on it so that I can use one of my USB devices on it as well as use a Wireless USB Network adapter to integrate it with my wireless network at home.

I recently bought a brand new USB 1.0 PCI card for the computer (ADS Technologies, Model #USBX-500-EF) and tried inserting it into an empty PCI slot.  However, when I turn on the computer it will not load properly...it does power on but it "hangs" before displaying anything on the screen.  As soon as I remove the card, the system boots fine.

I tried exchanging the USB card at the store I bought it from but the new card still exhibits the same problem.  In fact, this *exact same* problem also occurred when I tried installing a network interface card months ago. (DLink DFE-530TX)  

I am fully aware that PCI cards must be *completely* inserted into the PCI slot to function, and I have tried using other available PCI slots for my USB card, but this does not solve the problem.

I visited usbman.com and they suggested that the problem may have to do with my BIOS.  The first thing the site told me to check was to make sure that USB is enabled on the BIOS, and I have changed it so that it is *now enabled*.  Unfortunately, this did not seem to change anything (though I'm sure it was probably a good first step).

The second thing the site told me is that if the BIOS is older than 1998, then this is likely to be the source of USB trouble.  I believe this is a strong possibility since my computer was bought in 1996-1997 and aside from this issue, all the PCI slots are functioning perfectly with their devices.

From my research, I am aware that updating the BIOS can be very damaging to the motherboard and it should only be done if necessary.  However, this computer is useless to me if it can't support USB, so I appreciate any professional feedback Experts-Exchange can offer.

I used BIOS Wizard 2.10 to retrieve some information about my BIOS.  This is a snippet of its output:

BIOS Manufacturer: Award Modular BIOS v4.51PG
BIOS ID          : 03/03/97-i430VX-02071997C-00
BIOD Date        : 03/03/97
BIOS OEM Signon  : Release 03/03/1997S
BIOS ROM Size    : Unknown
Chipset          : Intel Triton 430VX rev 2
Super I/O Chip   : UMC/ITE 8669 found at port 108h

(Note: BIOSWizard was not able to detect ACPI or a valid DMI...I'm not sure if this may be the problem)

Unfortunately, I do not have the manual for my motherboard.  However, after some research I realized I had a PC Chips motherboard.  In fact, the PC Chips Lottery website (http://www.stud.fernuni-hagen.de/q3998142/pcchips/pccjs.html) indicated that based on my chipset and available PCI and ISA slots, my motherboard must be one of these models:

A101 v1.1
A101 v1.4
M525/30/35/38/49

But the site also notes that these boards share the same BIOS:
M520,M525,M530,M535,M538,M549,A101 V1.4

So it means that my computer could only be one of two BIOS types:
1. A101 v1.1
2. A101 v1.4, M525/30/35/38/49

The former is highly unlikely because a picture of it looks very different than my motherboard.

The M520 BIOS seems to be the most popular to cover all of the latter types.  This is confirmed by Houston Tech (http://houstontech.topcities.com/586_M5xx/M530_M539/index.html).  As a sidenote, I should also mention that a sticker on my computer's motherboard reads:

  Houston Technologies HT12888A.
  9639A1 1689V

and I know from the PC Chips Lottery that Houston Technologies is affiliated with PC Chips.

I have already read an excellent reference on updating the BIOS from Comp Techs (http://www.comptechs.org/hardware/biosflashingfaq.htm).  I have also obtained the latest Award flasher (Awd814c.exe) and the latest BIOS binary file I could find was the 12-07-98 version from BiosDrivers.com (http://www.bios-drivers.com/drivers/48/48792.htm).

However, when I ran the Award flash program with the 1998 Award BIOS file from DOS mode, the program hanged and kept blinking "Please Wait !" (I waited for three hours...nothing)  I turned the computer off, back on, and nothing changed.  It was as if I never ran the Award flash program.

Summary
=======
- I have a Pentium I 166MHz non-brand computer with 32MB of RAM.
- I am having trouble getting USB to work.  My system "hangs" when I insert the card into an available PCI slot and power it on.
- I have tried exchanging the card, using a different PCI slot and I have enabled USB in the BIOS.  My computer uses an Award BIOS for a PC Chips Motherboard whose BIOS Type shares with the M520 model.  The chipset is an Intel Triton 430VX.
- I have tried updating the BIOS using an Award flash program but this program also hangs and does not update my BIOS.

My main question would be:
How can I get USB to work on my computer, given my situation?

If anyone can help me with this problem I would greatly appreciate it.  Thank you for your time in reading this post.
0
Comment
Question by:frozsoul
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
  • 2
  • +2
10 Comments
 
LVL 2

Expert Comment

by:matguy
ID: 8235576
Well, when you say that you enabled USB in the BIOS that has nothing to do with the card you're putting it, that is to enable USB on the board itself, meaning there is probably a headder for it.  Many PcChips boards that I've dealt with had the USB, PS/2, and IRDA headders in one block that goes to a single rear slot card connected by a cable.  This card is known as an ATX Form Factor card and looke like: http://www.abcd.com.au/motherboard/pc_atxformcard.jpg

Now, it's hard to say if your particular board supports this card, but I would probably be willing to bet that there is some kind of USB header on the board, although it's hard to say if it's going to be labeled.  But, reguardless, that is the function your BIOS is referring to, and if you're putting in your own PCI USB card and ignoring any on board USB you'll likely want to "DISABLE" the on board USB in the BIOS, which may also magically fix your peoblem as it should free up an IRQ for you if a conflict is the problem.
0
 
LVL 1

Expert Comment

by:baz_can_fix_it
ID: 8235591
Hi...sorry it was too much to read so I haven't read the lot... sounds like you have IRQ problems... what else do you have in there... try taking other parts out such as soundcards, scsi card, network card etc...also check the Bios see if your plug and play is on auto if it has that option...also try moving it to a diffrent pci slot... Cheers
0
 

Author Comment

by:frozsoul
ID: 8240646
Thank you for your comments so far.  Again, I apologize for the length of my post.

matguy: I will check out for any onboard USB, although I don't recall seeing that ATX Form Factor card.  (My system does not have PS/2 connector anywhere)  Is that card supposed to be connected to a PCI slot?
- Regarding the USB BIOS issue, when I first installed it USB was disabled in the BIOS, and I had the exact same problem then as well.

baz_can_fix_it: I will try taking out any unnecessary cards and see if that helps.

* The IRQ conflict sounds like a possibility.  How can I tell if I have a conflict if the system won't turn on when the card is installed?

Thanks again for any help.
0
 [eBook] Windows Nano Server

Download this FREE eBook and learn all you need to get started with Windows Nano Server, including deployment options, remote management
and troubleshooting tips and tricks

 
LVL 2

Expert Comment

by:matguy
ID: 8241375
The ATX Form Card may not be installed is what I'm getting at, so obtaining one may help you if your board provides the correct plug.  The plug will look somewhat like a Floppy connector on the board, just smaller, which a cable will stretch from the board to the ATX Form Card.

As far as resolving IRQ confilcts when the board won't power up, that can be a hard one being you don't know what IRQ the PCI USB card is requesting, but being PCI it shouldn't be hard set to take any one IRQ and it should be flexible, so the IRQ conflict idea ends up being a stab in the dark with a route to fix also being a stab in the dark, meaning that even if that does end up being the problem it can be a long trial end error proceedure to try to fix it.

It's just real hard to do anything with being it refuses to post with the card plugged in.
0
 
LVL 1

Expert Comment

by:baz_can_fix_it
ID: 8241911
Hi Frozoul As far as the IRQ goes matguys explanation is very much right...I actually installed one yesterday and I was surprised it was using IRQ 9 as well as 15...The PC would turn on but it wouldn't boot... took the sound card out and reset the bios it solved the problem on that PC...but in yours could be any of the cards...as I said try taking them out and reset your bios might help...Good Luck
0
 
LVL 16

Accepted Solution

by:
Kyle Schroeder earned 300 total points
ID: 8242024
The card probably requires a PCI v2.1 or higher compatible slot, which a Pentium I does not have.  Yes, I've confirmed it at www.adstech.com:
Q2) What are the specs for the USB PCI port? ?  
A) Our USB PCI CARD conforms and qualifies for both USB SPECIFICATION 1.0 and 1.1. The PCI Implementation is PCI 2.1.
Also the Card is OHCI complaint.

This is why the system won't boot with the card installed; its trying to recognize it to determine what it is and is unable to.
 
I think you're going to have to face the facts that your system just won't work properly with USB (though if you can find the pinout for the (hopefully) onboard USB header you might be able to use that).  I have a feeling a good portion of your CPU time would be taken up if you were using a USB wireless connection also due to the processing required.  YOu are also burdened by a motherboard made by an absolutely terrible company (PCChips/ECS-Elitegroup).  As far as flashing the BIOS, you probably need an older version of the flash program that works properly with the FlashROM on your system.

I don't generally advise throwing money at the problem ("Go buy 3 other PCI USB cards", etc), or have a "give up now and save yourself the headache" attitude, but I think in this case you're just going to need to upgrade the system to something less than 6 years old.  The big OEMs (Gateway, HP, Compaq) are all selling very nice performing (no comparision to your current system, really) systems which you can get for <$500 or so (check Dell's refurb/return store for really great deals at http://www.dell.com/us/en/dfh/default.htm !) or your local PC shop to see if they have an old Pentium II 450 or so you can get for very cheap.  See here for a Dell:
http://outlet.us.dell.com/Dispatcher?target=SpecPage&serviceTag=DDBMJRG9&sessionID=2IN88Aqs!-1738043025!1790888040!1049152828223&tgtSeg=I

-dog*
0
 
LVL 16

Expert Comment

by:Kyle Schroeder
ID: 10093270
I think there is no solution to this problem other than upgrading the whole system.  Clearly this motherboard has issues with newer PCI cards as evidenced by frozsoul's comment that a DLink NIC caused the same problem (and also requires PCI 2.1 compliance)

I feel my answer is correct, there is no fix.

-dog*
0
 
LVL 14

Expert Comment

by:FriarTuk
ID: 10831085
No comment has been added to this question in more than 21 days, so it is now classified as abandoned.  I will leave the following recommendation for this question in the Cleanup topic area:

Accept: dogztar

Any objections should be posted here in the next 4 days. After that time, the question will be closed.

FriarTuk, EE CleanUp Volunteer
0

Featured Post

Flexible connectivity for any environment

The KE6900 series can extend and deploy computers with high definition displays across multiple stations in a variety of applications that suit any environment. Expand computer use to stations across multiple rooms with dynamic access.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Monitor input from a computer is usually nothing special.  In this instance it prevented anyone from using the computer.  This was a preconfiguration that didn't work.
Stuck in voice control mode on your Amazon Firestick?  Here is how to turn it off!!!
The viewer will learn how to successfully download and install the SARDU utility on Windows 8, without downloading adware.
The viewer will learn how to successfully download and install the SARDU utility on Windows 7, without downloading adware.
Suggested Courses
Course of the Month8 days, 12 hours left to enroll

764 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question