[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 305
  • Last Modified:

Setup sound card under Mandrake Linux 9

Hi, I'm trying to get my sound card setup under mnadrake 9. I have a KT3 Ultra2-R motherboard with onboard sound. I want to get the onboard sound working. The on board soundcard is a VT8233 AC97. I tried getting drivers from VIA's web site but they only support Mandrake 8.2 and when I try to install the driver sfrom their site I get a message saying Wrong Kernel Version. When I just try to play a mp3 file in XMMS I get a message saying the sound device is busy. When I try to configue the sound server I get a message saying again that the sound device is busy. On VIA's web site they said to make the following changes to /etc/modules.conf...

alias sound-slot-0 snd-card-via8233
post-install snd-slot-0 snd-pcm-oss

I made the changes but still no luck. I have the speakers plugged in right and I hear a continious clicking. When I try to configure the sound server the clicking stops for a second but other than that I can't get it to do anything. I tried the sndconfig program but it says my sound card is not supported. Mandrakes web site says it is...
Can anyonme help?
Thank you in advance.
0
Xcalabers
Asked:
Xcalabers
  • 3
1 Solution
 
XcalabersAuthor Commented:
[root@babyblue root]# cat /proc/asound/cards
0 [card0          ]: VIA8233 - VIA 8233
                     VIA 8233 at 0xc800, irq 22

I don't know if this will help someone help me but I was reading a diffrent article on setting up a sound card and it said this was a way to detect your card. Sorry... I'm a little new with linux
0
 
bakameCommented:
I'm new to Linux myself and I had problems setting up the sound for Mandrake 9.0 and I hope this will help you...
Edit /etc/modules.conf as follows:
If "lspcidrake" shows a sound facility and /etc/modules.conf has one or more sound aliases, AND volume controls are set high enough to hear sound if it is playing.
Use lspcidrake and the modules information to hunt down a driver for the sound at
file:/lib/modules/2.4.18-6mdk/kernel/drivers/sound
Try taking out the sound configuration shown in /etc/modules.conf and substituting
alias sound (modulename)
stripping the .o.gz from the name of the file you want to try.
It is best to first try (in a superuser terminal window)
# chkconfig --del alsa
# modprobe (modulename)
If you get error messages, then your driver choice is incorrect and you move on to the next on your list of candidates, until you find one that installs or run out of modules.
Once tha alias is found,
"alias sound (modulename)" replaces the two former lines and then everything should work.
save /etc/modules.conf and reboot. You should now hear something.
0
 
XcalabersAuthor Commented:
Thank you!!! It worked the first try. I ended up using "alias sound ac97" and just commenting out the other lines that refered to the sound card.
0
 
XcalabersAuthor Commented:
Thank you again.
0

Featured Post

The new generation of project management tools

With monday.com’s project management tool, you can see what everyone on your team is working in a single glance. Its intuitive dashboards are customizable, so you can create systems that work for you.

  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now