?
Solved

Setup sound card under Mandrake Linux 9

Posted on 2003-03-30
4
Medium Priority
?
298 Views
Last Modified: 2013-12-15
Hi, I'm trying to get my sound card setup under mnadrake 9. I have a KT3 Ultra2-R motherboard with onboard sound. I want to get the onboard sound working. The on board soundcard is a VT8233 AC97. I tried getting drivers from VIA's web site but they only support Mandrake 8.2 and when I try to install the driver sfrom their site I get a message saying Wrong Kernel Version. When I just try to play a mp3 file in XMMS I get a message saying the sound device is busy. When I try to configue the sound server I get a message saying again that the sound device is busy. On VIA's web site they said to make the following changes to /etc/modules.conf...

alias sound-slot-0 snd-card-via8233
post-install snd-slot-0 snd-pcm-oss

I made the changes but still no luck. I have the speakers plugged in right and I hear a continious clicking. When I try to configure the sound server the clicking stops for a second but other than that I can't get it to do anything. I tried the sndconfig program but it says my sound card is not supported. Mandrakes web site says it is...
Can anyonme help?
Thank you in advance.
0
Comment
Question by:Xcalabers
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
4 Comments
 

Author Comment

by:Xcalabers
ID: 8234523
[root@babyblue root]# cat /proc/asound/cards
0 [card0          ]: VIA8233 - VIA 8233
                     VIA 8233 at 0xc800, irq 22

I don't know if this will help someone help me but I was reading a diffrent article on setting up a sound card and it said this was a way to detect your card. Sorry... I'm a little new with linux
0
 

Accepted Solution

by:
bakame earned 500 total points
ID: 8236334
I'm new to Linux myself and I had problems setting up the sound for Mandrake 9.0 and I hope this will help you...
Edit /etc/modules.conf as follows:
If "lspcidrake" shows a sound facility and /etc/modules.conf has one or more sound aliases, AND volume controls are set high enough to hear sound if it is playing.
Use lspcidrake and the modules information to hunt down a driver for the sound at
file:/lib/modules/2.4.18-6mdk/kernel/drivers/sound
Try taking out the sound configuration shown in /etc/modules.conf and substituting
alias sound (modulename)
stripping the .o.gz from the name of the file you want to try.
It is best to first try (in a superuser terminal window)
# chkconfig --del alsa
# modprobe (modulename)
If you get error messages, then your driver choice is incorrect and you move on to the next on your list of candidates, until you find one that installs or run out of modules.
Once tha alias is found,
"alias sound (modulename)" replaces the two former lines and then everything should work.
save /etc/modules.conf and reboot. You should now hear something.
0
 

Author Comment

by:Xcalabers
ID: 8239769
Thank you!!! It worked the first try. I ended up using "alias sound ac97" and just commenting out the other lines that refered to the sound card.
0
 

Author Comment

by:Xcalabers
ID: 8239773
Thank you again.
0

Featured Post

Understanding Linux Permissions

Linux for beginners: How to view the permissions associated with files and directories and also how you can change them.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

How many times have you wanted to quickly do the same thing to a list but found yourself typing it again and again? I first figured out a small time saver with the up arrow to recall the last command but that can only get you so far if you have a bi…
SSH (Secure Shell) - Tips and Tricks As you all know SSH(Secure Shell) is a network protocol, which we use to access/transfer files securely between two networked devices. SSH was actually designed as a replacement for insecure protocols that sen…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial
Suggested Courses
Course of the Month14 days, 18 hours left to enroll

770 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question