• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 342
  • Last Modified:

after change ip address,apache become slow

Hi,
 I am a beginner.I use redhat8.0+apache(rpm)+sendmail,it worked good before.
  After change ip,apache become very slow. Default page takes me 40 seconds(0.1s before).
  I checked apache error_log,a new error"directory index is forbidden by rule...."appears after ip change.
  Thanks.
   
0
swm9999
Asked:
swm9999
1 Solution
 
ag0nyCommented:
This looks like a problem with the name resolution. Looks like Apache is trying to resolve the IP where the requests come from, but it is unable to do so and it doesn't reply until the DNS query timeouts.

Please make sure that you updated /etc/hosts after the IP change.
0
 
swm9999Author Commented:
I have sloved this problem.
I made a mistake in dns configuration,added a wrong dns IP address.I checked /etc/sysconfig/network-scripts/   /etc/sysconfig/network . After completely removed wrong dns settings,apache is working good now.
Thanks you,agOny.
0
 
burnsj2Commented:
Hi swn9999,
Can you relay some details about what was wrong with your /etc/sysconfig/network-scripts/   /etc/sysconfig/network or other DNS?  I am having a similar problem and can't seem to crack it.
Thanks.
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now