Dreamweaver: Brackets in HTML Reverting to Code for Special Characters

I need to put the characters {BTAG} exactly like that into the code in my HTML. I am not concerned about how that looks when viewed in a browser. But sometimes Dreamweaver converts that to %7BBTAG%7D. I'm haven't been able to find exactly what triggers Dreamweaver to make that change. Maybe it has to do with switching between Code view and Design view.

How can I stop Dreamweaver from making that change.

I would also settle for a macro or action or extension that I can invoke with one or two keystrokes that converts all the instances of %7BBTAG%7D to {BTAG}

Please help me solve this problem.
johnsmith98Asked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
webwomanConnect With a Mentor Commented:
If you enter special characters is DESIGN view, it's assumed you want to see them IN THE BROWSER. So the code to display them is entered. If you enter them in CODE view, it's assumed they're CODE, and they're not changed.

So don't enter special characters in DESIGN view unless you WANT to see them in the browser. ;-)

You should be able to use find/replace and only search CODE to replace them.
0
 
johnsmith98Author Commented:
I now see that what converts causes the change is when I am in code view and I have the properties inspector open and I click on the word that is a link and I click on the link window in the properties inspector. If I do that and then go to code view I can see the {BTAG} has been changed to %7BBTAG%7D.

Maybe not doing that that will help me avoid this problem. Do you have any better/other solutions.

0
 
crchambersCommented:
Dear johnsmith98-

Try this:

1. go into code view.

2. type {BTAG}, but do it in CODE VIEW, not in design view.

3. Now when you go to design view, DO NOT change it. Any time you need to type a special character literally, don't do it in design view, because design view will translate special characters.

4. If you are still having the problem, check your settings. There should be an option there for changing special characters. I don't have DWMX on this computer right now, so I can't remember exactly. But if you are still having trouble, please post.
0
 
zenlion420Commented:
No comment has been added lately, so it's time to clean up this TA.
I will leave the following recommendation for this question in the Cleanup topic area:

Accept: webwoman {http:#8238901}

Please leave any comments here within the next seven days.
PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER!

zenlion420
EE Page Editor
0
All Courses

From novice to tech pro — start learning today.