?
Solved

Server IP changing in DNS - how do I stop it?

Posted on 2003-03-31
17
Medium Priority
?
262 Views
Last Modified: 2010-04-13
I have set up a Win2000 Server as a test server (we currently use NT4) and installed Exchange 5.5 (we will upgrade to 2003). When I put the server and MX record in DNS the test network works fine. But when I reboot the Win2000 Server the IP address of the server and MX entries in DNS changes to something not part of my network, presumably picking it up from our ISP. The server has a fixed IP on the private network, but we do not have a static IP for our internet access.

How can I keep the IP address from changing in the server and MX entries in DNS on the Win2000 Server?
0
Comment
Question by:awilson1199
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 4
  • 4
  • +3
17 Comments
 
LVL 2

Expert Comment

by:jimshoe
ID: 8240204
Under the network card IP properties, you find a check box that states "register this connections IP address" under the DNS properties tab.

Under the DNS Server Properties you can tell DNS what interface to listen on.  If this server is multihomed and has both interfaces listed then it's picking up DNS information from the external NIC also.  If its not multihomed and only has a LAN NIC then somewhere in your LAN is a DNS server providing the MX record.

Try rebooting the server with the network cable connected to a hub not connected to the network.  Does the new MX and Server record stay in the records then?  This will tell you whether the records are coming from an internal source or are just not being saved.
0
 

Author Comment

by:awilson1199
ID: 8240548
jimshoe

Thanks for the help. The network this Win2000 server is attached to only has 2 machines on it, itself, and a WinXP client.

"Under the network card IP properties, you find a check box that states "register this connections IP address" under the DNS properties tab."

I unchecked this box and it did not help. The server is not multi-homed, only 1 nic. It has an IP of 192.168.0.3. When I register this server in the DNS (installed and running on this server) with this IP address it works fine ie. Outlook will connect to the Exchange server also running on the server. But when I reboot it picks up a completely different IP address.

Any more thoughts?
0
 

Expert Comment

by:asxtc
ID: 8241082
For Servers it is the norm to allocate set IP addresses and not let APIPA allocate the IP address as is happening in your case. Set the IP address of the server in either the network card (NO DCHP) or in the dns snap-in.
192.x.x.x is a private range which (I would bet) is not the range you are using. There are a few server settings that can be set in DNS snap-in that would help...
Andy
0
Ransomware-A Revenue Bonanza for Service Providers

Ransomware – malware that gets on your customers’ computers, encrypts their data, and extorts a hefty ransom for the decryption keys – is a surging new threat.  The purpose of this eBook is to educate the reader about ransomware attacks.

 

Author Comment

by:awilson1199
ID: 8241180
I have the IP address for the server NIC TCP/IP set at 192.168.0.3. My router/gateway to DSL is 192.168.0.1. My DNS setting in both the only client on the network and the server NIC TCP/IP are 4.2.2.1 and 4.2.2.2. My DSL currently uses a dynamic IP address. When I create a server entry in DNS on the server and select the server it resolves the IP address to 192.168.0.3 as it should as that is the IP address of the NIC in the server. But when I reboot the server the server record in DNS resolves to 209.x.x.x, even though the server IP is still 192.168.0.3.
0
 
LVL 2

Expert Comment

by:jimshoe
ID: 8242308
Check the binding order.  Under network connections/advanced properties, verify that tcp is bound to the lan network adapter.

HOW TO: Change the Binding Order in Windows 2000
http://support.microsoft.com/default.aspx?scid=kb;en-us;266771
0
 
LVL 51

Expert Comment

by:Netman66
ID: 8242588
OK, here is what to do.

The DNS settings on both the client and server should point to your server.

If you want to resolve internet stuff too, then delete the root zone (the "." - period) on your DNS server - restart the DNS services and set up the Forwarders tab (right-click the servername in DNS management, choose Properties) to point to your ISP's DNS servers.

Also, double check the Interface tab to make sure that DNS is only listening on your internal network.

See what happens.


0
 

Author Comment

by:awilson1199
ID: 8266112
OK, none of this is working, when I reboot the Win2000 server the Name Server listed in the Forward Loookup Zone picks up a different DNS IP address which prevents my Outlook clients from accessing the Exchange 5.5 server running on the same server.

Can anyone tell me how to stop the Name Server in the Forward Lookup Zone from picking up a different IP address when the system boots?
0
 
LVL 51

Expert Comment

by:Netman66
ID: 8266596
Can you identify the address?  Does it belong to you or is it your ISP's?

Also, make sure the internal NIC has NO gateway.  DNS should be itself only.  If you are running DHCP, make sure the option for name server is only your DNS address.

External NIC, gateway, DNS and IP supplied by ISP.  Uncheck MS networks, disable NetBIOS over TCP/IP, and uncheck register in DNS.

In DNS:

Expand your server, then the Forward Lookup Zone, then the domain zone.  Right-click the domain zone and select Properties.  On the name servers tab make sure only your server is there.  On the General tab make sure Dynamic updates are set to Secure only.  On Zone transfer tab, make sure the Allow Zone Transfers in UNchecked.  And on the WINS tab, unless you have a WINS server this should be unchecked too.

Now, all this being set/checked, remove the name server entries from the Forward Lookup Zone - you could remove everything in the zone if you want, it will be recreated.

Let me know what you find.


0
 

Author Comment

by:awilson1199
ID: 8266672
Netman666,


"Also, make sure the internal NIC has NO gateway. "
Done

" DNS should be itself only"
Done

"If you are running DHCP"
Not running DHCP

"External NIC, gateway, DNS and IP supplied by ISP.  Uncheck MS networks, disable NetBIOS over TCP/IP, and uncheck register in DNS"

Done

" Right-click the domain zone and select Properties.  On the name servers tab make sure only your server is there"
Done

"General tab make sure Dynamic updates are set to Secure only"

Done


"On Zone transfer tab, make sure the Allow Zone Transfers in UNchecked."

Done


Good effort but no go. It will not allow me to delete the name server entries from the Forward Lookup Zone.

Also I have discovered something else since posting the last update. Even though all the IP addresses, MX, Name Server, A record, in DNS are 192.168.0.3, when I do a
NSLOOKUP servername it comes back with 219.21.229.199 which has nothing to do with this small network.
0
 
LVL 51

Expert Comment

by:Netman66
ID: 8266893
This server is registered in your ISP's DNS server isn't it?  Likely as the mailserver for your domain.  If not, are you using a real domain name internally that does exist in the internet cloud?

After testing the IP you provided, it looks like a user node at Yahoo!

In DNS console, if you right-click the servername and select Properties, on the Interfaces tab it should be set to Only the following IP addresses - and your server IP should be all that's there.

Now, try also from a commandline on the server:

ipconfig /flushdns

then

ipconfig /registerdns


With respect to NSLOOKUP, it can be set to use another server as the root for lookups.

Advise.







0
 
LVL 2

Expert Comment

by:jimshoe
ID: 8266941
The DNS supplied by ISP (4.2.2.1 and 4.2.2.2) should be in forwarders of DNS properties, not in the properties for TCP.  

In TCP properties for the LAN NIC,  you should have the servers ip address (192.168.0.3) for DNS Primary and WINS Primary (if running wins on server).  Under advanced, DNS tab, be sure you have the checkbox register this connections address in DNS checked.

If you need a Q article explaining this let me know and I'll look one up.

Let us know the results after you have this correct configuration.

0
 
LVL 51

Expert Comment

by:Netman66
ID: 8266958
Also, have you rebooted this box since making any of the changes?

0
 

Author Comment

by:awilson1199
ID: 8269635
"This server is registered in your ISP's DNS server isn't it?  "

No, this is purely a test server on a separate network from company network for developing with SQL Server, though we want it to have internet access we do not want it on the internet and the router it is behind had a dynamic IP address.

"If not, are you using a real domain name internally that does exist in the internet cloud?"

No and don't want to.

"Only the following IP addresses - and your server IP should be all that's there."

Already been set.

"ipconfig /flushdns"

Done that many times but as soon as soon as the server reboots it picks up the new IP address.

"With respect to NSLOOKUP, it can be set to use another server as the root for lookups"

Only have one server and one client on this test network.


jimshoe:

"Under advanced, DNS tab, be sure you have the checkbox register this connections address in DNS checked."

I have tried this both unchecked and checked it seems to have no affect, but when it says register this connection, what does that mean, register it with my ISP DNS? I don't want that as this is purely a test server on a separate network from the company behind its own router with a dynamic IP address. We want it to have access to the internet (research and downloading) but do not want it to be on the internet with a domain name (like a home setup).
0
 
LVL 2

Expert Comment

by:jimshoe
ID: 8269758
awilson1199,

HOW TO: Configure DNS for Internet Access in Windows 2000
http://support.microsoft.com/default.aspx?scid=kb;en-us;300202


0
 
LVL 5

Expert Comment

by:cempasha
ID: 8595524
This question is still open and getting old. If any of the comment(s) above helped you please accept it as an answer or split the points who ever helped you in this question. Your attention in finalising this question is very much appreciated. Thanks in advance,

****** PLEASE DO NOT ACCEPT THIS AS AN ANSWER ********

- If you would like to close this question and have your points refunded, please post a question in community support area on http://www.experts-exchange.com/Community_Support/ giving the address of this question. Thank you      

Pasha

Cleanup Volunteer


0
 

Author Comment

by:awilson1199
ID: 8962730
I put this command "ipconfig /registerdns" in a bat file on my client and put it in the Startup of my client. It solved my problem for now, but I will have to come back and figure out why it is needed.
0
 
LVL 5

Accepted Solution

by:
Netminder earned 0 total points
ID: 9096218
User resolved; points refunded and question closed.

Netminder
EE Admin
0

Featured Post

Migrating Your Company's PCs

To keep pace with competitors, businesses must keep employees productive, and that means providing them with the latest technology. This document provides the tips and tricks you need to help you migrate an outdated PC fleet to new desktops, laptops, and tablets.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

NTFS file system has been developed by Microsoft that is widely used by Windows NT operating system and its advanced versions. It is the mostly used over FAT file system as it provides superior features like reliability, security, storage, efficienc…
Ready to get certified? Check out some courses that help you prepare for third-party exams.
This tutorial will teach you the special effect of super speed similar to the fictional character Wally West aka "The Flash" After Shake : http://www.videocopilot.net/presets/after_shake/ All lightning effects with instructions : http://www.mediaf…
Have you created a query with information for a calendar? ... and then, abra-cadabra, the calendar is done?! I am going to show you how to make that happen. Visualize your data!  ... really see it To use the code to create a calendar from a q…
Suggested Courses
Course of the Month7 days, 23 hours left to enroll

765 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question