?
Solved

3640 and rommon

Posted on 2003-03-31
25
Medium Priority
?
2,775 Views
Last Modified: 2010-01-20
I have a 3640 with a corrupt flash
i have xmodem a new ios over to the 3640
but when i reboot the router it comes up in rommon again
am i missing something?
this is what rommon says:

System Bootstrap, Version 11.1(20)AA2, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)
Copyright (c) 1999 by cisco Systems, Inc.
C3600 processor with 98304 Kbytes of main memory
Main memory is configured to 64 bit mode with parity disabled

get_man_dev: Unknown device - probably NOT formatted.
unknown flash device - mandev code = 0x89aa
cannot read flash info
getdevnum warning: device "flash" has size of zero
get_man_dev: Unknown device - probably NOT formatted.
unknown flash device - mandev code = 0x89aa
cannot read flash info
getdevnum warning: device "flash" has size of zero
open: read error...requested 0x4 bytes, got 0x0
trouble reading device magic number
boot: cannot open "flash:"
boot: cannot determine first file name on device "flash:"

System Bootstrap, Version 11.1(20)AA2, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)
Copyright (c) 1999 by cisco Systems, Inc.
C3600 processor with 98304 Kbytes of main memory
Main memory is configured to 64 bit mode with parity disabled

rommon 1 >
0
Comment
Question by:gator
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 10
  • 8
  • 6
25 Comments
 
LVL 79

Expert Comment

by:lrmoore
ID: 8243155
0
 

Author Comment

by:gator
ID: 8250127
i have tried the xmodem thing, and it works, and as long as i do not reboot the router then i am fine but once the router is rebooted its back to rommon

so if you or anyone has any other ideas
i am open for suggestions
0
 

Author Comment

by:gator
ID: 8250143
i have tried the xmodem thing, and it works, and as long as i do not reboot the router then i am fine but once the router is rebooted its back to rommon

so if you or anyone has any other ideas
i am open for suggestions
0
Manage your data center from practically anywhere

The KN8164V features HD resolution of 1920 x 1200, FIPS 140-2 with level 1 security standards and virtual media transmissions at twice the speed. Built for reliability, the KN series provides local console and remote over IP access, ensuring 24/7 availability to all servers.

 
LVL 79

Expert Comment

by:lrmoore
ID: 8250226
Do you have a line in your config that starts "boot flash:"
If so, remove it.

Else, set the router to ignore the startup config:
Using the ROMmon confreg Utility, watch for the line enable  "ignore system config info"? y/n  [n]:  
Answer Yes to this one only, then reboot.

rommon 2 > confreg

    Configuration Summary
enabled are:
load rom after netboot fails
console baud: 9600
boot: image specified by the boot system commands
      or default to: cisco2-C3600

do you wish to change the configuration? y/n  [n]:  y
enable  "diagnostic mode"? y/n  [n]:  

!--- Pressing "Enter" accepts the default (value between the brackets).
                                   
enable  "use net in IP bcast address"? y/n  [n]:  
disable  "load rom after netboot fails"? y/n  [n]:  
enable  "use all zero broadcast"? y/n  [n]:  
enable  "break/abort has effect"? y/n  [n]:  
enable  "ignore system config info"? y/n  [n]:  
change console baud rate? y/n  [n]:  y
enter rate: 0 = 9600,  1 = 4800,  2 = 1200,  3 = 2400
            4 = 19200, 5 = 38400, 6 = 57600, 7 = 115200  [7]:  7
change the boot characteristics? y/n  [n]:

    Configuration Summary
enabled are:
load rom after netboot fails
console baud: 115200
boot: image specified by the boot system commands
      or default to: cisco2-C3600
     
do you wish to change the configuration? y/n  [n]:  
     
You must reset or power cycle for new config to take effect

If it boots now but with empty config, it's something in the config.

0
 
LVL 79

Expert Comment

by:lrmoore
ID: 8250245
Are you sure you have enough DRAM memory for the IOS version you have?
0
 

Author Comment

by:gator
ID: 8250646
i have tried the xmodem thing, and it works, and as long as i do not reboot the router then i am fine but once the router is rebooted its back to rommon

so if you or anyone has any other ideas
i am open for suggestions
0
 

Author Comment

by:gator
ID: 8250691
yeah i have enough dram 98mb
0
 

Author Comment

by:gator
ID: 8250713
running set in rommon has the following

MONRC=BOOT=flash:,100
RET_2_RUTC=0
BSI=0
RET_2_RTS=
BOOT=flash:,100
?=0


any clues?
0
 

Author Comment

by:gator
ID: 8250741
running set in rommon has the following

MONRC=BOOT=flash:,100
RET_2_RUTC=0
BSI=0
RET_2_RTS=
BOOT=flash:,100
?=0


any clues?
0
 

Expert Comment

by:icemaster
ID: 8253711
Hi,

once your router is up, you'll need to copy tftp flash.  I think what is happening, and has happened to me is that it just uses the xmodem to boot from.  You then need to copy the image to flash, and make the changes in the Config to reflect the image in the flash as stated above.  that should do it.

regards,
Corey
0
 

Author Comment

by:gator
ID: 8258055
Once i tftp the ios here is my config
After i save this to mem and power cycle router it still goes to rommon, but until i reboot the router it works fine
here is config

Current configuration : 930 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
boot system flash c3640.122-12a.bin
!
ip subnet-zero
!
!
!
ip audit notify log
ip audit po max-events 100
!
call rsvp-sync
!
!
!
!
!
!
!
!
interface Serial0/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
!
interface FastEthernet1/0
 ip address 192.168.100.69 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet2/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet3/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
ip classless
no ip http server
!
!
!
!
!
!
!
line con 0
 speed 115200
line aux 0
line vty 0 4
 login
!
end

Router#
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 8258750
Try doing this

router(config)#no boot system flash c3640.122-12a.bin
router(config)#exit
router#write mem
[OK]
router#reload
Proceed? Yes

0
 

Author Comment

by:gator
ID: 8258796
ok did that and i got this:

System Bootstrap, Version 11.1(20)AA2, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)
Copyright (c) 1999 by cisco Systems, Inc.
C3600 processor with 98304 Kbytes of main memory
Main memory is configured to 64 bit mode with parity disabled

get_man_dev: Unknown device - probably NOT formatted.
unknown flash device - mandev code = 0x89aa
cannot read flash info
getdevnum warning: device "flash" has size of zero
get_man_dev: Unknown device - probably NOT formatted.
unknown flash device - mandev code = 0x89aa
cannot read flash info
getdevnum warning: device "flash" has size of zero
open: read error...requested 0x4 bytes, got 0x0
trouble reading device magic number
boot: cannot open "flash:"
boot: cannot determine first file name on device "flash:"

System Bootstrap, Version 11.1(20)AA2, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)
Copyright (c) 1999 by cisco Systems, Inc.
C3600 processor with 98304 Kbytes of main memory
Main memory is configured to 64 bit mode with parity disabled

rommon 1 >
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 8258847
Are you using a PCMCIA flash card? Paste results of:
rommon 1 > dev

rommon 3 > dir flash:

0
 

Author Comment

by:gator
ID: 8258874
no i am not using PCMCIA
rommon 3 > dev
Devices in device table:
        id  name
    flash:  flash
    slot0:  PCMCIA slot 0
    slot1:  PCMCIA slot 1
    eprom:  eprom
rommon 4 > dir flash:
get_man_dev: Unknown device - probably NOT formatted.
unknown flash device - mandev code = 0x89aa
cannot read flash info
getdevnum warning: device "flash" has size of zero
get_man_dev: Unknown device - probably NOT formatted.
unknown flash device - mandev code = 0x89aa
cannot read flash info
getdevnum warning: device "flash" has size of zero
get_man_dev: Unknown device - probably NOT formatted.
unknown flash device - mandev code = 0x89aa
cannot read flash info
getdevnum warning: device "flash" has size of zero
get_man_dev: Unknown device - probably NOT formatted.
unknown flash device - mandev code = 0x89aa
cannot read flash info
getdevnum warning: device "flash" has size of zero
open: read error...requested 0x4 bytes, got 0x0
trouble reading device magic number
dir: cannot open device "flash:"



after i xmodem ios over and then  do a tftp or not/either way doesnt matter
i can do a dir flash: and the ios is listed there

0
 

Expert Comment

by:icemaster
ID: 8259675
Hi,

I just saw one thing the : is missing in the config, but
still it should read the first image in the flash.
Have you tried to format the flash first then xmodem the image or tftp the over?

Regards,
Corey
0
 

Expert Comment

by:icemaster
ID: 8259681
oooops lmost forgot you might want to reset the Boot varible as well.

0
 

Author Comment

by:gator
ID: 8260642
when xmodeming the file over it has an option to erase flash first...i have done that

as far as formating the flash..How is that done
and
how do i reset the boot variable?
0
 

Expert Comment

by:icemaster
ID: 8261055
you use the command BOOT=[variable]

Sorry for formating the flash I was thinking about something else sorry.

But if all else has failed, I would saw your flash is defective.  Just out of curiosity what is your config-register set at?  0x2102?

Corey
0
 
LVL 79

Accepted Solution

by:
lrmoore earned 1000 total points
ID: 8261136
Once you get back into the full router mode, try using the squeeze command. Paste results of these:

router#sho ver

router#squeeze flash:

router#sho flash:

0
 

Expert Comment

by:icemaster
ID: 8261200
Looking into this abit more there was a bug in the Bootstrap earlier then the one you have.  But you should clear the variables you currently have use the folowing:

rommon 1>unset MONRC
       rommon 2>unset BOOT
       rommon 3>sync
       rommon 4>reset
0
 

Expert Comment

by:icemaster
ID: 8261221
Did you also follow the memory table set up for your 98MB Ram?

rommon 10 > meminfo -l
Supported 64 bit configurations:
SIMM 0 SIMM 1 SIMM 2 SIMM 3
--------------------------------------
4M 4M 4M 4M
8M 8M
8M-DUAL 8M-DUAL
8M 8M 4M 4M
8M-DUAL 8M-DUAL 4M 4M
8M 8M 8M 8M
8M 8M 8M-DUAL 8M-DUAL
8M-DUAL 8M-DUAL 8M 8M
8M-DUAL 8M-DUAL 8M-DUAL 8M-DUAL
16M 16M
16M 16M 4M 4M
16M 16M 8M 8M
16M 16M 8M-DUAL 8M-DUAL
16M 16M 16M 16M
32M-DUAL 32M-DUAL
32M-DUAL 32M-DUAL 4M 4M
32M-DUAL 32M-DUAL 8M 8M
32M-DUAL 32M-DUAL 8M-DUAL 8M-DUAL
32M-DUAL 32M-DUAL 16M 16M
32M-DUAL 32M-DUAL 32M-DUAL 32M-DUAL
Supported 32 bit configurations:
SIMM 0 SIMM 1 SIMM 2 SIMM 3
--------------------------------------
4M
4M 4M
4M 8M
4M 16M
4M 4M 4M
4M 4M 8M
8M
8M 4M
8M 16M
8M 8M 4M
8M 8M 8M
8M 8M 16M
8M 8M 4M 8M
8M 8M 8M 4M
16M
16M 4M
16M 8M
16M 16M 4M
16M 16M 8M
16M 16M 16M
16M 16M 4M 8M
16M 16M 4M 16M
16M 16M 8M 4M
16M 16M 8M 16M
16M 16M 16M 4M
16M 16M 16M 8M
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 8442670
G'day, gator
It has been 31 days since you posted this question.
Do you still need help? Have you received enough information?
Can you close out this question?
Ways to close questions: http://www.apollois.com/EE/Help/Closing_Questions.htm
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 8725692
gator,
No comment has been added lately (44 days), so it's time to clean up this TA.
I will leave a recommendation in the Cleanup topic area for this question:

RECOMMENDATION: Award points to lrmoore

Please leave any comments here within 7 days.

PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER!

Thanks,

lrmoore
EE Cleanup Volunteer
---------------------
If you feel that your question was not properly addressed, or that none of the comments received were appropriate answers,
please post comments here where a Moderator will see it.
0

Featured Post

Manage your data center from practically anywhere

The KN8164V features HD resolution of 1920 x 1200, FIPS 140-2 with level 1 security standards and virtual media transmissions at twice the speed. Built for reliability, the KN series provides local console and remote over IP access, ensuring 24/7 availability to all servers.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I have seen some questions on problems with SSH/telnet access to Cisco routers that may occur despite the fact that from a PC connected to your LAN, Internet connectivity is in place and users can access Internet sites without any issues.  There are…
Shadow IT is coming out of the shadows as more businesses are choosing cloud-based applications. It is now a multi-cloud world for most organizations. Simultaneously, most businesses have yet to consolidate with one cloud provider or define an offic…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Suggested Courses

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question