?
Solved

Retrieving Excel data via ODBC/SQL into Crystal reports v6

Posted on 2003-03-31
3
Medium Priority
?
840 Views
Last Modified: 2006-11-17
All,
I am trying to retrieve data from an Excel 97 workbook to Crystal Report version 6.0 via an SQL and(?) ODBC connection.
First created an ODBC connection via ODBC administrator via the Start, Configuration panel. Then I used that as input for the report. This worked fine, the report showed what it should show.

However, after I installed Access 2K on my machine (for other purposes), the report doesn’t work no more.

As long as I don’t use the ‘Verify database’ function in Crystal report, the report still works fine. However after I have used that function Crystal report gives the error message ‘memo field not allowed in formula’ and shows the formula editor with that ‘memo’ field. Crystal report doesn’t show where in the report definitions this formula is used.

Apparently Acces 2K has modified the Excel-SQL-ODBC connection.
The SQL/ODBC tool (delivered via Seagate Crystal reports) reports the following:
ODBC Version is : 03
 
SQL Driver Name is : ODBCJT32
SQL Driver Version is : 04.00.3711
SQL Driver Supported ODBC Version is : 03
SQL DBMS Name is : EXCEL
SQL DBMS Version is : 08.00.0000
Also this tool shows that now all datetime fields have a length of 19, all number fields have a length of 15 and all text fields are varchar with length of 255.
However in Crystal reports the date fields are also text fields with length 255.

I have tried to uninstall the Excel-conversion module from Access 2K. After that the error still occurs.

I have tried to use the ODBC administrator with Crystal report v6, but then an error shows up like ‘version of administrators program is not same as dll file’.

Who can help me out? I think I am using wrong versions of dll-files of ODBC and/or SQL, but which is the case and where can I find updates for these?
Or is the solution only in buying an update to a more recent version of Crystal reports or using another spreadsheet tool instead of Excel?

thx
Govert
0
Comment
Question by:GvA
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
3 Comments
 
LVL 101

Accepted Solution

by:
mlmcc earned 460 total points
ID: 8243359
Have you tried reinstalling CR and the Jet 4.0 drivers from M$.

http://www.microsoft.com/downloads/details.aspx?FamilyID=56d7b86c-7141-42fe-a995-59997d86d079&DisplayLang=en

mlmcc
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Hot fix for .Net Crystal Reports 10.2.3600.0 to fix problems with sub reports running on 64 bit operating systems ISSUE: Reports which contain subreports fail with error "Missing Parameter Value" DEPLOYMENT SERVER OS: Windows 2008 with 64 bi…
There have always been a lot of questions related to when Crystal Reports evaluates report components (such as formulas, summaries, cross-tabs, charts, to name a few examples). Crystal Reports uses a two-pass reporting process to provide greater …
Monitoring a network: how to monitor network services and why? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the philosophy behind service monitoring and why a handshake validation is critical in network monitoring. Software utilized …
In this video, Percona Solution Engineer Rick Golba discuss how (and why) you implement high availability in a database environment. To discuss how Percona Consulting can help with your design and architecture needs for your database and infrastr…
Suggested Courses
Course of the Month12 days, 4 hours left to enroll

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question