[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 189
  • Last Modified:

I'm trying to install mysql in red hat 6.0

I have the following problem :
I have to execute /usr/local/mysql/scripts/mysql_install_db
but mysql_install is a Bourne shell script
I'am superuser and I have /bin/bash
How can I change the /bin/bash to /bin/sh in order to execute the mysql_install script?
0
vage78
Asked:
vage78
1 Solution
 
naccadCommented:
the 1st line of the script sets what shell to use,
e.g.

#!/bin/sh

means that this is a /bin/sh script
just change it to whatever you want there.

tc
-nick
0
 
vage78Author Commented:
I have not understand
I know it is a bourne script.
I have default shell as superuser bash shell.
When I'm trying to write /bin/sh is not executed what can I do?
0
 
mmuserCommented:
type this a super user:

ln -s /bin/bash /bin/sh

Thats it! if it still doesn't work then you script is bad, show script in forum...
0
 
CleanupPingCommented:
vage78:
This old question needs to be finalized -- accept an answer, split points, or get a refund.  For information on your options, please click here-> http:/help/closing.jsp#1 
EXPERTS:
Post your closing recommendations!  No comment means you don't care.
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now