?
Solved

can't ./configure!

Posted on 2003-04-01
17
Medium Priority
?
208 Views
Last Modified: 2013-12-16
Hi

I can't ./configure. Always get following error
" /bin/sh: bad interpreter: Permission denied "

Makes no difference root or user, or changing permissions either for tar.gz file or configure file per se (even with everything allowed in properties)

Have tried this with at least 4 tar.gzs - all the same :((

SuSE 8.1 Pro, KDE 3

Any ideas.

Please!!!

neill

0
Comment
Question by:babysnake
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 8
  • 5
  • 2
  • +2
17 Comments
 
LVL 3

Expert Comment

by:naccad
ID: 8246132
does /bin/sh exist
0
 

Author Comment

by:babysnake
ID: 8247951
yep

/bin/sh is there
0
 
LVL 3

Expert Comment

by:naccad
ID: 8248054
ok, this error is usually due to a missing shell

install "ash", its a nice drop in for /bin/sh (suse has it in rpm
somewhere im sure), and give it another try.

you prolly have /bin/sh symlinked to /bin/bash or some such.

good luck
-nick
0
Get proactive database performance tuning online

At Percona’s web store you can order full Percona Database Performance Audit in minutes. Find out the health of your database, and how to improve it. Pay online with a credit card. Improve your database performance now!

 

Author Comment

by:babysnake
ID: 8248100
Thanks

I do have /bin/sh symlinked to /bin/bash as u suggest

What is the significance of this please?

(I've only been at this a week now - can u tell ;>) !!)
0
 

Author Comment

by:babysnake
ID: 8248127
I tried using ash (already installed)

I simply get
./configure: permission denied (from root, all permissions enabled in configure)
0
 
LVL 3

Expert Comment

by:naccad
ID: 8248257
lets try this another way:

type:

bash configure

and see what happens.
this is starting to sound interesting :)

tc
-nick

ps. the significance of using ash vs a symlinked sh is that by
mistake you could have linked sh to csh or tcsh or something
equally horrible, that is why i had to make sure.

0
 

Author Comment

by:babysnake
ID: 8248886
# bash configure gives

no such file or directory!!

cd /bin
bash configure

no such file or directory!!

alarming! (or I'm making some simple error!)

neill


0
 
LVL 3

Expert Comment

by:naccad
ID: 8248974
i think i did not make myself clear

instead of typing ./configure, run the file thru bash
for for example, if u have foo-1.2.tar.gz

tar zxf foo-1.2.tar.gz
cd foo-1.2
bash configure


0
 

Author Comment

by:babysnake
ID: 8249091
it configures......but fails for another reason altogether!

i rebooted anyway in the meanwhile (windoze habit!) and got the file to configure. It fails due to qt 2.2.2 or higher missing. I know i have qt on the system (YaST the SuSE config manager says so) and a higher version (2.3.2) so any ideas what's wrong??

this probably counts either as another problem or more points

At the end i simply want to install some soft!!

thanks

neill
0
 
LVL 51

Expert Comment

by:ahoffmann
ID: 8254230
does following list the required packages:

rpm -q -l qt
0
 

Author Comment

by:babysnake
ID: 8254720
I get a list:

/etc/qt.fontguess
/usr/lib/libqt-mt.so.2
/usr/lib/libqt.so.2
/usr/lib/libqutil.so.1
/usr/lib/qt-2.3.2
/usr/lib/qt-2.3.2/lib
/usr/lib/qt-2.3.2/lib/libqt-mt.so
/usr/lib/qt-2.3.2/lib/libqt-mt.so.2
/usr/lib/qt-2.3.2/lib/libqt-mt.so.2.3
/usr/lib/qt-2.3.2/lib/libqt-mt.so.2.3.2
/usr/lib/qt-2.3.2/lib/libqt.so
/usr/lib/qt-2.3.2/lib/libqt.so.2
/usr/lib/qt-2.3.2/lib/libqt.so.2.3
/usr/lib/qt-2.3.2/lib/libqt.so.2.3.2
/usr/lib/qt-2.3.2/lib/libqutil.so
/usr/lib/qt-2.3.2/lib/libqutil.so.1
/usr/lib/qt-2.3.2/lib/libqutil.so.1.0
/usr/lib/qt-2.3.2/lib/libqutil.so.1.0.0
/usr/lib/qt2
/usr/share/doc/packages/qt/doc
/usr/share/doc/packages/qt/doc/ANNOUNCE
/usr/share/doc/packages/qt/doc/FAQ
/usr/share/doc/packages/qt/doc/INSTALL
/usr/share/doc/packages/qt/doc/LICENSE.GPL
/usr/share/doc/packages/qt/doc/LICENSE.QPL
/usr/share/doc/packages/qt/doc/MANIFEST
/usr/share/doc/packages/qt/doc/PLATFORMS
/usr/share/doc/packages/qt/doc/PORTING
/usr/share/doc/packages/qt/doc/README
/usr/share/doc/packages/qt/doc/README.QT
/usr/share/doc/packages/qt/doc/README.SuSE
/usr/share/doc/packages/qt/doc/changes-2.3.0
/usr/share/doc/packages/qt/doc/changes-2.3.1
/usr/share/doc/packages/qt/doc/changes-2.3.2

thanks for the continued interest

neill
0
 
LVL 3

Accepted Solution

by:
naccad earned 1400 total points
ID: 8254808
if you are sure you already have an equal or higher version of
the libraries required, the reason configure fails is prolly becasue
it is looking for the development libraries/headers

let me explain,

there are two sets of any package that you install, for example, qt
comes in two packages, qt.rpm and qt-devel.rpm.
qt.rpm is what we call a runtime package, it provides the libraries
needed to run a software based on qt, the -devel package on the
other hand contains the libraries and source code files needed to
build a software based on that package.

so, in order to develop/compile/build a software based on qt,
you need to install the qt-devel package, which for suse 8.1
can be found at

ftp://ftp.suse.com/pub/suse/i386/8.1/suse/i586/qt-devel-2.3.2-304.i586.rpm 

hope that helps
good luck
-nick
0
 
LVL 51

Expert Comment

by:ahoffmann
ID: 8254829
agree with naccad that qt-devel should solve this problem
0
 
LVL 6

Expert Comment

by:TheAmigo
ID: 8260202
Sounds like an end-of-line problem.  If you run:
head configure | cat -v
does that show any control chars?
0
 

Author Comment

by:babysnake
ID: 8265187
nick

I'll get onto this over the weekend and get back

Thanks

neill
0
 
LVL 4

Expert Comment

by:albay
ID: 8284458
hi babysnake,

if you still get this error message "no such file or directory!!", file should be executable. change the file permissions,

  chmod 755 configure

and try again..

good luck,

albay
0
 

Author Comment

by:babysnake
ID: 8287014
In the end I did it via a reistall but that's no bad thing as I learnt about a lot of things I had made windows-type assumptions about

thanks

learning is fun!!
0

Featured Post

Get your Conversational Ransomware Defense e‑book

This e-book gives you an insight into the ransomware threat and reviews the fundamentals of top-notch ransomware preparedness and recovery. To help you protect yourself and your organization. The initial infection may be inevitable, so the best protection is to be fully prepared.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

rdate is a Linux command and the network time protocol for immediate date and time setup from another machine. The clocks are synchronized by entering rdate with the -s switch (command without switch just checks the time but does not set anything). …
Setting up Secure Ubuntu server on VMware 1.      Insert the Ubuntu Server distribution CD or attach the ISO of the CD which is in the “Datastore”. Note that it is important to install the x64 edition on servers, not the X86 editions. 2.      Power on th…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial
Suggested Courses

765 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question