ASP: CDONTS email gets stuck in pickup folder

I'm writing a program in ASP/HTML to send e-mails.  It goes something like this (except I'm using actual e-mail addresses):

--------------------------------------------------------------------

set objSendMail = CreateObject("CDONTS.NewMail")

objSendMail.From = "abc@xyz.com"
objSendMail.To = "def@xyz.com"
objSendMail.Subject = "test"
objSendMail.Body = "hi, this is a test."

objSendMail.Send

--------------------------------------------------------------------

I don't get any errors or anything, but I never recieve the e-mail.  It just stays in the Pickup folder in mailroot, with the extension .EML.  My anonymous internet users (IUSR_SERVER and IWAM_SERVER) have operator rights to my Default SMTP Virtual Server. Why aren't the e-mails getting through, and what can I do to fix it?

Please help! and thanks in advance,
Kevin


kevin_readingAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

amit_gCommented:
In Pickup folder ... Seems like SMTP server is not running. Open a command prompt and do

net stop SMTPSVC
net start SMTPSVC

What does it say?
kevin_readingAuthor Commented:
>net stop stmsvc
The Simple Mail Transport Protocl (SMTP) service is stopping.
The Simple Mail Transport Protocl (SMTP) service was stopped successfully.

>net start stmsvc
The Simple Mail Transport Protocl (SMTP) service is starting.
The Simple Mail Transport Protocl (SMTP) service was started successfully.

It is still doing the same behavior.  The SMTP service is installed, but I haven't done anything to configure it.  I had this script working on a different W2K Server machine before, and just got a new server, upon which it doesn't work.  But, yes, the service is indeed running.

Kevin
amit_gCommented:
Check the event log. Anything there with reference of SMTP?

The mails (.elm files) are stuck in Pickup folder or they are moved to Queue or Badmail folders?
Become a Microsoft Certified Solutions Expert

This course teaches how to install and configure Windows Server 2012 R2.  It is the first step on your path to becoming a Microsoft Certified Solutions Expert (MCSE).

kevin_readingAuthor Commented:
I've looked at the event log.  It was mentioned only as notices ("the service has started", etc), no warnings or errors.

The mail files aren't moved to Queue or Badmal; they stay in Pickup.
amit_gCommented:
Open a command prompt in the web server and do this

ping yahoo.com

nslookup

>set q=mx
>yahoo.com

What do you get?
kevin_readingAuthor Commented:
>ping yahoo.com

Pinging yahoo.com [66.218.71.198] with 32 bytes of data:

(All four pings were replied correctly; I'm not going to write them out)

>nslookup

***Can't find server name for address 192.168.0.1: No response from server
Default server:  eli-mail1-int.syptec.com
Address:  192.168.1.42

> set q=mx
> yahoo.com

Server:  eli-mail1-int.syptec.com
Address:  192.168.1.42

Non-authoritative answer:
yahoo.com     MX preference = 5, mail exchanger = mx4.mail.yahoo.com

(it gives me a bunch of other IPs for yahoo, too.)

Just FYI, 192.168.0.1 is a BSD computer I have, through which my internet connection is running and being shared.  192.168.1.42 is the primary DNS server at my ISP.  My ISP is SYPTEC.  The computer I'm running my ASP and SMTP  off of is 192.168.0.84.
amit_gCommented:
Do this also from command prompt

telnet mx4.mail.yahoo.com 25
helo
quit

Is your DSN IP given or obtained automatically?
GripSavageCommented:
Try this:

Right click on Default SMTP virtual server - select properties, and click on the delivery tab then on the advanced button at the bottom.

Enter the fully qualified domain name of the mail server in the fully qualified domain name box and the smart host box. Uncheck the attempt direct delivery box. Ok - Ok.

Click on Domains (under Default SMTP virtual server) enter the name of the web server and make sure that it is the default domain (if you have more than one).

Stop - Start SMTP service.

** Note - If you want to send internal email then the mail server you specify must have the IMS (internet mail service) installed, sounds weird but it needs the IMS to work out if its internal or external.

If the above doesn't work - remove and reinstall the SMPT service and set the above again.

Hope this helps.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
amit_gCommented:
What was the resolution to your problem? Is it resolved? If yes, you should not grade it C. If it was not resolved, you should ask for refund rather than grading it C. Whatever is the reason, you should have at least posted a comment about it and the way you resolved it. When you accept an comment, the question goes to PAQ where people look for solution before posting their question. The way this question stands now, no one will know how this problem was resolved. Please read...

http://www.experts-exchange.com/Web/qnaFAQ.jsp#3

Please post a question in http://www.experts-exchange.com/Community_Support/ if you want to change the grade.
kevin_readingAuthor Commented:
I apologize for my poor ettiquitte; this is my first time on Experts Exchange.  I'll include an explanation of what I did to resolve the problem:

What I ultimately did to resolve the problem was I gave Everyone Modify rights to the mailroot folder.  (It wouldn't work with just enabling the internet guest accounts.)  After that, my e-mail client could pick it up.

While your comments and GripSavage's comments didn't directly solve the problem, they gave me ideas to exercise which led to my finding a solution.
amit_gCommented:
Well if you think our comments helped, it should be graded B :) If I were you, I would rather ask for refund. None of the comments mentioned about the permissions, so if you see it, you figured out the solution yourself. Please post a 0 point question in http://www.experts-exchange.com/Community_Support/  and the moderators will take care of this. I think they can refund the points even now. If not, at least they can change the grade to B. Most experts will not answer your next question if they see that you have graded a previous question as C. Moreover you don't loose anything by grading better because grading changes only the multiplication factor. You have already spent your points and they remain same. In this site grade C is very frowned upon and is treated as an insult.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Development

From novice to tech pro — start learning today.