Slow LAN speed using Linksys DSL Router

I have a home network hooked up using a 8-port Linksys DSL router. The network consists of one 2003 NT server, and 3 XP Pro workstations. All using Intel onboard LAN. All with at least 512MB RAM and 2Ghz processor. All computers report a 10/100 connection. The DLS router is the gateway and handles NAT, but the server handles DHCP.

Speed to Internet is great. Speed sharing files is not so great. Saving a text file to the server takes a couple seconds. At work I set up a very similar network and it saves in a fraction of a second.

I've installed a different 10/100 card in the server, but had the same performance. So my question is simply... Does the Linksys DSL router go slower than a typical switch? Would my LAN speed pick up if I plugged all the computers into a switch and then either used my server as a gateway using 2 NIC cards or simply bridged the switch and DSL router?

Thanks!
LVL 1
graphicodysseyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

emery_kCommented:

I assume it is a new Linksys router. I've had great luck with the linksys and there really should not be any difference in speed between it and any other switch for your application. Even an older router should work as well
a) borrow a different switch for test purposes and don't worry about internet access during the test
b) get it down to two computers on the network and maybe even try the peer-peer networking for test purposes as there might be a problem with some piece of hardware/software generating a lot of noise. Also make sure you have no virus problems.
If two of the workstations can transfer files quickly through the linksys but it slows down when you bring up other stations that gives you a clue where to look.
Make sure you have firewall turned OFF on all computers as the linksys is performing that function. Good luck
Les MooreSr. Systems EngineerCommented:
Do you have DNS setup on your local server?
Try enabling NetBios over TCP/IP on all systems:
Enable NetBios over TCP/IP in WIndows XP
Step 1: Turn On NetBIOS over TCP/IP
Click Start, click Control Panel, and then click Network and Internet Connections.
Click Network Connections.
Right-click Local Area Connection, and then click Properties.
Click Internet Protocol (TCP/IP), and then click Properties.
Click the General tab, and then click Advanced.
Click the WINS tab.
Under NetBIOS setting, click Enable NetBIOS over TCP/IP, and then click OK two times.
Click Close to close the Local Area Connection Properties dialog box.
Close the Network Connections window.

Step 2: Start the Computer Browser Service
Click Start, right-click My Computer, and then click Manage.
In the console tree, expand Services and Applications.
Click Services.
In the right details pane, verify that the Computer Browser service is started, right-click Computer Browser, and then click Start.
Close the Computer Management window.

References:
http://support.microsoft.com/default.aspx?scid=kb;en-us;318030
http://support.microsoft.com/default.aspx?scid=kb;en-us;314366
http://support.microsoft.com/default.aspx?scid=kb;en-us;315267
http://www.practicallynetworked.com/sharing/troubleshoot/slowbrowse02.htm
http://www.michna.com/kb/WxNetwork.htm

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
graphicodysseyAuthor Commented:
Ok I took your comments and here are my results. I also increased the point value since now we're getting more into this.

a) Used a 4-port Linksys 10/100 switch to connect nothing but the server and 1 workstation together. It still responded at the same slugish speed.

b) Shared a drive on one workstation and accessed the same text file from a different workstation. Worked great. Definitely going the speed it should. So, I'm guessing it's something with how the server is set up.

c) Confirmed that the built-in firewall option is off for all computers. There is no chance of a virus as everything is a clean install from this last weekend.

d) Enabled NetBios over TCP/IP on all computers. It still responded at the same slugish speed.

e) Confirmed that the Computer Browser service was running on all computers.

f) Briefly reviewed the reference articles provided and I didn't see anything that appeared relevant.

So, since the only indicator thus far is pointing blame at the server I should probably tell you the server characteristics: I lied about the processor... it's a 1.7Ghz, 768MB RAM, 1 IDE 40Gig system drive, 2 IDE 80Gig data drives (mirrored and on a seperate SIIG controller card), it's running DHCP, DNS, and Active Directory.

Ok I've been doing some tests as I'm writing this... Since the data drives that contain the text files are mirrored drives using the SIIG controller card I decided to put a copy of the test text file on the plain ole system drive. Then I shared the root of the C drive to see if it was as sluggish. I opened the file in Dreamweaver MX like normal through My Network Places (since there wasn't a mapped drive yet to the new share) It worked great. So then I shared the root of the data drive. I then copied the test text file to the root of the data drive and shared that - also worked great. Next I tried files that I was originally had problems with. So then I played around with creating share and deleting shares while restarting my workstation, and it went both and slow, but I can’t come up with a definite reason why it would or wouldn’t work. No matter what I share or how I open a file, I can’t get a consistent good or bad connection. Could it be something with authentication? Tell me oh wise support gurus!
Your Guide to Achieving IT Business Success

The IT Service Excellence Tool Kit has best practices to keep your clients happy and business booming. Inside, you’ll find everything you need to increase client satisfaction and retention, become more competitive, and increase your overall success.

tstaddonCommented:
Are you connecting the machines using drive maps or UNC paths? UNC will usually have a lag associated with it.

Secondly, Do you have QoS enabled on ANY of the network connections? If so, try removing it.

It does sound as if you are right: it is the way the server is set up; pure IP traffic to the Internet is going great guns, and P2P between the workstations is also fine.

Only other thing I can think of is the security associated with the file system AND the shares on the server. Assuming you are authenticating from the workstations using AD, it is vital you get the permissions right on the server.

Make sure your workstations and user accounts are logging into the Active Directory properly.


jemery27Commented:
A couple comments:

First, most likely cause of slow file transfers is NIC settings - not processor, or disk drives or anything else. You need to make sure the NIC on the server is set to AutoNegotiate. Do not set it to 100Full when it is plugged into the Linksys because the Linksys is set to Auto and will never negotiate to 100Full unless the other side is also set to Auto.

I would update the firmware in the Linksys first of all. Make sure all machines connected to it are set to Auto. If you still suspect the linksys is the problem, try making a crossover connection between two PC's that are slow and try the same transfer. Try the same thing but set both NIC's to 100Full. If this is still not fast, then there is something up with the NIC (most likely) or driver, or TCP (least likely). At that point you either replace the Linksys (not recommended unless you can somehow verify it has an actual problem and you replace with another Linksys) or if you need seriaous LAN speed put in another switch as you mentioned, but a good one - like a Cisco and set the server/workstation ports to 100full as well as all the NICs. Only set the uplink to the Linksys to Auto - that will be great for Internet speeds.

Second, Internet speed being great has no meaning. You think Internet speed is great if you get 512Kbps. Trust me - you don't think LAN Speed is great at that rate. You can't compare these two things.

One last thing - do all your speed testing using IP addresses and FTP. This eliminates name resolution and netbios crap as parts of the problem.

Good luck,
Jason
graphicodysseyAuthor Commented:
First of all, I'm at work so I can't test the saving of the text file, but I can TermServ into the server and check some of the settings the past few comments have referred to.

a) Primarily I’m using mapped drives to the location of the text file. However, last night when I was playing around with the shares (as mentioned in my last comment) I used UNC paths. By UNC you mean \\server\testshare, right? Sorry never knew that acronym : ) Using both methods typically yields the sluggish response. However, when I was screwing around I could occasionally make both methods work as fast as they should. What did I do? I have no idea. I was creating shares, deleting shares, accessing them via a mapped drive or UNC, using different drives and using different subdirectories within the drive. No matter how many times I screw with it I can’t find the specific sequence that is the winning combination.

b) No I don’t see the QoS service installed on the server. You’re talking about the separate QoS Packet Scheduler service, right? Or is it some buried option somewhere? I have no idea what the workstations have. I’ll let you know tonight. If it’s left off by default, then it should be off for each computer.

c) About the security… I’m using Active Directory and all the workstations log into the domain nice and quick. So my novice opinion is that everything is authenticating, as it should. There is not a .bat file that runs each time I log in that remaps the path; rather, the computer just remembers the mapped drives. For the share settings on the server I’ve been using the “Authenticated Users” Group. Last night I added the “Everyone” group, but had the same poor response. In the event log I see nothing but successful audits, so from the surface it looks like everything is fine.

d) I’ve been pretty faithful about upgrading my Router software, but there was an update available. So I installed that. I’ll know tonight if it makes a difference.

e) I did set all of my NIC cards to 100Full before I reinstalled everything this last weekend and I was having the same sluggish response. Now that all the systems are new I forgot about the NIC speed. So, they are still on their default, which is auto. Because of your recommendation I’ll leave it. As mentioned in my previous comment, I did connect 2 workstations together and the LAN speed was great. However, I used the Linksys router and not a crossover connection.

f) I apologize for grouping LAN speed with WAN speed. I was only trying to demonstrate that the router, gateway, and DNS settings were all working as they should.

g) Tonight I will try the same tests via IP to factor out the name resolution as Jason mentioned.

By the way, is there any way to give even more points to the question? So many of you guys are helping me out. I feel bad splitting only 500 points!

Thanks for all your help,
Ken
jemery27Commented:
Just to add - double check the NIC speed settings. I can't emphasize this enough. It could also be that the mediocre switch in the Linksys is grinding to a halt because only one of the connected devices is at 100Full or something else. Older hub/switches used to be called 10/100, but the truth was if you connected anything at 10Mbps, then the whole hub had to run at 10Mbps.

If you were able to connect two devices to the switch and get reliable fast throughput, then just add a third device and test everything again between the first two and also to the third device. Add the fourth device and so on.

Good luck,
Jason
graphicodysseyAuthor Commented:
Thanks Jason, I'll make sure to triple check that this evening.
johnb6767Commented:
A very basic fix for slow XP browsing is  related to DNS. If the DNS server is setup properly (internal LAN), then the internal DNS server should be the only STATIC dns entry in the TCP/IP properties of XP. Otherwords, XP should have the DNS server statically set, and can get everything else via DHCP if you like.

See how that works....
graphicodysseyAuthor Commented:
So I’ve turned off all computers except for the server and one workstation. Then I performed the following:

a) Confirmed that NIC cards in both the server and workstation are set to Auto Detect.

b) Confirmed that the QoS service was not installed on either computer. Well, it was installed on the workstation. So I installed it on the server, restarted everything and got the same results. Then I unistalled it on both computers, restarted everything and also got the same slow results.

c) Disconnected the connection from the DSL modem to the Linksys Router – same results.

d) Mapped the same drive as I’ve tried before but my using the server IP instead of the server name – still had the same speed.

e) Tried something the opposite way… copied the test text file to the workstation, mapped the root of the C drive and then connected via UNC paths – worked great. Mapped the drive – worked great.

Again it sounds like a network setting purely wrong with the server. As a few of you mentioned DNS could be an issue. So… let me tell you about the network settings in detail.

Workstation (DHCP):
- IP: 192.168.1.100
- Subnet: 255.255.255.0
- Default Gateway: 192.168.1.1
- DHCP Server: 192.168.1.50
- Primary DNS Server: 192.168.1.50
- Secondary DNS Server: 192.168.1.1

Server:
- IP: 192.168.1.50
- Subnet: 255.255.255.0
- Default Gateway: 192.168.1.1
- DHCP Server: 192.168.1.50
- Primary DNS Server: 192.168.1.50
- Secondary DNS Server: 192.168.1.1

DNS is running on the server. There are 2 forward lookup zones: _msdcs.hq.graphicodyssey.com and hq.graphicodyssey.com in that order. There are no reverse lookup zones. In the DNS section of the Event Log there were only a few entries. There was one error from a few days ago and quite a few warnings. The warnings were all stating that there were too many IP’s that were facilitating DNS requests. So, I went into the properties for the DNS server and removed all IP’s except for the one that the workstations used (192.168.1.50). I still got the same results.

Okay I think I’m at the end of my road. I don’t know what else I could do. Help!
graphicodysseyAuthor Commented:
By the way, I also tried setting the workstation DNS to the IPs of some hosting company's DNS servers. (I think that's what johnb6767 was getting at) And that didn't seem to help. If you mean something else, let me know and I'll try that.
tstaddonCommented:
If I remember my DNS correctly, no workstation will ever use 2 DNS servers at the same time. They will use the primary unless it isn't available.

Try a TRACERT to www.google.com and see how it's getting there. If it's going through your gateway without touching your server then I guess your DNS service isn't working properly.

Silly suggestion: try adding a HOSTS file to your workstations (winnt\system32\drivers\etc) with the server's name and IP address in it, and see if it makes a difference.

If you are using your server for DHCP, remove the secondary DNS entry from your workstations' DHCP scope (I'm assuming your server is configured with a static or reserved IP address with its DNS entries configured seperately).
jemery27Commented:
It sounds like you are not reproducing your statement about getting fast throughput with two devices connected to the switch. Connect them toegther with a crossover cable and try the same transfer. If you are using DHCP in the linksys you may have to assign static IP addresses. This way you can also try setting both NICs to 100full and test your speed. I can practically guarantee it will be fast. If you cannot get high throughput with a direct connection, then you know it is a problem with the server or workstation and not the linksys.

You would be better off just doing all your tests using ftp and ip addresses as long as you still suspect a network performance issue. Just forget about the DNS and file sharing until you feel comfortable you are relaibly getting good throughput.

Good luck,
Jason
graphicodysseyAuthor Commented:
Response to Jason-

I only have the slower speeds when accessing files located on the server from the workstation. I tried it in reverse (accessing the same file located on the workstation and accessing it from the server) and the speed was great. I also tried it just between two workstations and it worked great. So the router is working great and the NIC cards are too. So I'm guessing it's purely something wrong with my network settings. FYI, DHCP is handled by the server. NAT is handled by the Linksys Router.

Response to tstaddon-

When I get home this evening I'll play with the DNS and traceroute. I never thought about the host file... I'll give it a shot. Yes DHCP is hosted by the server and it defines the DNS and Gateway. DHCP is from 192.168.1.100-200. The server has a static IP and DNS settings (listed above).
johnb6767Commented:
"By the way, I also tried setting the workstation DNS to the IPs of some hosting company's DNS servers. (I think that's what johnb6767 was getting at) And that didn't seem to help. If you mean something else, let me know and I'll try that. "

Actually what I was getting to was using the internal DNS server, built in to 2000 server.Configure it to forward all requests out to the ISP's DNS, and statically set the DNS on the XP systems, to that of the internal DNS server.

Not sure if that is what you tried or not....Just wanted to clarify...
emery_kCommented:
it is a small network
why not just set everything to static IP, set the DNS manually for your ISP's DNS servers or some other DNS  and manually set the gateway as the router

seems a lot less trouble than the time you've put into troubleshooting this

graphicodysseyAuthor Commented:
Yeah I know this is a lot of work for something that is overkill for a home network, but I love it. It's a lot of fun. There's nothing more gratifying than getting something like this to work after hours upon hours of testing. Thanks for bearing with me.

John-
I'm not sure I exactly know what you mean... Right now if I run "ipconfig /all" on a workstation you're saying it should only return 192.168.1.50 (the server) as the primary DNS server, right? That's what I currently have. However, the primary DNS of 192.168.1.50 is automatically set by DHCP. I think at one point I set it statically and it didn't make a difference. Then in the DNS properties on the server it should forward all DNS requests to the ISP? Currently I have all requests forwarding to the Linksys router. I'll try playing with that later.
graphicodysseyAuthor Commented:
Well, after screwing around with it ALL freakin weekend I found out that I only get the problem when Active Directory is installed. Without AD everything runs great. For the life of me I can't figure out what it is about AD that screws it up. I'm guessing something with DNS. Nevertheless, I give up! Thank you to everybody for your help. I really appreciate it.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Telecommunications

From novice to tech pro — start learning today.