Outbound message queue filling up

Exchange Server 5.5 installed on NT4.0.

The outbound messages have been slowing down (incoming OK). I checked the IMS outward messages queue and it is filled with 10s of thousands of obviously spam messages. As soon as you delete one batch of 10,000 (the maximum shown in the box) another 10,000 pop up. I think this has only happened recently - although I cannot discount the possibility that these have been building up for a long time as our maintenance has not been as good as it could be - I am from a very poor developing country.

I think this might be due to relaying, which brings in the second point. On our internal network (which uses NAT and fixed IPs) we have one host which needs to relay, because of some HF radio email software which it runs (i.e. that host is a gateway for a radio email network). If I disallow all hosts from relaying, the radio email does not work (outward messages get the relaying probibited error). In the Exchange server IMS properties , routing, routing restrictions box I am only allowing (1) hosts that authenticate AND (2) the host with the internal IP address for the radio email computer. I am not 100% sure that relaying is completely prohibited.

Can I have your kind advice on what angle of attack I should take? How can I configure the routing restrictions so that that single computer with the radio email is allowed to relay without getting general relaying occuring? Should I enter the IP of the SMTP server where Ex Server is installed in the NEVER relay box (sorry if that is a stupid question)?

 
leemingdAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ahmedbahgatCommented:
have you tried to disable ip forwarding on the mail server?

cheers
David WilhoitSenior Consultant, ExchangeCommented:
Check the time stamp on the messages to see when they came in. Also check details to see whre they are coming from. You may have a loop set up, or a virus on one of the clients. Please give SP levels on NT and Exchange. also, is there a firewall or router in front of all this?

D
David WilhoitSenior Consultant, ExchangeCommented:
Until you see what's going on too, you might want to change the IMC mailflow to "none", flush the queues manually. then open it up and see what happens.

D

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Software

From novice to tech pro — start learning today.