PCL XL error when printing to an HP LJ 4050

I have an HP Laser Jet 4050.  I was printing a lot of documents and decided to cancel the job.  Now whenever I go to print I get this on the page:

PCL XL error
Subsystem: Kernel
Error: IllegalStreamHeader
Operator: 0x0
Position: 0

I uninstalled and reinstalled the drivers but it didn't work.  Can you help?
s_strydomAsked:
Who is Participating?
 
PsiCopConnect With a Mentor Commented:
Have you tried rebooting the printer? My thought is that a buffer on the printer has junk in it.
0
 
s_strydomAuthor Commented:
Rebooting the Printer and PC worked thanks.
0
 
PsiCopCommented:
You're welcome. Glad to help.
0
Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
MahendrabrCommented:
SOLUTION:


Perform the following in the order provided:

Try to print using the PCL5e printer driver that came with the HP LaserJet printing system.

Unplug the parallel or network data cable from the back of the product.

Verify that the product is in Ready Mode.

Print a Configuration Report.

If the page does not print or garbled characters or symbols appear on the report, have the printer serviced. If the report prints correctly, proceed to the next step.

Verify the parallel cable connection.

Verify that the parallel cable is IEEE-1284 compliant.

Try a different IEEE-1284 cable.

Connect the printer directly to the parallel port on the computer. If the printer cannot be directly connected to the computer, try a different network cable or network port on the hub.

If applicable, try a different USB cable.

Remove any external pass-through devices such as switchboxes, tape drivers, or scanners.

Change the properties of the PCL 6 printer driver using one of the following methods:

Windows 95, 98, and Me

Select Start, Settings, then Printers.

Right-click the HP LaserJet 4050 PCL6 driver,  icon and select Properties from the drop-down menu.

Select the Details tab.

Click Port Settings.

Remove the checks from the following option boxes and click OK: Spool MS-DOS print jobs. Check port state before printing.

Select OK to return to the Windows desktop screen.


Windows NT 4.0

Select Start, Settings, then Printers.

Right-click the HP LaserJet 4050 PCL6 driver icon and select Properties from the drop-down menu.

Select the General tab.

Select Print Processor.

Set the Default Datatype setting to RAW, then select OK.

Select OK to return to the Windows desktop screen.


Windows 2000/XP (classic view)

Select Start, Settings, then Printers.

Right-click the HP LaserJet 4050 PCL6 driver  icon and select Properties from the drop-down menu.

Select the Advanced tab.

Select Print Processor.

Set the Default Datatype to RAW and select OK.

Select OK to return to the Windows desktop screen.


Change the printer port mode (on parallel connections only). The parallel port mode of the computer may need to be changed to provide the best performance with an HP LaserJet series printer. ECP mode generally provides the best performance with HP LaserJet series printers. If the ECP port mode option does not work, try other available modes starting with bidirectional mode (bidirectional mode is not available on all computers). The parallel port mode may be changed on most computers by entering setup or accessing the computer's BIOS.

In Windows 95 only, update the version of the LPT.VXD file currently on the system. Perform the following to verify the current version of lpt.vxd file in use on the system.

Select Start, Find, then Files or Folders from the Windows 95 desktop.

Type lpt.vxd in the Named: text box.

Change the Look In: box to indicate the C:\ drive.

Click Find Now.

Highlight the file in the results list.

Right-click the file name and select Properties from the drop-down menu.

Select the Version tab.

Contact the PC manufacturer for information on obtaining the most current version of the file.

Try modifying the HP LaserJet 4050 PCL6 driver  settings when the issue is isolated to specific applications or documents.

Windows 95, 98, and Me

Select Start, Settings, then Printers.

Right-click the HP LaserJet 4050 PCL6 driver icon and select Properties from the drop-down menu.

Select the Finishing tab.

Select the Custom setting under Print Quality then select Details.

Select a lower resolution, such as 600 dpi.

Select Send TrueType as Bitmap in the Print Quality Details window then click OK.

Select OK to close the window.

Print a page from the application or document in question.


Windows NT 4.0

Select Start, Settings, then Printers.

Right-click the HP LaserJet 4050 PCL6 driver icon and select Document Defaults from the drop-down menu.

Select the Finishing tab.

Select the Custom setting under Print Quality then select Details.

Select a lower resolution such as 600 dpi.

Select Send True Type as Bitmaps in the Font Settings window and then click OK.

Click OK to close the Document Defaults window.

Print a page from the application or document in question.


Windows 2000/XP (custom view)

Select Start, Settings, and then Printers.

Right-click the HP LaserJet 4050 PCL 6 driver  icon and select Printing Preferences from the drop down menu.

Select the Finishing tab.

Select the Custom setting under Print Quality, then select Details.

Select a lower resolution, such as 600 dpi.

Select Send TrueType as Bitmaps in the Font Settingswindow and then click OK.

Click OK to close the Printing Preferences window.

Print a page from the application or document in question.


Try using a different font within the application or document in question.

Try printing using an alternate pre-installed Microsoft printer driver, such as the HP LaserJet 4 Plus or HP LaserJet 5L PCL driver.
0
 
WakeupSpecialist 1Commented:
s_Strydom,

You may want to close this question out?  Been a long while, and you confirmed that PsiCop's comment worked/helped you out....

you may want to grade and close and award points.
0
 
PsiCopCommented:
I object! Oh, wait, those are my points.

Never mind.









:-)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.