command of FTP not working properly

montydcunha
montydcunha used Ask the Experts™
on
MY sco version is 5.0.5

When I am doing ftp from my windows  machine to my UNIX servers  , I am able to put my files on my SCO openserver.
But get command hangs after receiving few bytes not more than 2920 .
Is there any buffer problem or any configuration problem in my UNIX machines?
 
Your prompt reply will be highly appericiated

Anthony
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Hanno P.S.IT Consultant and Infrastructure Architect

Commented:
Is the filesystem on the server filling up or do you have disk quotas in place?
I understood this happens when you "send" a file from you PC to the UNIX box, right?

Author

Commented:
thanks for reverting back sir

1) the filesystem of server has enough space
2) i am having problem in getting a file from sco box. i can receive only 2920 bytes from server but i can copy n no. of bytes on my sco box through FTP from command line or from putty.

Anthony

Commented:
Hi,

Sounds to me like a network problem.  Have you checked the network settings for both ftp server and client?

-Joe
Introduction to Web Design

Develop a strong foundation and understanding of web design by learning HTML, CSS, and additional tools to help you develop your own website.

Hanno P.S.IT Consultant and Infrastructure Architect

Commented:
Does this apply to any file or just a specific one?
Did you try setting "binary" before doing the "get"?
Top Expert 2005

Commented:
Does this happen only when the FTP is initiated from a specific PC or does it hapen from multiple PC's? If it only happens on a single PC I'd suspect a problem with that machines NIC. It might be a a bad NIC, a driver problem or a link negotiation issue. In a like manner if this happens from any client PC I'd suspect the same sorts of issues with the SCO server.

On a 100Mbps network it isn't uncommon to find that a system has mis-negotiated network link speed/mode, whcih can cause this exact problem. If that happens one end of the link is operating in 100/HDX and the other is in 100/FDX. The fix is to force one or both ends of the link to the same mode, 100/HDX for a hub or 100/FDX for most switches.

This can also be a driver problem and the obvious solution is to install a current version of the driver.

Commented:
In order to test if it´s a network problem, you can try using rcp  instead of
ftp
Is the PC and the SCO box in the same LAN, or just a modem connection. If it is a modem connetion, check the port speed and modem speed setting, make sure that it is not a buffer over run (reduce the speed!)

Author

Commented:
hi sir ( Just Unix ) - this apply to only one sco server & i am setting "binary" before doing the get
        ( Jlevie )       - yes sir i am having problem only in getting the file from server which is of more than 2920 bytes.         And  i tried doing ftp from different machines in my network every where the same problem is there.
         

         ( Bira )        - i tried to do rcp it is saying Permission denied
         ( Yuzh )      -  yes sir its on the same lan (100 mbps network).

From the common view of all of you i think i should change my lan card & see the performance.
today evening i will be taking the downtime i will see changing the lan card to come to any conclusion.

Thanks Sir

Top Expert 2015

Commented:
Maybe you have duplex mismatch somewhere in between hosts,
Or a Path MTU blackhole.
Check first and attempt to disable Path MTU on both hosts ( i cannot tell you how, simply do not know)
Commented:
did this ever work in the past?

check netstat -m and see if anything is in the fail column. (nic or driver problem)
also run a full system verify (thru custom) and correct any problems found.
I have seen this on a 5.0.4 system and fixmog solved the problem.

Commented:
does the network route through any firewalls or a NAT ?

If so, it could be a problem with the data channel receipt, you may have to use PASSIVE mode, as the server by default will initiate a connection back to the client to send you the data. Therefore firewalls and also NAT can prevent the return data back to the client.

The symptoms you would see is;

Logon fine, but cannot get a directory listing or retrieve files ( it hangs and them times out).

use PASSIVE mode on the client, this will resolve the problem if this is what you are getting.


Regards

UkWizard.

Eric BDirector of Information Technology

Commented:
UKwizard may have the key. To open passive mode socket connection, try "quot pasv".

Author

Commented:
The output of the command ifconfig -a , & netstat -nr is as follows and i have a doubt on my lancard settings of ethernet (dcx0:) the recv size: is 4096 ; send size : 8192; ideally which should match , So pls tell me how to set the parameters to equal the size.

#ifconfig -a
dcx0: flags=4043<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
        inet 200.0.0.6 netmask ffffff00 broadcast 200.0.0.255
        perf. params: recv size: 4096; send size: 8192; full-size frames: 1
        ether 00:00:f8:24:5c:da
lo0: flags=4049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 8232
        inet 127.0.0.1 netmask ff000000
        perf. params: recv size: 57344; send size: 57344; full-size frames:


# netstat -nrRouting tables
Destination      Gateway            Flags    Refs      Use  Interface
127.0.0.1        127.0.0.1          UH          2       22  lo0
200              200.0.0.6          UC          1        0  dcx0
200.0.0.6        127.0.0.1          UGHS        5       58  lo0
210.200.170      200.0.0.20         UCS         0        0  dcx0
224              200.0.0.6          UCS         0        0  dcx0

Waiting for reply

Anthony


Top Expert 2015

Commented:
Do not worry, problem is within nested protocol, tcp is fine.
Likely # ifconfig dcx0 send-size 32767 # etc (you have ifconfig manuals you know)
What about netstat -n -i ?
Is there a firewall between server and client???

Author

Commented:
HI gheish i didnt get u ,
by giving the command "#ifconfig dcx0 send-size 32767"

will change the send-size, pls explain as i am worried that this is my live server
& the out put of the command is given below

# netstat -n -i
Name  Mtu      Network     Address          Ipkts        Ierrs     Opkts        Oerrs  Coll
dcx0    1500    200         200.0.0.6           91661       0          13200          0      0
lo0       8232   127           127.0.0.1           96             0           96             0       0
Top Expert 2015
Commented:
1) Your card is fine. Your ethernet is OK.
2) Can you put file using localhost??

3) /etc/inconfig ip_perform_pmtu 0 may be a fix if you have PMTU blackhole called firewall (not sure how to do this on Windows, but will be necessary)

4) Try telneting to port 21 of your ftp server and type after banner:
USER yourname
PASS yourpass
SYST
<gimme output>
PASV
<Is it OK or 500?>
QUIT

Commented:
Did you run fixmog?

As I said before it was a permissions/config problem (sorry i don't remember the exact bit that was wrong).  
I just double checked the machine that had the problem and it is a prioris XL5150 with a dcx0 driver.
version 2.1.7

name=dcx0 base=0x8400 offset=0x7F vec=10 dma=- type=DC21040 addr=00:00:F8:24:03:6C

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial