Drive A content doesn't change even if i change the floppy! ! !

have an Intel pentium 4 CPU 2 GHz with 512 KB cash memory, 850MV intel motherboars, 512 MB RD-RAM Samsung, Radeon 7500 all in wonder, Sony DVD, ASUS CD-RW and finaly 80 GB westerndigital hard disk drive.

the problem is that when I use windows explorer and open drive A, I see the contents of the floppy which is in the drive. If I change the floppy disk, I can't access the newly inserted disk, because what I see is the content of the old floppy, if I keep refreshing the window, it still show the contents of the old floppy.

This problem happens with all windows; 9x, XP, win 2000 and even windows 2003 server. but doesn't happen with DOS!!

I tried another Floppy disk drive on my machine and tried my Floppy disk drive on another computer and I discovered that the problem is in my PC ! ! !

plsease help me here, I'm stuck, if I want to copy a couple of floppies then I've to restart :(
LVL 16
dr_dedoAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Johnny2003Commented:
I suspect the problem lies in the BIOS(CMOS) settings or you have a  Faulty FDC (Floppy Disk Controller) on your Mother Board.

Try disabling the FDC and all associated Floppy drive sections in the BIOS, saving settigns. Re-boot, go back into the BIOS and re-enable the FDC and all associated Floppy drive sections, not forgetting to select 1.44 3.5inch(which I hope it is).

I guess you also tested the Floppy drive cable too? Worth trying, incase one line is broken, and causing a silly fault.

If this dosn't cure it, then maybe its a faulty FDC on the motherboard.
Hopefully the MB is under warrenty? If not a cheap PCI FDC board might be a cheap fix alternative.

Good luck,

Johnny2003

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ridCommented:
If it works OK in DOS the hardware may be OK, but you may have a driver issue. Check the above suggestions
and also remove FDD and controller from device manager and let windoze re-detect the hardware. Might help.
/RID
dr_dedoAuthor Commented:
The problem was the cable. a line was nbroken and it was getting me nuts. thanks gos it is not the mobo
Johnny2003Commented:
Cool, glad you fixed it.
Damn ribbon cables, do this occationaly!!!

It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Hardware

From novice to tech pro — start learning today.