Please Help, Solaris 8 root password change. Can't login in any longer

Help
 I am new in Solaris 8.

I logged in as root and change the root password.
The system tells me it updated it. but now can't login in

it give me the following error

"Not in system console"

Is there any solution for this??

Thanks
bbkaycieAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

yuzhCommented:
Where did you try to login, use telnet/rlogin from remote?

Can you login from the console?

If you can login from the console, your system is fine. and you should not allow telnet/rlogin as root to your system (not secure). consider to use secure shell for remote login (include root)

You can download openssh from:

http://sunfreeware.com/

In this case, your /etc/default/login file should have the following defined:
CONSOLE=/dev/console   # only allow on console


IF you can not login from the console, you need to boot up the system from CDROM or a boot server, then edit the shadow file, delete the password, also check /etc/default/login
to make sure the setting is :

CONSOLE=/dev/console

Note:
     CONSOLE=/dev/ttya - direct root logins only on /dev/ttya
     CONSOLE= - direct root logins disallowed everywhere
     CONSOLE= - direct root logins disallowed everywhere
     #CONSOLE (or delete the line) - root logins allowed everywhere

To recover the root password, put the Solaris software CD in, then type in:
<Stop> A
boot cdrom -s
mount /dev/dsk/c0t0d0s0 /a                #assume you root partion is /dev/dsk/c0t0d0s0
vi /a/etc/passwd
  you will see a line like this:
     root:x:0:1:Super-User:/root:/sbin/sh
            ^
      delete this "x" and save the change. you'll have no passwd for root.

then vi /a//etc/default/login

to make sure that CONSOLE setting is correct.

save the change, and reboot your system, make sure you remember to reset the root password.

Good luck!



Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Unix OS

From novice to tech pro — start learning today.