W2K install on clean drive - can't find system files on boot

rcclaffe
rcclaffe used Ask the Experts™
on
Starting with a brand new unformatted harddrive, I attempted to install W2K.  On boot system hangs at line "Verifying DMI Pool Data.....".  When I connect this new drive as slave to a working W2K drive, I can see the new drive is NTFS formatted and it has a WINNT directory with all sorts of system files -- those files just aren't being loaded when starting up using that drive alone.  I tried to do "Recovery" with install disk but got the error "Cannot find Windows 2000 installation to repair".  Is this a Master Boot Record issue on the new HD?  I'd suspect my BIOS could use an upgrade but my other working disk is same make & size & similar model.  I have a win98 startup disk if that version of format or fdisk are needed, just let me know the commands.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
Make sure that the drives are compatible, not all drives from different manufacturer's are compatible in master/slave set up. If you are sure they are compatible then:


Try connecting your "new unformatted" harddrive which has NTFS file system and W2K installed on it as the master drive, that means connect only 1 drive to the computer, then boot the machine. If you still have problems, you need to reformat the drive with the utility program that came with the drive. If you don't have the utility program, then go to the manufacturer's web site and download it, you will need the model number of the drive which is usually printed on the top of the drive.

Commented:
Hi:
If you can afford to reformat the drive while you have it connected as a slave drive, then do so and perform clean install of w2k using NTFS5 which won't have the 4 GB System drive size limit. W2k setup CD should be bootable and you can create the required partitions during setup,  you don't need to use the win98 startup disk and it's tools.

or if you still want to recover, try this:
connect this new drive as slave to a working W2K machine. If the slave drive is D, from MS-Dos prompt, run
chkdsk d:

Good luck

Commented:
what size drive?
what motherboard?
bios and version?

I'm confused :\
if you install the OS on new drive??? No boot..!!
was pin set to master?
is bios configured correctly?

and no you can't use 98 floppy! it cannot correctly manipulate NTFS or understand it.
you need to obtain the correct boot disks for windows 2000 to use options available with OS
http://www.bootdisk.com/bootdisk.htm
JavaScript Best Practices

Save hours in development time and avoid common mistakes by learning the best practices to use for JavaScript.

Author

Commented:
DRIVE: Western Digital 40GB (slightly newer model than the Western Digital 40GB drive which has a working W2K [I'm not doing this for the first time])
MOTHER: Gigabyte GA-5AX (~4yrs old!)
BIOS: Award 4.51a (latest version from gigabyte)

In the beginning: using a W2K setup CD, no valid partions were found on new drive (it was the master, only attached drive), I created a new partition and entered a valid partion size (default size is way too high -- this makes me think there's a problem with BIOS and disk).  Once partion was created, drive was formatted with NTFS, and then files installed, on reboot computer hangs (yes, drive is master - I tried several configurations hoping to get something to stick, all fail).... when I set new drive to be slave for old drive with installed OS, the new drive is recognized as drive "E:", and when examing its contents, low and behold, a valid formatted NTFS drive with a "C:\winnt" directory and what looks like all the standard OS files are found...... so it appears the partion/format/install went as expected, just when starting up the files don't get called.  

I assumed there was something wrong on the MBR, so, for better or worse, ran W2K setup, selected recovery and then console and from command promt ran "fixmbr".  I'm pretty sure that was a mistake now, but still hopeful I didn't destroy the harddrive, or make it unrecoverable (any thoughts on that?).  I don't have anything on the drive so reformatting or repartioning is not an issue.

At this point I believe that the drive is (or was) probably working correctly, and that the real problem is with my old motherboard so I'm getting ready to upgrade that and start from scratch hoping for better luck with a newer BIOS.  It's about time anyway.  Thanks for any assistance.

Commented:
as for fixmbr
not a mistake
this would only create a new boot.ini file
and should have booted

here's another thought!
don't assume the drive is performing correctly.
new m-board might not fix problem.
Did you try?

The Downloadable Data Lifeguard Tools was written specifically for Western Digital EIDE hard drives. It can perform the following tasks on a drive: tests it for problems and errors, fixes certain errors, scans for bad sectors, and provides drive information (serial and model number).
New features:
Certified to work on all current WD drives (model numbers starting with "WD")
Friendly user interface and easy to use
GUI Interface Drive Installation Software
Compatible with Promise card and driver solution for 137 GB barrier
Drive to Drive copy capability with new NTFS support
Fast Format Installation for 98 and ME
http://support.wdc.com/download/dlg/dlginstall_10_0.exe

or

The Diagnostics utility allows you to test the Western Digital drive, print results for last drive tested, repair errors found during the Test Drive option and write zeros to the drive (low-level format).
http://support.wdc.com/download/dlg/dlgdiag10.zip

or

BIOS Check reports number of drives physically detected, number of drives accessed by the BIOS and additional drive table information. This utility was written so end users can report their system configuration to Western Digital technical support personnel when discussing disk drive issues.
http://support.wdc.com/download/dlg/dlgchk10.zip
Commented:
You have 2 PCs or 2 WD HDrives? The working win2k on the WD harddrive is installed on the 1 PC or another PC?
When the PC boots up, does it go past the Boot.ini or does the "Verifying DMI Pool Data....." message comes up right away?

Try changing the boot sequence to HD, floppy, CD-ROM

or
try the 2 command in this sequence:
fixboot e:
fixmbr e:
reboot

Author

Commented:
wtrmk74 - I'll run these utilities and let you know if anything is found.... my most promising lead yet, thanks

mike_ca -
I'm using one computer, switching the HD(s) connected, old drive works as master, new drive only works as a slave.
When booting the PC states "Verifying DMI Pool Data...." and hangs there when the new drive is connected as master.
That msg comes up after running memory test and detecting secondary devices on IDE (and the PC is finding the CD Drive that is connected, sometimes on its own IDE, sometimes as slave, it doesn't seem to matter).

If I run "fixboot e:" then "fixmbr e:" then "E:" would be my new drive and it would be connected as slave, so before rebooting I'll need to remove the working drive and make "E" be the "C", right.  How about if I just run these commands with the new drive as "C" and use the win2k startup disk, go to recovery, then console?  Makes more sense right?

Commented:
rcclaffe:
Check the HD jumpers of the new HD with the old working HD.
Did you try setting the jumper of the new IDE HD as cable select and the CD-ROM as Secondary master?
Did you also try changing the boot sequence to HD, floppy, CD-ROM?

After runing fixboot and fixmbr e: you need to connect it as primary master or primary cable select.
Correct: also, run the commands with the new drive connected as Primary master and run the from the recovery console.

Author

Commented:
thanks mike and wtm, the WD tools were promising and helped in otherways I wasn't asking about here (thus the partial credit), but it appears the true answer to this particular riddle was "fixboot".  I ran this command from setup/recovery/console with only the new harddrive and CD attach to the primary IDE..... and finally, the install worked.

Also, in this final working attempt, I had explicitly set the harddrive to Master and CD to Slave.  In several earlier attempts the jumpers were set to "Cable Select" for the harddrive/CD.  Though I like to think this wasn't part of the solution, I mention it because things don't always work as they ought to, and this was part of the final working configuration.

Author

Commented:
I recently learned something that may have been the primary mistake I made: when using the "Cable Select" setting, I did not know that the placement on the cable was a factor!  The "master" must be the device at the end of the cable, the "slave" in the middle of the cable, DOH!

Every time I attempted to use the "cable select", the CD drive was at the end of the cable! Guaranteed failure every time.  Well that probably doesn't account for all the problems I had, but it certainly helped me to waste several hours.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial