can't locate module char-major 10-135

Hello,

I have noticed this line during bootup on my Debian 3.0r1 Linux 2.4.21 system, and wonder if anyone knows what it is and how to get rid of it. I've searched the help files for the kernel while configuring it prior to compilation, but have not found which module it is coming from.
I think it somthing related to RTC Real Time Clock.

modprobe: can't locate module char-major 10-135

/dev# ls --color | grep rtc
rtc  # in yellow

thanks
samjAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

natmaCommented:
you probably have compiled CONFIG_RTC in the kernel

to recreate the special file /dev/rtc install the 'makedev' package and do, as root:
cd /dev
./MAKEDEV rtc

you can also use mknod
samjAuthor Commented:
I have followed as you said for no avial, I still get that error when bootup. I have also been noticing this as well:
Setting the System Clock using the Hardware Clock as references...
modprobe: can't locate module char-major 10-135
System Clock set. Locat time ...

OpenBSD Secure Shell server not in use (/etc/ssh/sshd_not_to_be_run)

I am not sure what you ment by "you can also use mknod"
natmaCommented:
if you know how to compile a kernel and have a .config working for your hardware: compile a kernel w CONFIG_RTC ('Enhanced Real Time Clock Support' in "Character devices")

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
samjAuthor Commented:
yes, that was right, I did not select this option before. I am glade you told me it is in "Character devices" other wise I would have never guessed it.  is there some where online searchable database for a quick reference in locating kernel options so such a problem in finding options does not have to be a pain?

I compiled that option into the kernel and that fixed the problem but the line "OpenBSD Secure Shell server not in use (/etc/ssh/sshd_not_to_be_run)" still shows up.
imnoguruCommented:
You could get rid of the char-major 10-135 line by commenting the alias line in the /etc/modutils/arch/i386 that contains the char-major-10-135 string (might be the only one)
after that you can run update-modules.modutils

that is if u don't want to recompile the kernel.(it looks like is too late for that)

As for the ssh issue, try (re)moving the file sshd_not_be_run from the /etc/ssh directory if it exists.
If that doesn't work try to purge the ssh package and then reinstall it.

(From aptitude if u pres "_" then the package is marked for purging or

apt-get --purge remove ssh

from console)
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.