Problem installing SP4 on Win2k Server....riprep.exe is open or in use...???

franklinmatt
franklinmatt used Ask the Experts™
on
I've been stumped on this problem and have found no answers on the web, so I registered here....

We have a Windows 2000 Server with Service Pack 3 that we tried to load Service Pack 4 on.  During the installation, an error appears:

Service Pack 4 Setup Error
The file c:\winnt\system32\dllcache\riprep.exe is open or in use by another application.
Close all other applications and then click Retry.
<Retry>  <Cancel>

Hitting Retry makes the error appear again, and cancel will cancel the entire installation.  We have searched for riprep.exe while the error message is up and the file is not even on the computer, so I can't see how it is in use.  It is not in the processes, nor is anything unusual running, we have also rebooted.  From what I gathered on the web, riprep.exe seems to have to do with deploying remote installation images, which we are not doing, nor have we ever tried to.  This is just a normal installation of SP4 on a normal manual installation of Win2k Server.  As far as I can tell riprep.exe should not even be used, so I don't understand this at all.  We have successfully installed SP4 on other servers, so only one is having this problem.  I've tried both the web install and redistributable copies of SP4, and both have the problem.
If anyone has any ideas on how to get past this or why riprep.exe is even being called, I would be very grateful.

Thanks,
--Matt
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Was this OS installed using the RIS (Remote Installation Service) that MS uses? It's name is actually RiPrep.exe, your current problem. RiPrep causes secondary path issues within the registry and if you try to run the update on the local machine, instead of through the RIS, then you will run into this problem. So you'll need to figure out if the servers OS was installed using RIS. Then post your answer here.....

Author

Commented:
No, we have never used RIS.  To be honest, neither of us knew about RIS before I looked up this problem and read about riprep.exe and RIS.  The OS was installed normally, by booting off the Win CD on the local computer and running through setup.
Check your registry for this entry:

HKEY_LOCAL_MACHINE\Software\Microsoft\WindowsNT\CurrentVersion\Winlogon\Shell:REG_SZ:C:\Winnt\Explorer.exe,

Note the comma at the end of the entry.... Waiting for your response
Learn Ruby Fundamentals

This course will introduce you to Ruby, as well as teach you about classes, methods, variables, data structures, loops, enumerable methods, and finishing touches.

Author

Commented:
I apologize, but the server is at a remote location that I won't be able to check immediately.  I will respond as soon as I can, thanks for your reply.  So as to kill two birds, f I do encounter this registry, what should I do?

Commented:
Did you try scanning server with fixsobig and fixblaster antivirus tools?
Virus has nothing to do with this as it is an imaging situation that has to do with the RIS service that windows incorporates into its software.

Author

Commented:
mkachurak, the registry key did not have the comma in it.  Nor is the computer infected with any virus.
This may be a far cry from the actual fix, but check what's in the dllcache folder? I'm not too sure what this would be, but if there's not much in there, try to rename it temporarily and see if you can do it then,.... I'm still thinking and researching this for you...
you may want to download and install the RIPREP.EXE update patch from MS also. Not sure if this may help you, but it's one direction to go in.

http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=CDA7F9FC-FE32-4826-A646-D64314178888

The issue now, is to find out exactly what's up with the registry. I'm thinking that somewhere in the registry, it's got information on using sysprep or ris to install your image, even though it was done from the cd. When you imaged this machine, did you fdisk, format and then install or did you update or just partition and do another installation?

Commented:
Why don't you try stoping all unnecessary services and installing service pack?
Commented:
did you do a search for riprep.exe after you turn on the option of showing all the system and hidden files?
use kill.exe to kill any processes associated with riprep.exe , eg: c:\>kill.exe riprep

Author

Commented:
Okay, we searched again for riprep.exe during the installation, this time using an administrative setup file for SP4 and it created the dllcache folder (loading it over the internet did not create this directory) and the riprep.exe file was there.  We took ownership of hte folder and renamed riprep.exe and it worked after that.  RIPrep was still not running even though it said it was.  Very strange, but that'sthat.
I had a similar problem w/ a slightly different solution:  mine said the same error but for d:\ntldr

Didn't exist either.  The problem was the account i was logged in with didn't have full control, wasn't a local administrator.

changing this allowed sp4 to continue and successfully install.  Probably why yours worked after you took ownership, rather than the rest of that.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial