Q u o a t a s doesn't work

swooshosh
swooshosh used Ask the Experts™
on
Red hat 8.0
Trying to activate disk quotas for user. I´ve read the Quota mini-HOWTO, but I can't make it work.

I assume the prekompiled kernel supports quotas, is that correct? The quota tools are on the system.

My fstab looks like this:
LABEL=/                 /                       ext3    defaults        1 1
LABEL=/boot             /boot                   ext3    defaults 1 2
none                    /dev/pts                devpts  gid=5,mode=620  0 0
LABEL=/home             /home                   ext3    defaults,usrquota 1 2
...

and there is this part in the /etc/rc.sysinit

# check remaining quotas other than root
if [ X"$_RUN_QUOTACHECK" = X1 -a -x /sbin/quotacheck ]; then
        action $"Checking local filesystem quotas: " /sbin/quotacheck -aRnug
fi
if [ -x /sbin/quotaon ]; then
    action $"Enabling local filesystem quotas: " /sbin/quotaon -aug
fi

Hower, I get this in boot.log
  Cannot find quota file on /home [/dev/hda5] to turn quotas on/off.

So I try to do
  edquota -u user
And get this
  edquota: Quota file not found or has wrong format.
  No filesystems with quota detected.

What is missing?

Thanks for your time,
--ph
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Have you create the quota.user and/or quota.group file(s) into your home directory?

Both quota record files, quota.user and quota.group, should be owned by root, and read-write permission for root and none for anybody else.
Login as root. Go to the root of the partition you wish to enable quota, then create quota.user and quota.group by doing:

touch /home/quota.user
touch /home/quota.group
chmod 600 /home/quota.user
chmod 600 /home/quota.group

after that try again :)

Author

Commented:
Ok thanks. That took away the error at boot (I used aqutoa.user and aqutoa.group). However, the edquota-error still remained. For the googling folks: this solved that
quotacheck -acugv
Am still not sure what all the parameters means, but it seems that the -c recreates the aqutoa.* files so they have the correct format.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial