Linux not reaching the internet -- DNS??

daveburrow
daveburrow used Ask the Experts™
on
newbie, green and wet --- nuff said

Been to and fro on this list trying to help myself to no avail.

Setup:
    Linksys wireless 802.11g router/DHCP connects:
    Box 1) My main XP box
    Box 2) An older 233 mHZ running NT 4.0, functions as an IVR for the phones
    Box 3) An older 233 mHZ running RH 9.0
    Box 4) ADSL modem

Symtoms/Clues:
    Linksys provides dynamic IP address for all boxes
    Windows boxes (XP and NT) successfully can resolve DNS lookups
    Linux box can not ping by name
    Linux box can not ping the internet (any site)
    Linux box CAN ping (by address) Linksys router and DSL modem
    PPP fails to start

Aids:

[root]:/etc ==> cat host.conf
order hosts,bind
multi on

[root]:/etc ==> cat resolv.conf
nameserver=207.69.188.185

[root]:/etc/sysconfig/network-scripts ==> cat ifcfg-eth0
DEVICE=eth0
ONBOOT=yes
BOOTPROTO=dhcp

[root]:/etc/sysconfig/network-scripts ==> cat ifcfg-ppp0
USERCTL=yes
BOOTPROTO=dialup
NAME=DSLppp0
DEVICE=ppp0
TYPE=xDSL
ONBOOT=yes
PIDFILE=/var/run/pppoe-adsl.pid
FIREWALL=NONE
PING=.
PPPOE_TIMEOUT=20
LCP_FAILURE=3
LCP_INTERVAL=80
CLAMPMSS=1412
CONNECT_POLL=6
CONNECT_TIMEOUT=60
DEFROUTE=yes
SYNCHRONOUS=no
ETH=eth0
PROVIDER=DSLppp0
USER=[maskeduser]      
PEERDNS=no

--------------------------------------------------------------------

Note: USER=[maskeduser] mannually altered from original value

Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Top Expert 2006
Commented:
I suspect that what you need to do is alter the default route for your linux box in order to ensure that it routes correctly to the outside world.

Please print out the response to the command route, so we can all see the actual routing, but I suspect that the following will solve your problem:)

You will then need a command (obviously adjust for your network) similar to:

route add default gw 1.2.3.4 dev eth0

(man route for more info)

To enable the DNS for your linux box, you need to add the capability to use a DNS server that you can access. Try adding the line: (This will enalble DNS lookups even if your routing is wrong)

nameserver=w.x.y.z

to your resolv.conf, where w.x.y.z is the ip address of your router. This is because many routers have the capability to act as aDNS proxy. I presume that 207.69.188.185 is the ip address of the DNS server given by your ISP.

HTH :)
Top Expert 2005

Commented:
Since you have the Linksys router acting as an Internet gateway you don't need PPP on the Linux box at all. And that is probably at the root of the current problems. That needs to be removed from your configuration and the system rebooted. The Linux box should then get everything it needs from the DHCP negotiation.

You can check to see that a default route has been set by executing '/sbin/route -n' and looking for a line with a Destination of 0.0.0.0. The Gateway should be the IP of your Linkys router.

Author

Commented:
OK -- so I believe I've kept ppp0 from starting on boot, but I don't believe I've "removed" it. Is removal of ppp0 accomplished by just "rm /etc/sysconfig/network-scripts/ifcfg-ppp0" ??

Further info: I am working this issue to build a "development box" to play on, modeled after a dedicated server provided by a hosting service (I know, "what on earth a newbie is doing with dedicated server"?).  

Anyway, comparing the functional setup of the working server with my local linux setup, I notice an additional line in the output:

[root]:/root ==> route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 eth0
169.254.0.0     0.0.0.0         255.255.0.0     U     0      0        0 eth0
127.0.0.0       0.0.0.0         255.0.0.0       U     0      0        0 lo
0.0.0.0         192.168.1.2     0.0.0.0         UG    0      0        0 eth0

The host 169.254.0.0 seems erroneous..... I'm not sure if I should be attempting to delete it, but assuming I should, the delete attempt returns:

SIOCDELRT: No such process

Doing a web search on "SIOCDELRT" returned multiple advice like "add more operands to the route command"

I've tried:

route del -host 169.254.0.0
route del -host 169.254.0.0 eth0
route del -host 169.254.0.0 netmask 255.255.255.0
route del -host 169.254.0.0 netmask 255.255.255.0 eth0

which returns the same "SIOCDELRT" or:

route: netmask 000000ff doesn't make sense with host route

=====
Thanks for the help so far, I'm learning as we go, but -- Symtom remains as originally stated -- no internet access.....  
=====

Rowby Goren Makes an Impact on Screen and Online

Learn about longtime user Rowby Goren and his great contributions to the site. We explore his method for posing questions that are likely to yield a solution, and take a look at how his career transformed from a Hollywood writer to a website entrepreneur.

Top Expert 2005

Commented:
How about showing what '/sbin/ifconfig -a' shows?

And what does /etc/resolv.conf contain?

To eliminate the PPP connection you need to delete the PPP connection informationn in the same tool that you used to set it up in the first place.

Author

Commented:
eth0      Link encap:Ethernet  HWaddr 00:90:47:03:B9:D9
          inet addr:192.168.1.111  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:527 errors:0 dropped:0 overruns:0 frame:0
          TX packets:919 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100
          RX bytes:72673 (70.9 Kb)  TX bytes:171405 (167.3 Kb)
          Interrupt:10 Base address:0x6000

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:10 errors:0 dropped:0 overruns:0 frame:0
          TX packets:10 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:700 (700.0 b)  TX bytes:700 (700.0 b)


[root]:/root ==> cat /etc/resolv.conf
nameserver 192.168.1.2
nameserver 207.69.188.185


=====

where 192.168.1.2 = linksys router
where 207.69.188.185 = ISP's DNS

got WEBMIN going this morning..... still not obvious to me what the issue might be

Top Expert 2005

Commented:
Ordinarily I'd expect the Linksys to be at 192.168.1.1. Are you sure that the IP of the Linksys is correct? And is the Linksys providing a DNS proxy?

Commented:
Hmm , there is something I can understand . As dhcp work correct and the box hase obtained 192.168.1.111 address and 192.168.1.2 gw you have to be able to ping any ip address no matter DNS is correct or not . But anyway , this route - to 169.254.0.0 network (btw , daveburrow it is network , so the correct command have to be "route del -net") is automaticaly added after initializing eth0 before dhcp reply received . But once we havee obtained real ip address , this route must disappear its self , am I wrong ?

Author

Commented:
jlevie ---
The address for the linksys is correct as 192.168.1.2 -- I had configured this under its administration web page from its default value so as not to conflict with the DSL modem on the local LAN that had itself also laid claim to the default of 192.168.1.1.  I can change the address of the DSL modem as easily as I had changed the address of the linksys, if that were to prove important.

The modem is at 192.168.1.1 -- has its DHCP capability, and I believe that to have been disabled
The linksys is at 192.168.1.2 -- it behaves as DHCP server for the local lan, and I believe it is itself assigned an ip address at the ISP via dhcp

brabard ---

Thanks for the "-net" info --- yes, I've now removed the 169.254.0.0 entry.  

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.1.0     *               255.255.255.0   U     0      0        0 eth0
127.0.0.0       *               255.0.0.0       U     0      0        0 lo
default         192.168.1.2     0.0.0.0         UG    0      0        0 eth0

Top Expert 2005

Commented:
Does the Linksys have a default route pointing to your DSL modem? If you go to one of the windows boxes and do an 'ipconfig /all' in a cmd window what is shown for the default route and DNS server?

Commented:
Could you please provide the following:

cat /etc/nsswitch.conf
traceroute to an outside IP Address.
If you look at daveburrows first post, his nameserver entry does not have an = in it in /etc/resolv.conf.  I believe this = is not allowed.

Commented:
this may just be a network set up issue.  i have a bunch of questions for you, then i think i can help you.

what brand/model is your adsl modem?

are any of your clients wired w/ ethernet, or are they all wireless?  which ones?

what is the WAN address assigned to your linksys router (from the status page)
how is the WAN address assigned to your linksys router (static or dynamic?)
what is the LAN address assigned to your router (192.168.1.2, correct?)
what type of client is the linksys acting as?  (PPPoE, RAS, etc)



Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial