System Tray - Hide inactive icons not working

arwood
arwood used Ask the Experts™
on
Win XP home on my laptop. System Tray shows active icons correctly but the lbutton in the shape of the little circle with the arrow head in its centre is missing. I can therefore not show inactive icons. The icons that do show are sometimes intermittent eg "Remove Hardware safely" virtually never shows but does occasionally. Even the missing button come on about once a month. I have tried Increasing the size of the taskbar and restoring it, selecting a lower colour resolution, locking the taskbar. I have even disabled all startup items so that nothing shows. Still no arrow button. Any help appreciated.

Alan Wood
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Top Expert 2004

Commented:
Alan Wood,

The arrow will show only when you select "Hide inactive  icons".
For that Right-click your Start button and go to properties.

Select Taskbar tab on the left top and enable "Hide active icons".
Click "customize" and select the "behavior" for whatever icons you want to.


Restart the computer and see if that would solve the problem


If you have disabled all the icons during startup there would be no icons showing in the system tray and no need for "hide active icons"


Sunray

Author

Commented:
Hi Sunray
Thanks for the very quick reply (5mins). I am impressed. However I was aware of what you say and the "Hide inactive icons" checkbox is ticked and some icons are selected "Always Show" and some "Hide when inactive" I did the diabling as some MS data said that if some icons took a long time to load then it could possible screw up the other icons. I disabled all to see if it made any difference and then enabled them progressively.Still the same problem.

Regards

Alan Wood

Commented:
Trying to piece together what you are describing, it really sounds like the application that you want to see in the taskbar isn't showing at all. It may not be starting. When you right lick on the task bar and select properties and then select the Customize button on the tasbar tab do you see the program with the "button in the shape of the little circle with the arrow head in its centre"?

If you don't then it is not configured to startup at logon. Do you know what that program is?
If you do then you can look in four (4) different places to determine if it is configured to start up:

Open windows explorer and navigate to:

c:\DOCUMENTS AND SETTINGS\ALL USERS\PROGRAMS\STARTUP
C:\DOCUMENTS AND SETTINGS\USERNAME\PROGRAMS\STARTUP

Open regedit and navigate to:

HKEY_LOCAL_MACHINE\SOFTWARE\MICROSOFT\WINDOWS\CURRENTVERSION\RUN
HKEY_CURRENT_USER\SOFTWARE\MICROSOFT\WINDOWS\CURRENTVERSION\RUN

Bootstrap 4: Exploring New Features

Learn how to use and navigate the new features included in Bootstrap 4, the most popular HTML, CSS, and JavaScript framework for developing responsive, mobile-first websites.

Top Expert 2004

Commented:
For the moment try the TweakUI

http://www.microsoft.com/windowsxp/pro/downloads/powertoys.asp

cos this has an option of rebuilding icons.

So what ever it is you want the " show hidden icon" to appear . Right ?

Sunray

Commented:
See if this helps

Delete the IconStreams and PastIconsStream values from the following registry key:
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\TrayNotify

Author

Commented:
Attn Gemarti
First thanks for the reply. I am sorry but that is not the situation. No I do not see the circle button with the arrow although "Hide inactive icons" is ticked. All the start up programs configured to start from either the registry or start up folders actually work. Its that they are not shown in the system tray such as printers on line or similar.

Attn Sunray
Hi again. Its not just a problem with rebuilding the icons as the icons are correct.

Hi CrazyOne
I will try this shortly and revert.

In general the symptoms are as though the "Hide inactive icons" checkbox is not writing to wherever it is supposed to in the registry. Maybe for some reason the key has gone corrupt. I don't know where the key is and I have tried a registry search for icons I do know are present to try to find it. I was hoping someone just might know

Thanks   Alan

Author

Commented:
Hi CrazyOne
I tried it and it still had no effect. I deleted both keys and rebooted. Only the IconStreams key was recreated.I also notice that if I try Taskbar/properties/customise there is a long list of Past Items for which incorrect icons are shown but looking at my desktop this seems to be the same so it probably means nothing.
Alan

Commented:
Well it was a long shot. My experience with XP's icon hiding has been hit and miss sort of like what is happening to you. It works sometimes and other times it doesn't work. Quite frankly I think it is a bug in XP's code. Maybe it will be fixed when SP2 is released.

Author

Commented:
Hi CrazyOne
You may very well be right. I just wish I could fing where it writes to the registry when I activate Icon Hiding.
Thanks anyway
Alan
arwood -

I've had the same problem.  And I believe the accurate description for the button is a 'chevron'.  The only way I got rid of it was to UNcheck <Lock the taskbar> and <Auto-hide the taskbar> and <Hide inactive icons>.  I restarted XP and then checked <Hide inactive icons>.  Haven't had any problems since.

Also, there is a <customize> button next to Hide inactive icons, you may want click that and hit <Restore Defaults>.

Almost every technical discussion formum has something regarding this problem and as mentioned before I think it's just buggy.

Later,
VirtualF

Commented:
Sorry if this has already been said,(its late and the eyes are tired and don't want to focus on the thread), but is the taskbar lock? Right click on the task bar, you will see Lock task bar, uncheck this if it is checked.

Author

Commented:
Hi VirtualF
I tried your ideas but it did not work for me. Sorry but thanks anyway.

Hi wdr503
I've tried that too with no effect. Sleep well.

Alan

Commented:
arwood comments:
>>Tray shows active icons correctly but the lbutton in the shape of the little circle with the arrow head in its centre is missing. I >>can therefore not show inactive icons.

>>Its that they are not shown in the system tray such as printers on line or similar.

arwood: you wouldn't happen to be looking for the "button" that looks like this "<<" with a circle around it; would you? It appears just to the left of the area where the active Icons are displayed?
 If so that button only appears when an application is inactive. That is why it appears and disappears intermittently. Not all programs that are in the taskbar go inactive. For instance your Virus Scanning software is probably active all the time. If you have your network connection showing in that area it is probably always active.

As for your comment on the printers I have only seen the printer Icon appear when it is printing. That is because it is active. When the printer isn't printing anything it isn't an inactive running program. As a matter of fact the printer component isn't even running unless it receives a command to print.

Commented:

Hi,
After trying all the above, plz try this as well coz it just worked on my system which was experiencing the same problem.

Lets perform the following steps:



1.      Right click on the task bar, and then select properties.

2.      Click to clear the "Hide inactive icons" option.

3.      Click Apply.

4.      Right click on the task bar, and then select properties again.

5.      Select the "Hide inactive icons" option.

6.      Click "Customize?" button.

7.      In the Customize Notifications window, you can set all the items to be:

a)      Always show.

b)      Hide when inactive.

c)      Always hide.

P.S. Here I selected Always Hide for all third party installed programs and Hide when Inactive for windows installed components like java, windows system error etc.
I've chosen Always Hide for Volume.


8.      After setting these items, click OK to confirm.
 
                 Hit Apply and OK again

Is the problem resolved?

Commented:

It shud definitely work that way...
Cross checked again.
I just have one icon of Volume in the tray and no ARROW HEAD IN THE CIRCLE.

What I found is if I Customize it to hide icon when Inactive OR Always Show, The ARROW HEAD IN THE CIRCLE GOES AWAY

so I set it to Always Hide and the Arrow head in the circle is always there now.

I think there is any program which need to be Always Hide on ur computer too...

If u r not sure then, set all programs in the notification area as Always Hide.
Hit OK and see

Author

Commented:
Hi Gemarti and Alex

I tried your suggestions without success. I need to clarify one point. I do not even get the circle never mind just the enclosed chevrons. I know I have inactive programs as I can test out the effect on my desktop machine. It makes no difference if I customise to always show, always hide or hide when inactive. I appreciate that not all programs are inactive so I simulate it with one known program. (Quick View to look at a document and then close it down. On my desktopmp the icon disappears and the circle with chevrons appears and clicking on it shows the inactive program icon). Whatever program in WinXP which operates this function is just not working. Sorry to be such a pain in the A but I have been trying to sort this for about 5 months before putting it on EE.

Regards and thanks again   Alan

Commented:
>>>I have been trying to sort this for about 5 months before putting it on EE.

Join the club. I gave up on it a long time ago. :>)

Seen a lot of people posting about this as well. Have yet to see a remedy that works all the time.
Hello Alan,
I must admit that I am a little confused about your last post, I am not sure if you are actually able to get the circle and chevrons to appear or not. I was having the same problem when I started reading this thread, and I tried all the obvious things that are listed in the previous posts, here is the magic combination that finally solved my problem. I noticed that if I set any icons to ‘Always hide’ then the chevrons would appear, however they would go away just as quickly if I returned the setting to 'Hide when inactive'. The trick is that I rebooted while I had two icons set to 'Always hide'. I doubt that the fact that I chose two icons to hide was relevant, but I am fairly certain that rebooting while the setting was in place somehow reset the 'Hide Inactive Icons' functionality. After rebooting I was able to set all icons back to 'Hide when inactive' and the circle and chevrons appeared as normal. Give it a try, doesn't sound like you have anything to lose unless it doesn't work of course, then there is your sanity.


Good luck!!

Author

Commented:
Hi

Thanks for the posting. To clarify I do not get either the circle or a circle with chevrons. The left hand edge is a straight line. However I think you are getting there as I tried it and it worked for a time. I need a bit more time to experiment and I will revert but it is looking more hopeful than before.
Alan

Author

Commented:
Hi "bstephenc"

Sorry to be such a long time but one of my network maachines crashed fatally last week and it needed a complete reformat etc. Much time wasted!!!
It seems that what you advise is mostly true and it certainly restores the hide function however what I have found is that in order for it to "stick" I have to leave one item set to "al;ways hide". As this is not a problem I can live with the situation so I can award you the points. If you post a reply to this I will accept it.

Alan
thanks "bstephenc" . I had only to make 1 icon always hide. Then the arrow came again. Now the icon is autohide again and everything is going allright.

:-)

diurnambule

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start Today