Solved

Visual Studio.Net has detected. . . not running ASP.NET version 1.1. You will be unable. . .

Posted on 2003-10-21
52
65,732 Views
Last Modified: 2012-05-12
Experts, you've seen that message before.  It has happened to me after trying to Deploy a Web Project for the first time.  I have followed the instructions in MIcrosoft Knowledge base Article #306005 and run aspnet_regiis.exe.  

That didn't fix it.  

As it stands I can't open any projects.  In the Solution Explorer Looks like this:

Solution 'MasterList' (1 project)
     - WebDeploy
           - Detected Dependencies
           - (unable to determine name)
           - (unable to determine name)
     - MasterList (unavailable)
               The project file cannot be found.

But it is still there.

Some pointer setting has been knocked off, but I don't know which one.  

I'd like to fix this without having to reinstall IIS and Visual Studio.

Any suggestions?  Thanks!

0
Comment
Question by:GMosher
52 Comments
 
LVL 96

Expert Comment

by:Bob Learned
ID: 9593891
Look at Micro$oft KB article:

PRB: "The Specified Web Server Is Not Running ASP.NET Version 1.1" Error Message When You Create ASP.NET 1.1 Application
http://support.microsoft.com/default.aspx?scid=kb;en-us;817267

Hope it helps.
0
 

Author Comment

by:GMosher
ID: 9593997
Thanks.  It does feel like it could be something like that.

Unfortunately, that article applies to Microsoft Windows Server 2003.  

My IIS doesn't have a "Web Service Extensions" option.

So, I am still stuck.
0
 
LVL 96

Expert Comment

by:Bob Learned
ID: 9594032
Under Add/Remove Programs do you have 2 entries for Micro$oft .Net Framework 1.1.  One 6 MB and the other 37MB?
0
 

Author Comment

by:GMosher
ID: 9594106
Just one - 36.83 MB.
0
 
LVL 96

Expert Comment

by:Bob Learned
ID: 9601076
You did both steps of 306005, right?
0
 

Author Comment

by:GMosher
ID: 9601454
Yes.  I did it again to be sure.  

Step 2 reported that it had succeeded.

Still no go.
0
 
LVL 96

Expert Comment

by:Bob Learned
ID: 9601560
Did you have the 1.0 framework, and then upgrade to the 1.1 framework?
0
 
LVL 96

Expert Comment

by:Bob Learned
ID: 9601603
I found this forum reference that might help:

http://forum.discountasp.net/topic.asp?TOPIC_ID=431

It references an article about get_aspx_ver.aspx:
http://bluebones.net/news/default.asp?action=view_story&story_id=50

0
 

Author Comment

by:GMosher
ID: 9601722
Installed 1.1 new, not an upgrade from 1.0.

I'll have a look at those links and report.

THanks!  

0
 

Author Comment

by:GMosher
ID: 9601930
CustomError was set to "RemoteOnly"   - doesn't seem to explain why I can't even open a project locally.

Should I break down and reinstall?  

If so, which should I try first: IIS or Visual Studio?

0
 
LVL 96

Accepted Solution

by:
Bob Learned earned 500 total points
ID: 9602000
I have seen references to reinstalling VS.NET after IIS, so try .NET first.
0
 

Expert Comment

by:Kai77
ID: 9979031
I had the same problem, the solution I found:

Try running from commandline:

C:\WINNT\Microsoft.NET\Framework\v1.1.xxxxx\aspnet_regiis.exe -i

or

in this case being Windows XP Pro:

C:\WINDOWS\Microsoft.NET\Framework\v1.1.xxxxx\aspnet_regiis.exe -i

I do realize an answer was accepted already, but this might come in handy for people who don't feel like reinstalling anything.

0
 

Expert Comment

by:delacru2
ID: 10006651
Kai77

I had this problem and running aspnet_regiis.exe -i fixed it. Didn't have to reinstall.

Thank You
0
 
LVL 6

Expert Comment

by:LeeHenry
ID: 10214193
I went to add remove programs, and there was only one version of asp.Net 1.1, but when I checked the directory in dos, it had 2 versions.. 1.0 and 1.1. I delted 1.0, and ran Kai77's command (C:\WINDOWS\Microsoft.NET\Framework\v1.1.xxxxx\aspnet_regiis.exe -i)...
It fixed the problem.

Thanks Kai77
0
 

Expert Comment

by:Raibeart
ID: 10413414
I have an XP installation that I have tried to run the aspnet_regiis.exe -i on, but it has not had any effect.  I have uninstalled the framework and VS, reinstalled them, but still cannot get it to work.  Is there another fix of some kind?
0
 

Author Comment

by:GMosher
ID: 10413503
This won't make you feel any better, but I'm not an Expert.

I finally got fed up with uninstalling/reinstalling, running aspnet_regiis.exe, etc - all to no avail.  

So I bought a new PC and installed everything from scratch. That worked.

I wouldn't want to do that every time an application gave me trouble, though.  
0
 
LVL 6

Expert Comment

by:LeeHenry
ID: 10414771
*see what I did above* That worked for me.
I know someone who reformatted  their hardrive and it worked for them

0
 

Expert Comment

by:Raibeart
ID: 10414813
I would like to do it without reformatting my drive or buying another computer.  I have 12 now.  ;-)  LeeHenry, I did what you did also, but nothing changed.  :-(
0
 

Expert Comment

by:delacru2
ID: 10472324
Hello,

I can't get this miserable vs.net to recognize v1.1.4322, I have tried everything including going into the registries and changing every entry I saw with v1.0.3705 with v1.1.4322. And still it sees something that is not there.

I had this problem on my work station and fixed it with aspnet_regiis.exe -i, but now that I have to deploy my web site to the server the miserable server doesn't want to play.

Can someone please have some mercy on this lost soul and shed some light on how can I ger this to work on a win 2000 server with IIS 5 and VS.Net Enterprise Architects 2003.

Thank You
Julio
0
 
LVL 1

Expert Comment

by:UncleAndy
ID: 10666850

Kai77:

C:\WINDOWS\Microsoft.NET\Framework\v1.1.xxxxx\aspnet_regiis.exe -i

Worked great for me too! Thanks!

UA
0
 

Expert Comment

by:Kai77
ID: 10666886
Too bad I can't receive any points :(
0
 

Expert Comment

by:Kai77
ID: 10666892
But I am really glad so many people found this solution useful
0
 

Expert Comment

by:Raibeart
ID: 10670618
On my XP machine, I had to remove VS 2003, the framework, and IIS and then reinstall them in reverse order, IS, Framework, VS 2003.  After that, it worked as it should.
0
 

Expert Comment

by:anexela
ID: 10710399
Didn't work for me either...
0
 

Expert Comment

by:petebern
ID: 10746070
Worked for me. Thank you so much.

I'm running Windows XP Pro and the Academic version of VS.net 2003
0
 
LVL 1

Expert Comment

by:jasonwisdom
ID: 10754286
I removed the 1.0.asdf and ran aspnet_regiis -i and that solved my getting this error.

Thank you, both Kai77 and LeeHenry!!!
0
What Is Threat Intelligence?

Threat intelligence is often discussed, but rarely understood. Starting with a precise definition, along with clear business goals, is essential.

 

Expert Comment

by:sinhadeepak
ID: 10918732
I have a win2k proffessional installed on my machine. I am also trying to do the same through aspnet_regiis -i
but it is not workiing.

Is there any other resolution  to this problem

Deepak Sinha
0
 

Expert Comment

by:preeth
ID: 10935868
Hi

This topic was intresting ...

I have tried all the above options - but my problem is not solved ...................

Can u guys continue with this above discussions to resolve my problem..... I will be greatfull to u guys...

Preeth
0
 

Expert Comment

by:lobos
ID: 11193182
Kai77

I had this problem and running aspnet_regiis.exe -i fixed it. Didn't have to reinstall.

Thank You
0
 

Expert Comment

by:mclist
ID: 11207785
I was having the "Specified Web server is not running ASP.NET version" for the following reason:

VS.Net makes a request to the target server for the file ~/get_aspx_ver.aspx

In my IIS script mappings, I had the setting "Check that file exists" ticked for ASPX files.

Hence IIS was returning the standard 404 error html, without processing through ASP.Net and getting the version header.

IMHO this is a sad kludge by Microsoft

To solve, I recommend checking the setting for "Check that file exists" or making a dummy ~/get_aspx_ver.aspx file if you need to have a proper 404 handler.
0
 

Expert Comment

by:wilkersons
ID: 11217149
Many thanks as aspnet_regiis.exe -i worked for me too.

0
 
LVL 6

Expert Comment

by:JohnDesautels
ID: 11552792
Kai77:

C:\WINDOWS\Microsoft.NET\Framework\v1.1.xxxxx\aspnet_regiis.exe -i

Worked great for me too! Thanks!

John
0
 
LVL 1

Expert Comment

by:tomlau
ID: 12080348
Kai77:

C:\WINDOWS\Microsoft.NET\Framework\v1.1.xxxxx\aspnet_regiis.exe -i

Works for me too. Thanks!
0
 

Expert Comment

by:gags03
ID: 12089153
Kai77:

C:\WINDOWS\Microsoft.NET\Framework\v1.1.xxxxx\aspnet_regiis.exe -i

Works for me too. Thanks!
0
 
LVL 1

Expert Comment

by:mgcarney
ID: 12125781
ya that is too bad Kai77 that you cant receive any points....
0
 

Expert Comment

by:NateDizzle
ID: 12401543
I would just like to make it clear that GMosher initially offered the aspnet_regiis solution...he even by citing the help article number.

And also that the aspnet_regiis solution can be found by pressing the "Help" button when that error appears....Windows actually does try to offer solutions, so make use of them.
0
 

Expert Comment

by:crownclit
ID: 12621264
C:\WINDOWS\Microsoft.NET\Framework\v1.1.xxxxx\aspnet_regiis.exe -i

Works here as well

Cheers:
CrownClit
0
 

Expert Comment

by:LoveToSpod
ID: 13192311
ARE YOU BEHIND A PROXY SERVER? - READ THIS!!! >>>>>

I had this problem REAL BAD!!!!!!!!!

Nothing of the above worked, I uninstalled, and re-installed all in the right order. I have extracted some of the text from the link, and this solved the problem:

http://www.codeguru.com/columns/VB/article.php/c7277/

It then occurred to me my network is using a proxy server. By using localhost as the host URL, VS.NET was seeing the proxy server, which must have ASP.NET 1.0 installed on it. <<<The solution, or fix, was to bypass the proxy server.>>>

Because ASP.NET uses the network configuration settings from Internet Explorer, we can change the proxy settings through Internet Explorer. (Keep in mind that this problem and fix are only relevant if you are networked and using a proxy server.)

To change the proxy settings, start Internet Explorer and follow these steps:

Select Tools|Internet Options.
In the Internet Options dialog, select the Connection tab.
On the Connection tab, click the LAN Settings button.
If Use a proxy server... is checked in the Proxy server group (see Figure 3), check Bypass proxy server for local address (see Figure 3).
Click OK to close the LAN Settings dialog, and close the Internet Options dialog.

VOILA!!! - BIG respec to the guy on CODEGURU.COM that nailed this one.

Hope this helps...

LoveToSpod
0
 
LVL 3

Expert Comment

by:sr22ger
ID: 13220469
Thanks Kai77, your solution worked for me as well.
sr22ger
0
 

Expert Comment

by:dmeenan
ID: 13266465
Kai77,

Thanks so much.  
C:\WINNT\Microsoft.NET\Framework\v1.1.xxxxx\aspnet_regiis.exe -i worked perfectly.  
Total props!

dmeenan
0
 

Expert Comment

by:Fat_Albert
ID: 13342078
I'm glad I found this thread -- I recently re-built my system and re-installed dotNet ver 1.1, IIS and Visual Studio .Net.  When I tried to start up an ASP.NET project I got the...

"Visual Studio .NET has detected that the specified Web server is not running ASP.NET version 1.1. You will be unable to run ASP.NET Web applications or services."

...error message like you guys.

C:\WINDOWS\Microsoft.NET\Framework\v1.1.xxxxx\aspnet_regiis.exe -i

This solved the problem for me!
0
 

Expert Comment

by:AcelgaFrita
ID: 13343612
I had the same problem, but nothing I read here helped.

Opening my IIS Manager, the default web site showed a red cross. Trying to start it gave this error: "Unexpected Error 0x8ffe2740 Occurred".

At http://support.microsoft.com/default.aspx?scid=kb;en-us;816944 they say this is because the port 80 is used by another application. Voila, I installed yesterday Skype, it was hijacking port 80 !!!

So after uninstalling Skype all worked well again. :)
0
 
LVL 2

Expert Comment

by:AndreiPociu
ID: 13859507
Thanks AcelgaFrita, Skype was the problem here! I closed it and everything was back to normal :)
I don't think I would've ever figure it out...
0
 

Expert Comment

by:ascendit
ID: 14107340
aspnet_regiis.exe -i
has done for me !
Thanx
0
 

Expert Comment

by:kkkhandelwal
ID: 14168367
This problem may also be if you are having proxy setting in internet explorer. Remove the proxy setting, the things should become alright.
0
 

Expert Comment

by:Hachiihcah
ID: 14340154
I, too, was experiencing this problem peripherally with my hosting service. mclist's suggesting was a wonderful clue, and represents the real reason behind a good portion of the problems mentioned in this collaboration.

In general, it seems that Visual Studio .NET (in my case 2003) uses a simple HTML request to retrieve the version information of the .NET server on which a project resides. Anything that disrupts or distorts this request results in the error mentioned.  Here is a summary of the problems and their reasons:

1. .NET configuration issue - .NET was either not installed correctly, or conflicts with other .NET versions muddled the availability of .NET v1.1.....i.e. The server itself has the wrong answer to the version request. The most common solution seems to be "aspnet_regiis.exe -i" from the most current .NET framework's installation directory.

2. IIS configuration issue - If the version request reaches the server but is denied or ignored, then the same problem results. Evidentally, the HTML version request is for the file "~/get_aspx_ver.aspx" which may or may not exist on the server. This dummy request is not a problem unless the IIS server has the ("Check that file exists") setting for .aspx files. In this case, an error page is returned that hasn't been processed by .NET and thus has no version information. Solution: The server setting can either be turned off to avoid this problem, or a dummy "~/get_aspx_ver.aspx" file can be added to the user web folder.

3. Network configuration issue - If the network is not configured to allow an unaltered version request/response between client and server, the version test fails again. All standard networking issues apply here (IP addresses/netmasks/firewalls), but some other caveats are noted above. If there is a proxy server used that doesn't have an appropriate version of .NET installed, then the version request/response headers may be altered and fail the test. Solution: Disable proxy servers for local servers.

4. Port issue - If another application (ala skype) is hijacking ports that are needed for communcation (client or server side), then again the version request/response will fail. Solution: Seek and remove the hijackers.
0
 

Expert Comment

by:johnjore
ID: 14901599
the aspnet_regiis -i fixed it for me too. (Crappy product...)
0
 

Expert Comment

by:kalabogg
ID: 14910793

aspnet_regiis -i.. it helps a lot for me.. thanks for this great information..

ALSO, if u are using a proxy server in ur IE. please do remove the proxy settings in your browser to completely solve this problem.

0
 

Expert Comment

by:clsimeone
ID: 15024345
If you get the error "The Specified Web Server Is Not Running ASP.NET Version 1.1" and aspnet_regiis with either the -i or -s or -r flags does not solve the problem, then the issue is probably the ASP.NET 1.1 framework was installed before IIS was installed. This has happend to me and the following solved the problem...

1. uninstall asp.net 1.1 framework and it related service pack
2. reboot
3. reinstall asp.net 1.1 framework and it related service pack
4. reboot.

You should be good to go!
Chris
0
 

Expert Comment

by:Brainfour
ID: 15058793
For those where aspnet_regiis -i did not work and has Skype installed.
Skype has an option (under Tools-Options-Connection) as "Use port 80 and 443 as alternatives for incoming connections". (Default ON) Deselect it and problem solved.
0
 
LVL 3

Expert Comment

by:3abqari
ID: 22628440
Thank you LoveToSpod,

Your solution solved it for me, I posted my own thread (http://www.experts-exchange.com/Programming/Languages/.NET/Visual_Studio_.NET_2005/Q_23778915.html) similar to this thread since all others didn't help until I found this one. I followed your instructions and it worked.

Now, I don't have to tell my boss to buy me a new computer :)

I wish your solution could be posted as a solution to this Error.
0
 

Expert Comment

by:LoveToSpod
ID: 22640323
3abqari - I'm glad this helped you! Thanks for letting me know. It seems obvious in retrospect, but at the time I felt I had tried everything a few times over! All the best with whatever you are working on now.

LoveToSpod
0

Featured Post

Free Trending Threat Insights Every Day

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

Join & Write a Comment

Suggested Solutions

Welcome my friends to the second instalment and follow-up to our Minify and Concatenate Your Scripts and Stylesheets (http://www.experts-exchange.com/Programming/Languages/.NET/ASP.NET/A_4334-Minify-and-Concatenate-Your-Scripts-and-Stylesheets.html)…
In my previous article (http://www.experts-exchange.com/Programming/Languages/.NET/.NET_Framework_3.x/A_4362-Serialization-in-NET-1.html) we saw the basics of serialization and how types/objects can be serialized to Binary format. In this blog we wi…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
When you create an app prototype with Adobe XD, you can insert system screens -- sharing or Control Center, for example -- with just a few clicks. This video shows you how. You can take the full course on Experts Exchange at http://bit.ly/XDcourse.

705 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

17 Experts available now in Live!

Get 1:1 Help Now