Solved

Cisco 97 IPSec pass-through configuration for the Nortel VPN client

Posted on 2003-10-21
4
943 Views
Last Modified: 2008-02-26
Hello Colleagues. I got stuck on Cisco 97 IPSec pass-through configuration for the Nortel VPN client. Currently I have few computers behind the Cisco 97 box so I have to use dynamic NAT. Cisco box is currently configured for the 24/7 VPN connection with main office and works excellent. (I have PIX over there)
Problem is that we need to be able to connect to the totally deferent organization by using Nortel VPN client installed on one of the PCs. I tried to configure access list and NAT but no luck. No help from Cisco as well.
Does anyone know how to make it work?
Here is current config:
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname cisco
!
no logging buffered
enable secret 5 XXXXX
!
username cisco password 7 XXXXXX
username all
username XXXXX password 7 XXXXXX
ip subnet-zero
ip name-server 204.60.203.179
ip name-server 66.73.20.40
ip dhcp excluded-address 192.168.253.1
!
ip dhcp pool CLIENT
   import all
   network 192.168.253.0 255.255.255.0
   default-router 192.168.253.1
   domain-name domain.com
   netbios-name-server 172.20.1.5 172.20.3.6
   dns-server 172.20.1.5 172.20.3.6 204.60.203.179 66.73.20.40
   lease 0 2
!
ip inspect name firewall udp
ip inspect name firewall tcp
ip inspect name firewall ftp
!
crypto isakmp policy 1
 encr 3des
 authentication pre-share
 group 2
crypto isakmp key XXXXX address 208.169.48.218
crypto isakmp keepalive 30 5
!
!
crypto ipsec transform-set strong esp-des esp-md5-hmac
crypto ipsec df-bit clear
!
crypto map mymap 1 ipsec-isakmp
 set peer 208.169.48.218
 set transform-set strong
 match address 100
!
!
!
!
interface Ethernet0
 ip address 192.168.253.1 255.255.255.0
 ip nat inside
 ip tcp adjust-mss 1300
 shutdown
 hold-queue 100 out
!
interface ATM0
 no ip address
 shutdown
 atm vc-per-vp 64
 no atm ilmi-keepalive
 pvc 0/35
  pppoe-client dial-pool-number 1
 !
 dsl operating-mode auto
 dsl power-cutback 30
!
interface Dialer1
 ip address negotiated
 ip access-group 150 in
 ip mtu 1492
 ip nat outside
 ip inspect firewall out
 encapsulation ppp
 no ip route-cache
 ip tcp adjust-mss 1452
 no ip mroute-cache
 dialer pool 1
 dialer remote-name redback
 dialer-group 1
 ppp authentication pap chap callin
 ppp chap hostname XXXXXX
 ppp chap password 7 XXXXXX
 ppp pap sent-username XXXXXX password 7 XXXXXXX
 ppp ipcp dns request
 ppp ipcp wins request
 crypto map mymap
!
ip nat inside source list 120 interface Dialer1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
ip http server
!
access-list 100 permit ip 192.168.253.0 0.0.0.255 192.168.0.0 0.0.255.255
access-list 100 permit ip 192.168.253.0 0.0.0.255 172.20.0.0 0.0.255.255
access-list 120 deny   ip 192.168.253.0 0.0.0.255 192.168.0.0 0.0.255.255
access-list 120 deny   ip 192.168.253.0 0.0.0.255 172.20.0.0 0.0.255.255
access-list 120 permit ip 192.168.253.0 0.0.0.255 any
access-list 150 permit udp any any eq bootps
access-list 150 permit udp any any eq bootpc
access-list 150 permit icmp any any echo-reply
access-list 150 permit icmp any any unreachable
access-list 150 permit icmp any any time-exceeded
access-list 150 permit icmp any any time-exceeded
access-list 150 permit esp host 208.169.48.218 any
access-list 150 permit ip 192.168.0.0 0.0.255.255 192.168.253.0 0.0.0.255
access-list 150 permit ip 172.20.0.0 0.0.255.255 192.168.253.0 0.0.0.255
access-list 150 permit tcp any any eq telnet
access-list 150 permit ahp host 170.77.9.3 any
access-list 150 permit esp host 170.77.9.3 any
access-list 150 permit udp host 170.77.9.3 any
dialer-list 1 protocol ip permit
!
line con 0
 exec-timeout 120 0
 no modem enable
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 exec-timeout 120 0
 login local
 length 0
!
scheduler max-task-time 5000
end

0
Comment
Question by:ogaltson
4 Comments
 

Author Comment

by:ogaltson
ID: 9599423
Cisco Internetwork Operating System Software
IOS (tm) SOHO97 Software (SOHO97-K9OY1-M), Version 12.2(8)YN, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)
Synched to technology version 12.2(11.2u)T
TAC Support: http://www.cisco.com/tac
Copyright (c) 1986-2002 by cisco Systems, Inc.
Compiled Wed 30-Oct-02 21:49 by ealyon
Image text-base: 0x800131B0, data-base: 0x8074BDE4
ROM: System Bootstrap, Version 12.2(8r)YN, RELEASE SOFTWARE (fc1)
ROM: SOHO97 Software (SOHO97-K9OY1-M), Version 12.2(8)YN, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)
cisco uptime is 1 hour, 51 minutes
System returned to ROM by power-on
System image file is "flash:soho97-k9oy1-mz.122-8.YN.bin"
CISCO SOHO97 (MPC857DSL) processor (revision 0x400) with 29492K/3276K bytes of memory.
Processor board ID AMB072601EP (2533480144), with hardware revision 0000
CPU rev number 7
Bridging software.
1 Ethernet/IEEE 802.3 interface(s)
1 ATM network interface(s)
128K bytes of non-volatile configuration memory.
8192K bytes of processor board System flash (Read/Write)
2048K bytes of processor board Web flash (Read/Write)
Configuration register is 0x2102
0
 
LVL 11

Accepted Solution

by:
ewtaylor earned 500 total points
ID: 9608999
This modem is supposed to allow multiple NAT clients to connect with ipsec software. Here is how to enable this feature, if you need a look at a config http://www.cisco.com/en/US/products/hw/routers/ps380/products_configuration_guide_chapter09186a0080118cbb.html#45065 if this does not work let me know.

Configuring VPN IPSec Support Through NAT
This feature is available on the following Cisco routers:

Cisco 826 and Cisco 836
Cisco 827, Cisco 827H, Cisco 827-4V, Cisco 831, and Cisco 837
Cisco 828
Cisco SOHO 77, Cisco SOHO 78, Cisco SOHO 96, and Cisco SOHO 97
Cisco IOS Release 12.2(2)XI NAT supports IP Security (IPSec) client software that does not use Transmission Control Protocol (TCP) wrapping or User Datagram Protocol (UDP) wrapping. On Cisco routers, this feature allows the simultaneous use of multiple, PC-based IPSec clients on which IPSec packet wrapping is disabled or is not supported. When PCs connected to the router create an IPSec tunnel, network address translation (NAT) on the router translates the private IP addresses in these packets to public IP addresses. This NAT feature also supports multiple Point-to-Point Tunnel Protocol (PPTP) sessions, which may be initiated by PCs with PPTP client software.

You must enter the following command in global configuration mode for this feature to work:

ip nat inside source list number interface BVI number overload
0

Featured Post

What Security Threats Are You Missing?

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

Join & Write a Comment

When you connect to your workplace's VPN, you may not notice that you are using your workplace's servers to serve up webpages.  This might be undesirable since the workplace can log all the places you've been.  It also might be very slow to load pag…
For a while, I have wanted to connect my HTC Incredible to my corporate network to take advantage of the phone's powerful capabilities. I searched online and came up with varied answers from "it won't work" to super complicated statements that I did…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

747 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now