Solved

Cisco 97 IPSec configuration for Nortel VPN client

Posted on 2003-10-21
4
766 Views
Last Modified: 2010-03-17
Hello Colleagues. I got stuck on Cisco 97 IPSec pass-through configuration for the Nortel VPN client. Currently I have few computers behind the Cisco 97 box so I have to use dynamic NAT. Cisco box is currently configured for the 24/7 VPN connection with main office and works excellent. (I have PIX over there)
Problem is that we need to be able to connect to the totally deferent organization by using Nortel VPN client installed on one of the PCs. I tried to configure access list and NAT but no luck. No help from Cisco as well.
Does anyone know how to make it work?
Here is current config:
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname cisco
!
no logging buffered
enable secret 5 XXXXX
!
username cisco password 7 XXXXXX
username all
username XXXXX password 7 XXXXXX
ip subnet-zero
ip name-server 204.60.203.179
ip name-server 66.73.20.40
ip dhcp excluded-address 192.168.253.1
!
ip dhcp pool CLIENT
   import all
   network 192.168.253.0 255.255.255.0
   default-router 192.168.253.1
   domain-name domain.com
   netbios-name-server 172.20.1.5 172.20.3.6
   dns-server 172.20.1.5 172.20.3.6 204.60.203.179 66.73.20.40
   lease 0 2
!
ip inspect name firewall udp
ip inspect name firewall tcp
ip inspect name firewall ftp
!
crypto isakmp policy 1
 encr 3des
 authentication pre-share
 group 2
crypto isakmp key XXXXX address 208.169.48.218
crypto isakmp keepalive 30 5
!
!
crypto ipsec transform-set strong esp-des esp-md5-hmac
crypto ipsec df-bit clear
!
crypto map mymap 1 ipsec-isakmp
 set peer 208.169.48.218
 set transform-set strong
 match address 100
!
!
!
!
interface Ethernet0
 ip address 192.168.253.1 255.255.255.0
 ip nat inside
 ip tcp adjust-mss 1300
 shutdown
 hold-queue 100 out
!
interface ATM0
 no ip address
 shutdown
 atm vc-per-vp 64
 no atm ilmi-keepalive
 pvc 0/35
  pppoe-client dial-pool-number 1
 !
 dsl operating-mode auto
 dsl power-cutback 30
!
interface Dialer1
 ip address negotiated
 ip access-group 150 in
 ip mtu 1492
 ip nat outside
 ip inspect firewall out
 encapsulation ppp
 no ip route-cache
 ip tcp adjust-mss 1452
 no ip mroute-cache
 dialer pool 1
 dialer remote-name redback
 dialer-group 1
 ppp authentication pap chap callin
 ppp chap hostname XXXXXX
 ppp chap password 7 XXXXXX
 ppp pap sent-username XXXXXX password 7 XXXXXXX
 ppp ipcp dns request
 ppp ipcp wins request
 crypto map mymap
!
ip nat inside source list 120 interface Dialer1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
ip http server
!
access-list 100 permit ip 192.168.253.0 0.0.0.255 192.168.0.0 0.0.255.255
access-list 100 permit ip 192.168.253.0 0.0.0.255 172.20.0.0 0.0.255.255
access-list 120 deny   ip 192.168.253.0 0.0.0.255 192.168.0.0 0.0.255.255
access-list 120 deny   ip 192.168.253.0 0.0.0.255 172.20.0.0 0.0.255.255
access-list 120 permit ip 192.168.253.0 0.0.0.255 any
access-list 150 permit udp any any eq bootps
access-list 150 permit udp any any eq bootpc
access-list 150 permit icmp any any echo-reply
access-list 150 permit icmp any any unreachable
access-list 150 permit icmp any any time-exceeded
access-list 150 permit icmp any any time-exceeded
access-list 150 permit esp host 208.169.48.218 any
access-list 150 permit ip 192.168.0.0 0.0.255.255 192.168.253.0 0.0.0.255
access-list 150 permit ip 172.20.0.0 0.0.255.255 192.168.253.0 0.0.0.255
access-list 150 permit tcp any any eq telnet
access-list 150 permit ahp host 170.77.9.3 any
access-list 150 permit esp host 170.77.9.3 any
access-list 150 permit udp host 170.77.9.3 any
dialer-list 1 protocol ip permit
!
line con 0
 exec-timeout 120 0
 no modem enable
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 exec-timeout 120 0
 login local
 length 0
!
scheduler max-task-time 5000
end

0
Comment
Question by:ogaltson
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
4 Comments
 

Author Comment

by:ogaltson
ID: 9599415
Cisco Internetwork Operating System Software
IOS (tm) SOHO97 Software (SOHO97-K9OY1-M), Version 12.2(8)YN, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)
Synched to technology version 12.2(11.2u)T
TAC Support: http://www.cisco.com/tac
Copyright (c) 1986-2002 by cisco Systems, Inc.
Compiled Wed 30-Oct-02 21:49 by ealyon
Image text-base: 0x800131B0, data-base: 0x8074BDE4
ROM: System Bootstrap, Version 12.2(8r)YN, RELEASE SOFTWARE (fc1)
ROM: SOHO97 Software (SOHO97-K9OY1-M), Version 12.2(8)YN, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)
cisco uptime is 1 hour, 51 minutes
System returned to ROM by power-on
System image file is "flash:soho97-k9oy1-mz.122-8.YN.bin"
CISCO SOHO97 (MPC857DSL) processor (revision 0x400) with 29492K/3276K bytes of memory.
Processor board ID AMB072601EP (2533480144), with hardware revision 0000
CPU rev number 7
Bridging software.
1 Ethernet/IEEE 802.3 interface(s)
1 ATM network interface(s)
128K bytes of non-volatile configuration memory.
8192K bytes of processor board System flash (Read/Write)
2048K bytes of processor board Web flash (Read/Write)
Configuration register is 0x2102
0
 
LVL 3

Accepted Solution

by:
t1n0m3n earned 140 total points
ID: 9633817
There is no config needed on the cisco.

Tell the clients to enable IPSec over tcp and since you are using
ip inspect name firewall udp
ip inspect name firewall tcp
ip inspect firewall out (on the interface)

the return traffic will get let back in. (Isn't stateful firewall great???)

Be sure that not only the clients have IPSec over TCP enabled, but the Nortel Contivity VPN device on the other end has it enabled as well.

If you choose to put an access list 140 on the inside interface...the config needs to be modified like this :
access-list 140 permit tcp 192.168.253.0 0.0.0.255 host <ip address of the ContivityVPN box> eq 10000
access-list 140 permit udp 192.168.253.0 0.0.0.255 host <ip address of the ContivityVPN box> eq 500

By the way it looks like your ACL 120 may be goobered
are you wanting :
access-list 120 deny   ip 192.168.253.0 0.0.0.255 192.168.0.0 0.0.255.255
access-list 120 deny   ip 192.168.253.0 0.0.0.255 172.16.0.0 0.15.255.255
access-list 120 deny   ip 192.168.253.0 0.0.0.255 10.0.0.0 0.255.255.255
access-list 120 permit ip 192.168.253.0 0.0.0.255 any
Instead of what you have?  The above is your standard "don't nat RFC1918" stuff.
0

Featured Post

Free learning courses: Active Directory Deep Dive

Get a firm grasp on your IT environment when you learn Active Directory best practices with Veeam! Watch all, or choose any amount, of this three-part webinar series to improve your skills. From the basics to virtualization and backup, we got you covered.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

    Over the past few years, small business and home owners have become so dependent on internet that a need for redundancy has arisen.    What happens when your small business or home / home office loses its internet connection?  The results c…
Why do some people recommend buying business VoIP from an ISP? What are the benefits to my company? What are the costs?
If you’ve ever visited a web page and noticed a cool font that you really liked the look of, but couldn’t figure out which font it was so that you could use it for your own work, then this video is for you! In this Micro Tutorial, you'll learn yo…
This tutorial will teach you the special effect of super speed similar to the fictional character Wally West aka "The Flash" After Shake : http://www.videocopilot.net/presets/after_shake/ All lightning effects with instructions : http://www.mediaf…

623 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question