VMware in Redhat 9, cant install GCC

Ok here goes,

I am trying to install VMware onto my RedHat 9 machine.
I reed to compile my modules to get it to work.

My issue is however that I cannot seem to install GCC.
When I try to install it through the RPM manager I get the following error.

The following packages could not be found on your system, installation cannot continue.
krb5-libs = 1.2.7-10      krb5-devel
openssl = 0.9.7a-2      openssl-devel

So, I guess i need to install these, any pointers on the quicket way to do this...
Thanks,


LVL 1
mrorangeAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

victorbxCommented:
paullamhkgCommented:
well it's better to use the RH up2date program to update most of your application in your RH linux because it can update your application into the correct path or directory, the up2date info have a look here http://rhn.redhat.com/help/basic/up2date-config.html

and I think even the GCC redhat up2date will do for you.
paullamhkgCommented:
Also you will not have the dependencies error.
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

GnsCommented:
Problem is a slight "catch 22":
Install system with openssl and krb5-libs but without the corresponding -devel packages,
run up2date (or similar) which will update the installed packages,
and then try install the development system (that will depend on the -devel packages) in the Add/remove promgram...
Which fails since the packages for -devel it knows are a missmatch for the ones updated to.
Solution is (as victorbx says) to get the the packages and install them manually.
Download from your closest redhat ftp mirror (or either http://ftp.redhat.com/pub/redhat/linux/updates/9/en/os/i386/ or ftp://ftp.redhat.com/pub/redhat/linux/updates/9/en/os/i386/), and install with
rpm -ivh <package file names>

-- Glenn
heskyttbergCommented:
Hi!

You could also just simply do the following:
rpm -ivh --nodeps gcc-x.x.x.ixxx.rpm

This is not the best solution, but if you are sure all other pakcages are ok and gcc should work this is how you install it anyway.

Regards
/Hasse
GnsCommented:
As can be seen above, all packages aren't Hasse... Not that it'd matter much. Fixing the dependency would probably be best though... No rpm database inconsitencies lurking in the shadows, primed to bite your thumb at the least opportune moment:-).

-- Glenn
GnsCommented:
"As can be seen above, all packages aren't Hasse" ... Well, let's hope they aren't Hasse, all of them... Should have read
"As can be seen above all packages aren't, Hasse" ...

-- Glenn (a.k.a. Le Grand Typo)
mrorangeAuthor Commented:
Hi all, sorry I took a holiday for a week or so there... ok... i tried to run the update but no cigar...
I will try to install manually and let you know how i get on...
mrorangeAuthor Commented:
OK all here is the update.

I now need to install openssl 0.97a-2

i have tried to install openssl-0.9.7a-2.i386.rpm

but get the following error

package openssl-0.9.7a-20 (which is newer than openssl-0.9.7a-2) is already installed
        file /lib/libcrypto.so.0.9.7a from install of openssl-0.9.7a-2 conflicts with file from package openssl-0.9.7a-20

This error continues for a while... so any suggestions :-S

cheers
mrorangeAuthor Commented:
ok sorted the last issue  by insyalling gcc-3.2.2-5.i386.rpm

when i  now run the vmware-config.pl
i am asked the following

What is the location of the directory of C header files that match your running
kernel? [/usr/src/linux/include]

OK where would I find these files :-S


Cheers all
victorbxCommented:

follow this instructions , it will solve your issue !!!

http://www.ic.sunysb.edu/Stu/asmirnov/misc/vmware.htm

good luck

victor

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
mrorangeAuthor Commented:
Cheers Victor, between the www.rpmfind.net and the suggested website i have now got Vmware installed.

I have a few issues tring to install a Virtual Machine but I will start a new thread for that...


Thanks all.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Installation

From novice to tech pro — start learning today.