FrontPage 2000 Server Extensions

5thcav
5thcav used Ask the Experts™
on
I can't take it no more!

i keep messing up my FrontPage Server Extensions on my hosting server at readyhosting.com.

i cant understand how i can keep messing them up and then being forced to have them fix them. the way i see it if i can mess it up i should be able to fix them!

what steps and or files/folders do i need to self recover.

http://www.hopctech.com/Contact_Us.htm

Thanks

Im paying 500 points only becouse My brain hurts and i cant take anymore self feed input
i could learn something more then i need and PLOOWWWWW there goes half my brains all over my clean keyboard from an overload. :)
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Top Expert 2004

Commented:
Okay, well that completely cracked me up. I needed that.

There could be a number of things that you're doing that's causing either the extensions to break or the components in your pages not to function.

1. Are you using FTP?  If, yes, stop doing that....

2. When you try to open your web with FrontPage, are you getting the dreaded "Frontpage Server Extensions are not installed" error message?

3. You're working on your site locally, and then publishing the content to the live site, correct?

4. The Contact Us page link you quoted has a bad file structure in the form code:

u-file="unsaved:///_private/feedback.txt"

This should be:
u-file="_private/feedback.txt"

It's possible that just changing that filename will clear up the [FrontPage Save Results Component] error

Let me know - and keep that keyboard clean.

Author

Commented:
No good.

Ive used DreamweverMX 2004, FP2003, FlashFTP, edited realtime in FP and im also seeing FPExtensions are not installed

I even created and new subweb and copied the _folders over to try and fix it, FP wont allow me to create a site at http:\\www.hopctech.com only http:\\www.hopctech.com\html\{newname}

why wont just copying new extensions make it work? maybe im not copying the right ones?

Author

Commented:
i just made this site and it works
http://www.hopctech.com/new
Learn SQL Server Core 2016

This course will introduce you to SQL Server Core 2016, as well as teach you about SSMS, data tools, installation, server configuration, using Management Studio, and writing and executing queries.

Author

Commented:
just replaced the non working one with the good one and it dosnt work.. i feel the left side of my head pushing out,, grin

Author

Commented:
i suppose i can just make a link to the new folder and call that feedback form but it wont answer my question.

shouldnt just moving the folders from the NEW site folder to my main site correct the trouble?

Top Expert 2004

Commented:
If you've used FlashFTP, then you need to re-install the extensions. FTP will destroy them.

>>shouldnt just moving the folders from the NEW site folder to my main site correct the trouble?
Not necessarily. If they've been damaged, they may need to be reset - either through your own hosting control panel - or by them.

Let me have another look at your form in the meantime, I'll check back to see if you're still alive in the morning - 11:00pm here....
Check out:  http://www.hopctech.com/_vti_inf.html

If the FP extensions are installed correctly, you should get this message:
FrontPage Configuration Information
In the HTML comments, this page contains configuration information that the FrontPage Explorer and FrontPage Editor need to communicate with the FrontPage server extensions installed on this web server. Do not delete this page.

but as you see you do not.  

I would recommend maybe using includes instead of the frames & maybe using Jmail - that might be better for you?  But if you are connecting at any point via FTP - you can corrupt the extensions.  Another thing - you say you are using FP extensions 2000, but yet you are creating in FP 2003?  This also might be causing a problem.  I would say that you should be able to use FP extensions 2002 & FP 2000, but FP extensions 2000 & FP 2003, you might be running into a compatibility issue.

-Corey
Top Expert 2004

Commented:
For now, change this:

<form method="POST" action="_derived/nortbots.htm" webbot-action="--WEBBOT-SELF--" onSubmit="location.href='_derived/nortbots.htm';return false;" webbot-onSubmit>
<!--webbot bot="SaveResults" u-file="_private/feedback.txt" s-format="TEXT/TSV" s-label-fields="TRUE" s-builtin-fields="Date Time REMOTE_NAME REMOTE_USER HTTP_USER_AGENT" s-form-fields S-Email-Address="rtarcey@hopctech.com" S-Email-Format="TEXT/PRE" startspan --><input TYPE="hidden" NAME="VTI-GROUP" VALUE="0"><!--webbot bot="SaveResults" endspan i-checksum="43374" -->

to this:

<form method="POST" action="--WEBBOT-SELF--" onSubmit="">
<!--webbot bot="SaveResults" startspan U-File="_private/feedback.txt" s-Format="TEXT/CSV" s-label-fields="TRUE" s-builtin-fields="Date Time REMOTE_NAME REMOTE_USER HTTP_USER_AGENT" s-form-fields S-Email-Address="rtarcey@hopctech.com" S-Email-Format="TEXT/PRE" --><input TYPE="hidden" NAME="VTI-GROUP" VALUE="0"><!--webbot bot="SaveResults" endspan -->
Ah you're awake. :)  I thought maybe you fell asleep, George  :P

I was looking at all that, but I learned better that to fix that...

-Corey

Author

Commented:
im made  a sub web contact with Contact_Us.htm and disc2_frm.htm that work fine.

as soon as i import any thing into my root that form fails.

should i just call these from the contact folder after changing the graphics.

still dont know why it works there but not in the root.

Author

Commented:
ok im getting closer to knowing less,,, hahaha

when editing the new Contact folder from the main frontpage site the forms fail.

when reEditing the same file from the Contact site it fixes it.

i can link from the main to the contact and it works.

My Adds are comming out tommorow and i need a feedback working, even if from the contact folder.

im changing the site to ASP.NET sometime next month so im not to worried. i would still like to know whats happing with this.

TIA

Top Expert 2004

Commented:
The contact us page seems to be okay... do you want me to do a test submit?

http://www.hopctech.com/Contact_Us.htm

Author

Commented:
Hello

I was feeling lonely. i thought you would have been up at 5am getting back to work on this!!,, lol

i created a new website in FrontPage in a sub folder. Its real-time edits

Though my main site still wont run anything.

If i edit the sub site/folder from the Main site it fails

When I edit and post it from the subsite it works again.

Where are these extensions?
Try to go to this site - http://support.microsoft.com/default.aspx?scid=kb;en-us;300543&Product=fp10se - download FP 2002 extensions.  See if that helps.  

When you move it - are you moving these files in FP or are you moving them via internet explorer?

-Corey
Top Expert 2004

Commented:
Neither of these pages appear to exist - have you created them?

http://www.hopctech.com/confirmation.html
http://www.hopctech.com/Contact/confirmation.html

Your host - at the moment - only supports the 2000 extensions. You're not using anything in the site that requires you to upgrade, so I'd probably leave it for now...

Author

Commented:


>Try to go to this site - http://support.microsoft.com/default.aspx?scid=kb;en->us;300543&Product=fp10se - download FP 2002 extensions.  See if that >helps.  

This will only set my IIS5 not the remote server

>http://www.hopctech.com/confirmation.html
>http://www.hopctech.com/Contact/confirmation.html

i havnt created a confermation page yet

i want to upgrade to ASP.NET to Flex my MCAD cert and kill  2,000 hours.

i thought FP ext. we just files placed on the server?(i guess not)

If i goback to the first question; how do i get the correct files back into the root of my website without bothering my hosting company?


Top Expert 2004

Commented:
AFAIK, you can't get the extensions running by simply copying files.

If you want to email me your acces info for FP, I may be able to see what's going on at your host.
Ah ok - sorry I thought you were hosting it.  

-Corey

Author

Commented:
on the way george, dont give the information to coreybryant he looks like a shifty one.  grin
Ah shucks.  I thought I was being sneaky about it :P  I'll work harder on that.

-Corey

Author

Commented:
i hope your not spending all this time trying to see whats up.

remember i'll be changing to that ASP server soon.
Top Expert 2004

Commented:
Well, actually I haven't received the email in hotmail yet - probably something up with their email server.

Can I contact you here?
rtarcey@hopctech.com

Author

Commented:
sure

icq? 2682053

Author

Commented:
rtracey@

not

rtarcey@

:)
Top Expert 2004

Commented:
Never received anything... hopefully you're okay now.

Author

Commented:
been waiting for you? lol,,,, sent it twice all ready,, thought you allready had a wearz site up my now,,, lol

Im changing to ASP .NET soon and the sub folder is handling the feedback form. so i think im all set.

it would still be nice to know why the root folder wont run the feedback.

So comes back to How can i rebuild the extensions when ever i want in the root space.

Top Expert 2004

Commented:
...it just arrived...
Can I post a test message from the form that is working at your site?

Author

Commented:
sure?
Top Expert 2004

Commented:
Both forms appear to work - apart from you not having a confirmation page as the code expects. Did you receive 2 emails?

Author

Commented:
both forms?,, well i'll be a monkeys uncle turned upside down and spanked up side the head

they both work,,, (*^&@%QQ*^&*%&**@(@*&@
Top Expert 2004

Commented:
So that simple change I made worked then.

Author

Commented:
ya right!,, grin,,, i just edited the page from the main site, uploaded it and it no longer works?

Author

Commented:
http://www.hopctech.com/Contact/Contact_Us.htm

still works

i pointed the left.htm back to http://www.hopctech.com/Contact_Us.htm after changing it to point to http://www.hopctech.com/Contact/confirmation.html witch is a contact_.us with red letters
Top Expert 2004

Commented:
>>uploaded it and it no longer works?

In what way - the email doesn't go through?
Top Expert 2004

Commented:
So you're saying that this page exists?
http://www.hopctech.com/Contact/confirmation.html

Author

Commented:
ya frontpage error and yes confirmastion is there

FrontPage Error.
User: please report details to this site's webmaster.


Webmaster: please see the server's application event log for more details.

Author

Commented:
i get the fpage error and i also get 2 messages!!

i sent only one of the forms below and recived two back in diffrent emails

*******************************************************************************
Name:            8
Title:           8
Company:         8
Address:         8
Address2:        8
City:            8
State:           8
Zip:             8
WorkPhone:       8
Fax:             8
email:           8
URL:             8
Interest1:       Web Design
Interest2:       Web Hosting
Interest3:      
Interest4:      
Interest5:      
Interest6:      
Interest7:      
blockoftime:     Choose One
Remote Name:     24.151.133.19
Remote User:    
HTTP User Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.1.4322)
Date:            23 Oct 2003
Time:            20:57:24

comments:

---
[This E-mail scanned for viruses by Declude Virus]




*******************************************************************************
Name:            8
Title:           8
Company:         8
Address:         8
Address2:        8
City:            8
State:           8
Zip:             8
WorkPhone:       8
Fax:             8
email:           8
URL:             8
Interest1:       Web Design
Interest2:       Web Hosting
Interest3:      
Interest4:      
Interest5:      
Interest6:      
Interest7:      
blockoftime:     Choose One
Date:            10/23/2003
Time:            8:57:23 PM
Remote Name:     24.151.133.19
Remote User:    
HTTP User Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.1.4322)

comments:

---
[This E-mail scanned for viruses by Declude Virus]

Author

Commented:
one had this

blockoftime:     Choose One
Date:            10/23/2003
Time:            8:57:23 PM
Remote Name:     24.151.133.19
Remote User:    
HTTP User Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.1.4322)

comments:


the other had this in it

blockoftime:     Choose One
Remote Name:     24.151.133.19
Remote User:    
HTTP User Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.1.4322)
Date:            23 Oct 2003
Time:            20:57:24

comments
Top Expert 2004

Commented:
Top Expert 2004

Commented:
You need to setup the confirmation page correctly - the one there now is confirmation_gm.htm, but it needs to be formatted.

Author

Commented:
formatted?,,,

Top Expert 2004

Commented:
Laid out properly - names next to the form results, etc. If you test the form now, you'll see that the confirmation page is pretty unruly.

Run a test on the page now, and let me know that you received the email from the site, and we'll go from there.
Top Expert 2004

Commented:
For an example - go here:

http://www.hopctech.com/Contact_Us_gm.htm

Author

Commented:
3 Blocks Of Time (30 hours for $1,680)

Thats great! i can eat now!, Thank you


works fine, i see about the formatting,,, so what was going on?

Top Expert 2004

Commented:
Forgive me - it's once again time to sign off for the night - but I'm back at 5:30am to check in on you.
Top Expert 2004

Commented:
You can use the new page I created for you - just rename it over the existing confirmation.htm

>>so what was going on?

FP is finnicky. It expects to see certain things when posting a form to a confirmation page. I just made sure everything that had to be there, was there.

Author

Commented:
im a a a a a a scared to touch it,, lol,,,,

what a ball buster,,,,, so b4 u get paid,,, grin,,,,, the extensions were never messed up? there is no way to reset the extensions from my end if i ever had to?>
Top Expert 2004
Commented:
>> so b4 u get paid
I wish...

>>the extensions were never messed up
Correct.

>>there is no way to reset the extensions from my end?
Not unless it's an option in your control panel at readyhostying.com.

>>im a a a a a a scared to touch it
I can feel your pain :-)

Author

Commented:

Keep on the lookout for ASP .NET questions.. lol


Thanks for the help

My keyboard is still clean!, and the swelling is going down.
Top Expert 2004

Commented:
I look forward to the next round with alacrity.

Thanks again.
sounds like your isp / host is not keeping up with the fixes and is having troubles with fp extensions.  i host sites and have never had problems as you are describing.  front page ext are simple and they cant be messed up very easily.  
it could also be the code you have in your site, could you send a link to that so i can take a look?

john, joligario@recoverdata.com
Top Expert 2004

Commented:
Hi John.

Just a couple of things with regard to the forum here. You'll notice that the question has been answered, meaning that the problem has been solved at that point. Also, please don't post your email address here, all discussions need to take place in this thread.

Thanks,
GM

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial