Solved

MDAC prompts to allow data connections

Posted on 2003-10-22
5
909 Views
Last Modified: 2013-12-24
I have Frontpage 2003 and MDAC 2.8. When I add a OLAP Web Componet I'm continually prompted to allow the connection in both Frontpage and IE6. IE used to ask you if you wanted to allow then say add this site to youre list of secure site. Heres a MS KBN article. http://msdn.microsoft.com/library/default.asp?url=/library/en-us/ado270/htm/ado28_securitydcrs.asp

heres my messege."This Website uses a data provider that may be unsafe. If you trust the Website, click OK, otherwise click Cancel"

Has anyone found a way to remove this prompt?
t
0
Comment
Question by:troyavitia
5 Comments
 
LVL 31

Expert Comment

by:seanpowell
ID: 9600389
So what happens when you click OK?
0
 

Author Comment

by:troyavitia
ID: 9600418
It will allow you continue..but I want to eliminate the prompt. I was able to add the domain to the list of trusted sites (in IE6 settings) but when I access the site in FP I still get prompted
0
 
LVL 31

Expert Comment

by:seanpowell
ID: 9600521
Okay, sorry, I thought you meant that it continues to prompt even after clicking OK. I'm not aware of any way to remove the prompt from FP - other than rolling back to 2.7 :-(
0
 
LVL 1

Accepted Solution

by:
ErnestMcDuff earned 20 total points
ID: 10000123
My dear troyavitia,

I have had experienced the same problem.
Only I work wirh Access 2003. The problem occured when I upgraded from Office XP 2002 up to 2003. The reason behind this was, that when I wanted to open a data access page in Design View, it allmost took a full minute.
Strangely enough this did not happen with another page. So I compared the HTML of both pages, and I found out that there was a difference. The one who took a full minute to open, had as sourcepath to the database a string like: "C:\Documents and Settings\All Users\Documents" etc etc.

The one that did open in Design View very quickly had encoded: "\\Ernst\Documents"

So 1 page with a local path (takes bloody long to open), the otrher with a pathname according to UNC rules (quick).

Trying to find out what was happening why, I upgraded to 2003, but this did not do the trick. After I found out what was the reason (Hard Path vs UNC) I got stuck with EXACTLY the same warnings you got.

And I found the reason for this as well. The path to the solutions lays in the path itself (I sound like a Chinese philosopher....). When you give the page as source path a UNC pathname, like "\\Ernst\Documents" it will give you this error. In the connection strikng to the underlaying databse however, you need to specify this location with a UNC-pathname.

Conclusion: HTML-file needs as source path a localname pathname: "C:\Documents and Settings\All Users\Documents", the connection string to the underlaying database needs an UNC-name, like "\\Ernst\Documents".

Hopes this helps, at least I got rid of all these stupid warnings.

Ernest McDuff
0
 

Expert Comment

by:smandell
ID: 11932484
I found a slightly easier option. Just add the site to the trusted zone list in internet explorer. You can do this locally or through a GPO for everyone.

Steve
0

Featured Post

What Is Threat Intelligence?

Threat intelligence is often discussed, but rarely understood. Starting with a precise definition, along with clear business goals, is essential.

Join & Write a Comment

In this short web based tutorial, I wanted to show users how they can still use the powers of FrontPage in conjunction with Expression Web 3.  Even though Microsoft eliminated the use of Web components, we can still use them with FrontPage and edit …
Now that Expression Web 4.0 (http://www.microsoft.com/expression/products/Upgrade.aspx) is free if you buy or have the full version of Expression Web 3.0, now is the best time to  migrate from FrontPage to Expression Web (http://www.frontpage-to-exp…
The purpose of this video is to demonstrate how to reset a WordPress password if you are locked out and cannot reset the password. A typical use would be if you cannot access the email to which WordPress would send the password recovery email to…
The purpose of this video is to demonstrate how to set up the permalinks on a WordPress Website. This will be demonstrated using a Windows 8 PC. Go to your WordPress login page. This will look like the following: mywebsite.com/wp-login.php : Go t…

747 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now