How can I stop Visual Studio.NET 2002 from automatically reformatting my code (ASP and HTML) in the designer view?

Sometimes after taking great pains to indent my HTML and ASP.NET code properly, closing and re-opening the ASPX page causes the IDE to magically reformat  my tags and code the way it feels fit -- and sometimes the resultant tag and code placement is hard to read.  Is there an option setting to turn that feature off?

Thanks
TomscarbAsked:
Who is Participating?
 
boro_bobConnect With a Mentor Commented:
From the main menu select Tools>Options

In the dialog box that appears you get a folder menu on the left. Select Text Editor > HTML/XML > Format.
Uncheck the two tick boxes at the top that say When Saving Document and When Swicthing From Design To HTML/XML View.

That should do the trick!
0
 
TomscarbAuthor Commented:
Thanks a million, boro_bob!  Much appreciated.
0
 
kavitha_dCommented:
It is really a great tip.
0
 
KaitainHeavyIndustriesCommented:
Unfortuntaly that isn't truely the answer.  If you touch anything in design view, it will still mess up your code.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.