Denied all users from writing to a folder.

I was working with permissions on a shared folder on my Windows 2000 Pro machine and added a deny rule to restrict modifying the folder and all subfolders and files.  I didn't realize this would affect all users including the administrator and now I'm unable to modify anything, or to change these permissions now.  How can I remove the deny rule or hack around it?
triphoppAsked:
Who is Participating?
 
paulop1975Connect With a Mentor Commented:
Follow these instructions:

• Right-click the folder in question
• Choose Properties from the popup menu
• Go to the "Security" separator
• Click the "Advanced" button
• Go to the "Owner" separator
• Choose the "Administrator" user acount to be the owner of the folder.
• Apply new security settings (permissions) to the folder, including obviously the administrator--full control

Hope that helps you

Fui (portuguese for "gone")
c(^.^)o

pAul0|PIm3NTA
0
 
nader alkahtaniNetwork EngineerCommented:

uncheck DENY that beside Administrator then choose FULL CONTROL
0
 
VicTheDicCommented:
What you need to do is change ownership of the folder.

Right-Click on the folder and click on the Security Tab.
Then go to Advanced and then to the Owner tab. Change ownership to the Administrators group. Once you've taken ownership you'll be able to change settings.

Give your account Full Control and remove the 'Deny' check boxes from anywhere you don't need them.

Thing to remember, make sure to take ownership of all Files , Folders and Sub Folders.

- VicTheDic
0
 
loniiteCommented:
I think the points should be split.

- V
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.